1. Thanks for visiting! These forums are for the original Risk of Rain, if you're interested in discussing the newly released Risk of Rain 2 head over to that game's steam discussion forum
    Dismiss Notice

Bug reports for Risk of Rain 1.0.2

Discussion in 'General Discussion' started by needsomemiracle, Nov 11, 2013.

Thread Status:
Not open for further replies.
  1. needsomemiracle

    needsomemiracle Scruffy Nerf-Herder

    Backer reward, probably?
    • Treadlight

      Treadlight Existential Complex

      The Miner's 4th ability misses anything between him and the ground, rather than exploding on whatever enemies might be there.
      Yeah, probably.
      • lations

        lations Seal Broken

        I found a solution! Credit shouldn't go to me, since I saw a fan mention it on Twitter.
        The solution that works for me, is to turn off "GX" mode in the Asus Xonar driver panel. I've got a Xonar DX and turning this option off fixed the crashing and music for me!

        Edit: By the way, just to clarify, this is a fix for the crashing that inevitably happens once you enter the teleporter. It seems to only affect Xonar sound card users. The devs really need to communicate better and try and fix this issue, but in the meantime this is an easy solution - can somebody please add this to the Sticky thread so that others can see it easier?
          Last edited: Dec 3, 2013
        • DJFlare84

          DJFlare84 Spaceman Spiff

          I notice sometimes if you run into a step and then try to jump over it, the character only jumps straight upward instead, even if you are still holding down left/right to advance forward. This is only corrected by stepping away from the wall first. This can get you killed very quickly in a horde of monsters.
          • Cowey42

            Cowey42 Void-Bound Voyager

            I just unlocked the shield generator thing from HAN-D's achievement, and the padlock's still over the item in the items screen.

            After I quit the game and started it up again the next day, the padlock was gone.
              Last edited: Dec 4, 2013
            • Crown

              Crown Space Hobo

              Hey there! I've spent my whole night trying to unlock the sniper 10 consec kills with 1 hit. But it just doesn't unlock for me. I've tried doing it on every difficulty and on different stages as well. It just does not happen. I'm just gonna give it the benefit of doubt that I might not be doing something right but.

              Things i've tried:
              1. First time I attempted it I read somewhere you can hit other enemies as long as your bullet kills at least one. That didn't work
              2. I only targeted single enemies and one shot them each.
              3. I tried not to fire stray bullets into the air while doing it. (cos sometimes I miss the white bar on the reload and it bugs me)
              4. I tried it on all 3 difficulties.
              5. I've tried doing it on different stages thinking maybe I cant unlock it on the 1st stage.

              So is there something I'm not doing right?

              (Sorry I double posted in the old thread)
                somefatcracker likes this.
              • saintx18

                saintx18 Space Spelunker

                I think that Risk of Rain doesn't like Asus Xonar cards much. My sound keeps dying and locking up. The sound goes out mid way through my game session and I'm unable to access the options when this occurs. After death when trying to exit the game everything locks up and begins to freeze, causing a very annoying sound loop indicating that my sound card has crashed as well, I've already uninstalled/reinstalled everything twice. So for now when I play im just going to use my On Board sound card. If it's possible to be fixed I would very much appreciate it because I enjoy using my Xonar card to play this game because I can change effects and make it sound differently. Other than that I don't experience many other problems. I also faced this same exact problem when playing the beta on multiple occasions.

                Or maybe its the other way around, and the Asus Xonar's software is unfriendly with Risk of Rain?

                That doesn't seem to help me. I never have GX mode on. Perhaps there's other settings that need to be changed as well.
                  Last edited: Dec 6, 2013
                • Atomic Emu

                  Atomic Emu Aquatic Astronaut

                  Playing online MP with my brother, only the host receives XP and gold from Archer Bugs.
                  • Brassqund

                    Brassqund Hard-To-Destroy Reptile

                    A strange bug...
                    First stage, easy difficulty with the huntress...
                    I start the teleporter, kill the first boss (Wandering Vagrant) and surprise, ERROR OCCURRED
                    and the boss start to drop infinite number of experience and money (9892$ when I finally die. :rofl:)
                    For some reason, I was stuck too...
                    Sans titre.png

                    It happens to me again...
                    huntress, second stage... normal creature.
                    Strange... the two time, that was after take the Chargefield Generator.
                    I'm gonna try again see if this is that item the cause of the bug.

                    Third time and... yeah, this is the chargefield generator which make me bugged.
                    I can play but I can't take that object or that make that bug once I kill a monster.

                    second picture
                      Last edited: Dec 7, 2013
                    • Flonk

                      Flonk Space Hobo

                      Me and a friend just played a game over the internet.
                      While fighting Providence, my friend didn't pay attention to the purple circles and died.
                      I defeated him, but when I tried to leave the planet, I couldn't activate the computer.
                      It said 'Press "v" to leave the planet', but when I tried, I'd hear the sound that plays when
                      you can't afford to open a chest. In fact, I couldn't activate anything; the last thing I
                      remember successfully pressing "v" on was a broken drone after I defeated Providence.
                      I dunno.

                      The main thing I wanted to report though is that, when I left the game as a consequence,
                      the host was stuck ingame and had to leave via pressing Esc, when he probably should
                      have received a game over screen. I suppose that is because you don't actually check
                      if the remaining party is still alive if someone leaves the game.
                      • Penwize

                        Penwize Void-Bound Voyager

                        Interesting game-ending bug. Maybe from the latest update?

                        Playing as Mercenary on rainstorm difficulty, struggling through the Magma Barracks. I killed a Cremator and almost died of happiness when it dropped a Chargefield Generator. I got my grubby hands on it and immediately killed a bison next to me. Which is when my controls locked up, the bison exploded (Will-o'-the-Wisp style) straight up into the top of the screen and started raining down millions of dollars and experience points. And wouldn't stop. I went from level 16 to level 19 in about one second while my frame rate plummeted to a stout 15.

                        Very bemused, I watched the spectacle develop. More enemies spawned and attacked the motionless Mercenary but he was leveling so fast that he couldn't be killed. Enemies slowly died and they followed the first bison's example and became eternal fountains of fortune at the top of the screen.

                          Attached Files:

                        • Brassqund

                          Brassqund Hard-To-Destroy Reptile

                          Exactly like me... freaking Chargefield Generator, making us rich and paralyzed :rofl:
                          • joey4track

                            joey4track Ketchup Robot

                            Hopefully we will get a hotfix for this seeing as how it's pretty game breaking. If not I am going back to 1.0.1... if i can figure out how to :/
                            • needsomemiracle

                              needsomemiracle Scruffy Nerf-Herder

                              I don't think you can if you're playing via Steam. It's logical, from the system's point of view, to always keep your game up to date, isn't it?

                              Also, OP updated with info from 1.0.2. If you haven't seen it, go here: http://riskofraingame.com/risk-of-rain-patch-v1-0-2/
                              This is now a 1.0.2 bug thread.
                                Last edited: Dec 8, 2013
                              • Chthonic One

                                Chthonic One Aquatic Astronaut

                                Clearly this is revenge from Ifrit for denying him the ability to Moonwalk.
                                  Brassqund likes this.
                                • joey4track

                                  joey4track Ketchup Robot

                                  It's only logical if the newer version is more stable than the last but at this point the last version is more stable. I might be able to use the executable from my humble version and replace the steam exe maybe? I dunno, but that's usually how RoR updates go- one step forward, two steps back haha <jk>
                                  • needsomemiracle

                                    needsomemiracle Scruffy Nerf-Herder

                                    Sure, but everyone understands Steam can't keep track of quality changes of every update of every game, so this responsibility falls on the developer, with the distribution system always assuming a later version to be better in some way than an earlier one.

                                    Also, people who are better at this game than me, please check if having 72+ unique items is in any way bugged. We know it doesn't crash the game anymore, but it still might screw up your movement and make the character invisible.
                                    • SerratedSabre

                                      SerratedSabre Void-Bound Voyager

                                      I noticed a quirk in Providence's HP formula. Usually when I play single player, his HP tends to be around 55k-60k rather consistently. However, in mutiplayer, his HP is more consistently around the 25k-30k mark, with values as low as 22k, and as high as 32k. I know his HP is determined by time (or as least I think it is), so I'm kind of curious at the discrepancy, as I don't think the average time to get to Providence accounts for such a drastic change in his HP. Of course, I noted this in 1.0.1, so now I'm probably going to beat him in both modes again to be sure, or I could just snipe twitch streams.
                                      • lvv

                                        lvv Space Hobo


                                        When I try to start the game through steam I get the error "Failed to initialize D3DX." When I try to run the .exe (as admin) I get the error "Access violation at address 59A9D248 in module 'Steam_GM.dll'. Read of address 00000000." (the first number changes each time) followed by "Unexpected error occured when running the game.", followed by the application closing.

                                        I've run the repair on the vcredist file, I've updated my videocard drivers and updated .net framework. Still no luck. I'm running windows 7, and I've heard that a common issue with this game might be the fact that my game is installed on the same partition as my OS, which is something stupid I can't really do anything about at this point because I only have that one partition. Regardless, I haven't had that issue with any other games or programs.

                                        Has there been a fix for this yet or are the devs looking into this?
                                        • LadenSwallow

                                          LadenSwallow Void-Bound Voyager

                                          During online co-op mode, I as the host gained the benefit of ALL barbed wire pickups, whereas my team mate didn't gain the benefit of any he picked up.
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page