1.1 Beta Thread

Discussion in 'General Discussion' started by ConcernedApe, Sep 28, 2016.

  1. HarvestTroll

    HarvestTroll Tentacle Wrangler

    Summary of issue: Shane speaks a non fitting speech in the Saloon.

    Expected Behavior: The speech fits the place and time.

    Actual Behavior:
    Shane says "I'll definitely be going to the Saloon tonight" while already at the Saloon past 7 : 00 PM

    Steps to reproduce:
    Talk to Shane at night at the Saloon (at 7 hearts).

    Operating System:
    Windows 10 Home 64 bits.

    Edit :
    Summary of issue: Mummies killed in the Skull Mines continue to move when they should be incapacitated.

    Expected Behavior: Mummies stay on the ground for a while before "resurrecting".

    Actual Behavior:
    Once killed a Mummy may stay standing and moving, though not attacking. It will damage the player in contact and will still die with a bomb explosion.

    Steps to reproduce:
    Not sure yet. It seems to happens when either there are multiple mummies hit and "killed" at the same time, or it may be when the player "kills" the mummy while also hit by it at the same time.

    Operating System: Windows 10 Home 64 bits.
     
      Last edited: Oct 17, 2016
      ChaosAzeroth likes this.
    • Yaila

      Yaila Space Hobo

      Summary of issue:
      Game crashes when using a pickaxe/axe on a finished cask.
      Cask is placed in the basement with an iridium-class goat cheese in it, the pickaxe and axe are also iridium.

      Expected Behavior:
      Fancy goat cheese and cask on the floor.

      Actual Behavior:
      Not so fancy crashing of the game.

      Steps for Reproduction:
      Age some goat cheese and hack away at the cask.

      ... Tried restarting the game a few times and doing the same thing/using an axe instead of a pickaxe, crashed again.


      What Operating System are you using:
      Windows 10

      Sidenote:
      There's no problem in using the pickaxe or axe on an empty cask or a cask that's still in progress.
      Don't have anything other then goat cheese finished at the moment so can't tell if it goes for other items as well.
       
      • GhostlySilver

        GhostlySilver Void-Bound Voyager

        Summary of issue: While harvesting from a large amount of Coffee bean plants the character freezes and is unresponsive to any controls other than switching slots in the toolbar.

        Expected Behavior: No freezing, the ability to harvest coffee beans without freezing.

        Actual Behavior: Unresponsive character

        Steps for Reproduction: Harvesting large amount of coffee beans at once (with junimos)


        What Operating System are you using: Windows 10
         
          Last edited: Oct 21, 2016
        • Magistrella

          Magistrella Big Damn Hero

          Summary of issue: Can not plant a tree seed at shown location on the Forest Map.

          Expected Behavior: Should be able to plant a tree seed at this spot

          Actual Behavior: Error Message: Invalid Position

          Steps for Reproduction: Take a Tree Seed and try to plant it at said position

          What OS are you using: Windows 10

          [​IMG]
           
          • emilin_rose

            emilin_rose Poptop Tamer

            Summary of issue: all the new items don't have an image.

            Expected Behavior: there is an item with an image and a function(in some cases)
            Actual Behavior: no image, but function works
            Steps for Reproduction: buy new items/view in store

            What OS are you using: Windows 10

            I have a problem, they still take up space and can confirm the catalogues work as supposed to, but the graphic is missing. persists with multiple launches and just playing on in the game.

            anyone know how to fix?
             
            • emilin_rose

              emilin_rose Poptop Tamer

              Summary of issue: game crashes when checking mailbox
              Expected Behavior: read letter from someone
              Actual Behavior: game freezes
              Steps for Reproduction: read letter
              What OS are you using: Windows 10
               
              • Ladysarajane

                Ladysarajane Phantasmal Quasar

                Sounds like you might have some files missing are you using Steam?
                 
                • emilin_rose

                  emilin_rose Poptop Tamer

                  no. i got it from humble bundle. i don't like steam much, whenever its on i have trouble running games. takes too much memory.

                  I've tried re-installing it and have the same problems.
                   
                    Last edited: Nov 3, 2016
                  • Ladysarajane

                    Ladysarajane Phantasmal Quasar

                    Not familiar with Humble bundle, but with missing images and the mailbox problems, it sounds like an incomplete download. How much memory does your computer have?
                     
                    • emilin_rose

                      emilin_rose Poptop Tamer

                      64.8 gigabytes free, but i have trouble running stuff at the same time as steam. its probably more the total cpu than the memory that's the problem.

                      i just re-downloaded it and have the same problem.

                      Okay good news and bad news. Good news is i talked to my friend who let me use his GOG account to redownload and it seems to be working now. Bad news is for some reason whenever i run SMAPI, it runs the old version. tried fully uninstalling the game and am now reinstalling it hoping for the best.
                       
                        Last edited: Nov 3, 2016
                      • Ladysarajane

                        Ladysarajane Phantasmal Quasar

                        If you are still having trouble with Smapi, read and post in this topic Here :http://community.playstarbound.com/threads/dos-and-donts-of-reporting-issues-with-smapi-mods.125211/, Someone may be able to help you here with there. I have a couple ideas what it might be, but I need your log as described in that topic so I can guide you on it. If I am not on at that time, someone else can read that log and help. But if you have vanilla Stardew Valley running now that is a good step in the right direction. :) I never heard of Humble Bundle so I have no idea how you download from there, but I know that it did sound that something messed up your files. Now to get the mods back to working right.
                         
                        • emilin_rose

                          emilin_rose Poptop Tamer

                          Took some doing but i made it work. i also have another maybe bug but i don't think it has to do with missing files.

                          Summary of issue: unreachable foragables
                          Expected Behavior: follow the arrow, collect the item
                          Actual Behavior: cannot reach item
                          Steps for Reproduction: look for foragable items.
                          What OS are you using: Windows 10
                           
                          • crymblade

                            crymblade Void-Bound Voyager

                            The search bar hasn't been very helpful, but from what I understand this issue only started in 1.1

                            Summary of issue: Krobus talk glitch

                            Expected Behavior: You can talk to Krobus before shopping

                            Actual Behavior: Krobus is treated as already having been talked to, goes straight to shop

                            Steps for Reproduction: Start up stardew valley. Problem disappears after sleeping, but comes back every time stardew valley starts up.

                            What Operating System are you using: Windows 10
                             
                            • ChaosAzeroth

                              ChaosAzeroth Existential Complex

                              Actually this happened to me ALL THE TIME before 1.1.

                              Only it was random and unfixable.
                               
                              • Ambaaargh

                                Ambaaargh Hard-To-Destroy Reptile

                                (Prolly waaay late on this but I post it nonetheless :rofl:)

                                Summary of issue: Harvey's dialogue on Saturday (if you are married to him) when he comes back in from reading outside is the same when he returns from work on Tues/Thurs.

                                Expected Behavior: For him to say something about his day since he spent it comfortably reading out in his little book-nook.

                                Actual Behavior:
                                His dialogue around the evening time when he comes back in his him talking about being exhausted but at least his patients are healthy...basically using the same dialogue from when he leaves the house to work at the clinic.

                                Steps to reproduce:
                                Marry Harvey, Wait for a Saturday where he uses his little reading area, talk to him in the evening once he comes back in. (I'm currently in Spring, haven't seen what the other seasons do if anything yet)

                                Operating System:
                                Windows 10
                                 

                                Share This Page