1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/

Starbound has stopped working

Discussion in 'Support' started by powpowitsme, May 15, 2017.

  1. powpowitsme

    powpowitsme Void-Bound Voyager

    So recently, I decided I wanted to play starbound, as you might expect.
    I went to launch it, to be greeted by a white box in place of the chucklefish logo, and an error message saying
    "Starbound has stopped working".
    I don't have any mods either.
    I've tried reinstalling the game, launching from the exe, running in compatability mode, reinstalling Visual C++, updating graphics drivers, nothing's worked.
    My specs are as such:
    OS: Windows 10
    GPU: AMD Radeon R9 280x
    CPU: Intel Core i3-3240
    RAM: 16gb

    If I'm missing any important info, please let me know.


    [16:45:02.596] [Info] Root: Preparing Root...
    [16:45:02.598] [Info] Root: Done preparing Root.
    [16:45:02.598] [Info] Client Version 1.2.3b (windows i386) Source ID : 69bc1c906122a1c61453c6cff15aa088b613db78 Protocol: 729
    [16:45:02.599] [Info] Root: Scanning for asset sources in directory '..\assets\'
    [16:45:03.200] [Info] Root: Scanning for asset sources in directory '..\mods\'
    [16:45:03.200] [Warn] Root: Unrecognized file in asset directory 'mods_go_here', skipping
    [16:45:03.200] [Info] Root: Detected asset source named 'base' at '..\assets\packed.pak'
    [16:45:03.200] [Info] Root: Detected unnamed asset source at '..\assets\user'
    [16:45:03.200] [Info] Loading assets from: '..\assets\packed.pak'
    [16:45:03.850] [Info] Loading assets from: '..\assets\user'
    [16:45:05.157] [Info] Assets digest is 06cbcabd08c255b023a32ab90661887de878dffa9534c11a0de2b083efe882db
    [16:45:05.157] [Info] Root: Loaded Assets in 2.55902 seconds
    [16:45:05.165] [Info] Application: Initializing SDL Video
    [16:45:05.176] [Info] Application: Initializing SDL Joystick
    [16:45:05.376] [Info] Application: Initializing SDL Sound
    [16:45:05.547] [Info] Initialized Steam services
    [16:45:05.550] [Info] Application: Creating SDL Window
    [16:45:07.138] [Info] Application: Enabling VSync with late swap tearing
    [16:45:07.211] [Info] Application: Opened default audio device with 44.1khz / 16 bit stereo audio, 2048 sample size buffer
    [16:45:07.220] [Info] OpenGL version: '4.5.13474 Compatibility Profile Context 22.19.165.1' vendor: 'ATI Technologies Inc.' renderer: 'AMD Radeon R9 200 Series' shader: '4.50'
    [16:45:07.221] [Info] Application: initialization...
    [16:45:07.221] [Info] Root: no runtime config file, creating new default runtime config
    [16:45:07.221] [Info] Root: Loaded Configuration in 0.000262624 seconds
    [16:45:07.227] [Info] Application: renderer initialization...
    [16:45:07.232] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 128
    [16:45:07.233] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 64
    [16:45:07.236] [Info] Root: Loaded ImageMetadataDatabase in 3.31292e-06 seconds
    [16:45:07.268] [Info] Application: main update loop...
    [16:45:07.280] [Info] No subscribed user generated content
    [16:45:07.304] [Info] Root: Loaded NameGenerator in 0.0181506 seconds
    [16:45:07.536] [Error] Fatal Error: Access violation detected at 56FA62F9 (Read of address 00000008)
    [0] ab628a Star::captureStack
    [1] ab64c2 Star::fatalError
    [2] ab1de2 Star::SignalHandlerImpl::sehTrampoline
    [3] 5709cbab
    [4] 56f5a5f7
    [5] 56f5a678
    [6] 56f54c50
    [7] 56f5562c
    [8] 56f558dc
    [9] 56f60900
    [10] 5659cd24
    [11] 56625567
    [12] 566771c7
    [13] 56f472a1
    [14] 5642c8db
    [15] 5642c979
    [16] 5642cd1d
    [17] 6eec0ecf wglCopyContext
    [18] 6eecdfe7 wglSwapBuffers
    [19] 74257c38 GdiSwapBuffers
    [20] 74257d56 SwapBuffers
    [21] 6c80f59b SDL_LogCritical
    [22] 6c8038f4 SDL_LogCritical
    [23] 1006396 Star::runMainApplication
    [24] a22b9c WinMain
    [25] 11245e6 __scrt_common_main_seh
    [26] 740538f4 BaseThreadInitThunk
    [27] 77345de3 RtlUnicodeStringToInteger
    [28] 77345dae RtlUnicodeStringToInteger
    [16:45:07.545] [Info] Root: Loaded PlantDatabase in 0.240496 seconds
    [16:45:08.140] [Info] Root: Loaded ObjectDatabase in 0.853921 seconds
    [16:45:08.469] [Info] Root: Loaded ProjectileDatabase in 0.925098 seconds
    [16:45:08.627] [Info] Root: Loaded MonsterDatabase in 0.486833 seconds
    [16:45:08.630] [Info] Root: Loaded StagehandDatabase in 0.00293073 seconds
    [16:45:08.637] [Info] Root: Loaded VehicleDatabase in 0.00690533 seconds
    [16:45:08.643] [Info] Root: Loaded PlayerFactory in 0.00591025 seconds
    [16:45:08.687] [Info] Root: Loaded NpcDatabase in 0.217273 seconds
    [16:45:08.695] [Info] Root: Loaded VersioningDatabase in 0.00748479 seconds
    [16:45:08.695] [Info] Root: Loaded EntityFactory in 0.0515581 seconds
    [16:45:08.814] [Info] Root: Loaded ParticleDatabase in 0.119538 seconds



    [16:08:33.393] [Info] Root: Preparing Root...
    [16:08:33.396] [Info] Root: Done preparing Root.
    [16:08:33.396] [Info] Client Version 1.2.3b (windows x86_64) Source ID : 69bc1c906122a1c61453c6cff15aa088b613db78 Protocol: 729
    [16:08:33.396] [Info] Root: Scanning for asset sources in directory '..\assets\'
    [16:08:33.826] [Info] Root: Scanning for asset sources in directory '..\mods\'
    [16:08:33.827] [Warn] Root: Unrecognized file in asset directory 'mods_go_here', skipping
    [16:08:33.827] [Info] Root: Detected asset source named 'base' at '..\assets\packed.pak'
    [16:08:33.827] [Info] Root: Detected unnamed asset source at '..\assets\user'
    [16:08:33.827] [Info] Loading assets from: '..\assets\packed.pak'
    [16:08:34.318] [Info] Loading assets from: '..\assets\user'
    [16:08:35.438] [Info] Assets digest is 06cbcabd08c255b023a32ab90661887de878dffa9534c11a0de2b083efe882db
    [16:08:35.438] [Info] Root: Loaded Assets in 2.04273 seconds
    [16:08:35.445] [Info] Application: Initializing SDL Video
    [16:08:35.457] [Info] Application: Initializing SDL Joystick
    [16:08:35.621] [Info] Application: Initializing SDL Sound
    [16:08:35.755] [Info] Initialized Steam services
    [16:08:35.757] [Info] Application: Creating SDL Window
    [16:08:36.476] [Info] Application: Enabling VSync with late swap tearing
    [16:08:36.551] [Info] Application: Opened default audio device with 44.1khz / 16 bit stereo audio, 2048 sample size buffer
    [16:08:36.556] [Info] OpenGL version: '4.5.13474 Compatibility Profile Context 22.19.165.1' vendor: 'ATI Technologies Inc.' renderer: 'AMD Radeon R9 200 Series' shader: '4.50'
    [16:08:36.557] [Info] Application: initialization...
    [16:08:36.557] [Info] Root: no runtime config file, creating new default runtime config
    [16:08:36.557] [Info] Root: Loaded Configuration in 0.000198775 seconds
    [16:08:36.561] [Info] Application: renderer initialization...
    [16:08:36.564] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 128
    [16:08:36.564] [Info] detected supported OpenGL texture size 16384, using atlasNumCells 64
    [16:08:36.565] [Info] Root: Loaded ImageMetadataDatabase in 7.83054e-06 seconds
    [16:08:36.591] [Info] Application: main update loop...
    [16:08:36.602] [Info] No subscribed user generated content
    [16:08:36.619] [Info] Root: Loaded NameGenerator in 0.016061 seconds
    [16:08:36.620] [Error] OpenGL errors this frame: GL_INVALID_VALUE

     
    Last edited: May 15, 2017
  2. NexusTheBrony

    NexusTheBrony Phantasmal Quasar

    (asking b4 checking logs) do you have the Creator's Update for Windows 10? That seems to be the problem for many ppl
    (after logs) the only error that could've done something is the access violation, but thats common with 32 bit
     
    Last edited: May 17, 2017
  3. lazarus78

    lazarus78 The End of Time

    the "64bit log" doesn't seem to be a complete log.

    What are you basing this on?
     
  4. powpowitsme

    powpowitsme Void-Bound Voyager

    The 64-bit log was just that long. Not much I can do.
    I don't think I'm on the creator's update. I rarely update and my build version for W10 seems to be lower than that of the creator's update.
     
  5. powpowitsme

    powpowitsme Void-Bound Voyager

    Problem solved! Updating windows fixed it.
     
  6. NexusTheBrony

    NexusTheBrony Phantasmal Quasar

    fixed
     

Share This Page