1. Lose your pre-order key? Try using Humble's key resender. Also, please check the support FAQs before posting: http://playstarbound.com/help/
  2. Hey Guest! We've announced our new game Wargroove, check out the new forums!
    Dismiss Notice

How to fix [Error] Fatal Exception?

Discussion in 'Support' started by NovaZone, Mar 19, 2017 at 7:26 PM.

  1. NovaZone

    NovaZone Orbital Explorer

    I am having an error when I start up the game and I have located the error file that record it, it says (below) and then my game crashes before it started

    [14:16:06.173] [Error] Fatal Exception caught: (RendererException) OpenGL 2.0 not available!
    [0] 3d628a Star::captureStack
    [1] 3d51a8 Star::StarException::StarException
    [2] 929e2e Star::OpenGl20Renderer::OpenGl20Renderer
    [3] 923c47 std::make_shared<Star::OpenGl20Renderer>
    [4] 92438e Star::SdlPlatform::SdlPlatform
    [5] 926387 Star::runMainApplication
    [6] 342b9c WinMain
    [7] a445e6 __scrt_common_main_seh
    [8] 76168e94 BaseThreadInitThunk
    [9] 77b39bc3 RtlDestroyQueryDebugBuffer
    [10] 77b39b92 RtlDestroyQueryDebugBuffer
    Caught at:
    [0] 3d628a Star::captureStack
    [1] 3d678e Star::fatalException
    [2] 92641b Star::runMainApplication
    [3] 342b9c WinMain
    [4] a445e6 __scrt_common_main_seh
    [5] 76168e94 BaseThreadInitThunk
    [6] 77b39bc3 RtlDestroyQueryDebugBuffer
    [7] 77b39b92 RtlDestroyQueryDebugBuffer

    This is the file
     

    Attached Files:

    Last edited by a moderator: Mar 19, 2017 at 10:16 PM
  2. SleepySquidd

    SleepySquidd Tragically Magic Hands Forum Moderator

    Moved to the support sub forum :)
     
    Iris Blanche likes this.
  3. NexusTheBrony

    NexusTheBrony Void-Bound Voyager

    "OpenGL 2.0 not available!" Check if you have at least Open GL 2.0. if you don't your game will crash

    Minecraft requires OpenGl 2.1, so it may b goot to test with

    there are plenty of "What is my..." things online, so there should b 1 for Open GL
     
  4. Iris Blanche

    Iris Blanche Top Nep Forum Moderator

    What are your system specs in general? It seems your graphic chip is either not able to handle OpenGL 2.0 or you have to update your drivers.

    ~ Iris ~
     

Share This Page