1. When making a thread, please tag your thread accordingly using the menu to the left of the textfield where you name your thread where applicable. Server Advertisements and Mod Releases should be contained to their respective subforums.

Server Help Help creating a Starbound server! (Access violation error)

Discussion in 'Public Servers & Server Help' started by Putridmango, Dec 9, 2013.

Thread Status:
This thread is has not been replied to for more than 90 days.

Server Help Help creating a Starbound server! (Access violation error)

  1. Putridmango

    Putridmango Space Hobo

    So I have an ATT DSL connection. I tried Port forwarding 21025 AND running DMZ plus on my router. I have also tried using a static IP. Every time I try creating a server it gives me the error posted below after it says "Scanning for ports for port forwarding" on the cmd prompt. I have searched for hours on the forum and other sites with no resolve. Please help me! :(
    EDIT: It is important to not that is actually allowed me to create a server say.. 2 out of the 15 times I tried to make one? The server was fully functional and allowed my friend to join.

      Attached Files:

      Last edited: Dec 9, 2013
    • Putridmango

      Putridmango Space Hobo

    • gibbons

      gibbons Poptop Tamer

      What model of router do you use? Are you making sure the port forwarding is pointing towards your computers IP from the router and do you have any other protective software such as a firewall that may be blocking the game?
      • Putridmango

        Putridmango Space Hobo

        I am using an ATT 3801HGV router and yes the dmz plus is opened at my computer's IP. I used a port forwarding tool to check if the port is opened and both TCP and UDP are opened. I have made ingoing and outgoing rules on the firewall to allow port 21025.
        • gibbons

          gibbons Poptop Tamer

        • Putridmango

          Putridmango Space Hobo

          What would the application type be labeled under? a private network?
          • gibbons

            gibbons Poptop Tamer

            What are the options, im pretty sure that is just a label and doesn't actually attribute to anything, more for documentation / admin use
            • Putridmango

              Putridmango Space Hobo

              FTP,
              H.323-based internet telephony,
              DirectX Game
              IRC (Internet relay chat) server
              PPTP virtual private network server
              SIP-based internet telephony
              • Jammrock

                Jammrock Master Chief

                If you manually setup the port forwarding you need to turn off UPnP.

                Find this line in starbound\assets\default_configuration.config:

                "upnpPortForwarding" : true,

                ...and replace it with this line...

                "upnpPortForwarding" : false,
                  gibbons likes this.
                • gibbons

                  gibbons Poptop Tamer

                  Its not realy any of those, out of any of them i would choose DirectX game Virtual Private network server. Sorry i cant be of much more help without being there, American routers are far different to European ones, i Literally had to change 2 settings and i was hosting haha!
                  • Putridmango

                    Putridmango Space Hobo

                    Do I have to restart my computer for port forwarding changes to take effect? And haha it's okay.
                    • gibbons

                      gibbons Poptop Tamer

                      Is that not only if you are hosting via third party networking programs like Hamachi? If hes hosting through his router he would have to forward that port to his computer and the server would need to detect that the port is working. If you turn that feature off wouldnt it stop him from working all together?

                      I have manually set up my server with no configuration of the config files and i have manually set my port forwarding.
                      • I think he means disable upnp because this is causing actually a server crash (as the title mention access violation) but normally you shouldn't need to touch this option even if you manually forward

                        I have seen threads about this upnp option causing crashes
                          gibbons likes this.
                        • gibbons

                          gibbons Poptop Tamer

                          You should not have to restart the computer as the port forwarding happens on the router not the computer its self. all it does is redirect packets that come in on a certain port to a certain ip, in this case your computer.

                          Anyhow, its getting late here in the UK and i need my beauty sleep! Keep this post updated with your progress and if your still having problems tomorrow perhaps i can help sort your issues out remotely or by voice comm
                            dank sheet likes this.
                          • Putridmango

                            Putridmango Space Hobo

                            IT WORKED!!! Thanks everyone. I just disabled upnp and manually forwarded the port. The DMZ plus option seemed to not be working. Thank you!!! :) :)
                              dank sheet, class101 and gibbons like this.
                            • gibbons

                              gibbons Poptop Tamer

                              Haha glad to have been of little or no service! :) Good call Jammrock on the UPNP setting
                                class101 likes this.
                              • Putridmango

                                Putridmango Space Hobo

                                Haha yeah it didn't work when I turned upnp off when I dmz'd plus which is why i dismissed it as an option
                                • wsxdr50

                                  wsxdr50 Space Hobo

                                  Putridmango, I have the exact same router as you, and I need help lol. I have portfowarded it, but how do I change the UPnP settings and what is dmz?
                                  • Putridmango

                                    Putridmango Space Hobo

                                    You go to your steam app> common > starbound > assets > default_config and change the upnp portforwarding to "false,". After that, you have to open the TCP port 21025
                                    • Putridmango

                                      Putridmango Space Hobo

                                      gibbons likes this.
                                    Thread Status:
                                    This thread is has not been replied to for more than 90 days.

                                    Share This Page