Modding Help XNB Node Extractor Wont Let Me Pack Dialogue yaml File??

Discussion in 'Mods' started by aemilia, Feb 25, 2017.

  1. aemilia

    aemilia Void-Bound Voyager

    Hi, I need some help with something

    I was adding in a whole bunch of dialogue for Shane (using the guide from Alpha_Omegasis) and when everything looked good I decided to save it and then pack it.. but the only problem is that was the only file xnb_node extractor wouldn't pack no matter how many times I clicked on it. I even tried deleting everything else there but the Shane files to see if maybe it was too much for it to pack, I dont exactly know what to do since its able to pack everything else but the dialogue files, thanks. :)

    (I tried doing it manually too by clicking on the xnb_node.cmd but it closes right away. I'm going to add the yaml file to see if maybe there's something wrong with it that I didn't see.)
    P.S. dont laugh at me, I know some of them are corny :p
      Last edited: Feb 25, 2017
    • aemilia

      aemilia Void-Bound Voyager

      I've finally gotten the command prompt to open and stay by shift-right clicking the outside folder but its saying ""command" is not recognized as an internal or external command, operable program or batch file." the command I used was xnb_node.cmd pack shane23.yaml shane23.xnb. I'm not sure what to do. :\ I followed the guides and everything and it seems like I shouldn't even need to use the cmd because the extractor is supposed to pack/unpack for me right?
      • MysticTempest

        MysticTempest Spaceman Spiff

        Hey Aemilia!

        I took a look at your file, and you have a few issues with the formatting of your file.

        First up, you're missing the quotation mark at the end of the dialogue on the following lines:

        Mon3: "dialogue snipped for brevity" #!String

        And, for these. If you need to use quotation marks inside a dialogue string; you'll need to add a backslash before the internal quotes. In programming, this is called escaping your quotes. It prevents the computer from thinking it's the end of the line:

        Thu10: "The dialogue\"#$e#here has been\"$h#$e#snipped for brevity.$l" #!String

        After you fix those issues it'll pack correctly. Hope that helps some.
          Jokerine likes this.
        • aemilia

          aemilia Void-Bound Voyager

          Yes, it did! thank you so much! :)
          • Jokerine

            Jokerine Scruffy Nerf-Herder

            Pretty old post, but thank you so much for the tips, @MysticTempest! I was trying to do the same, editing the marriage dialogue for Shane, but the yaml wouldn't get packed into an xnb file. Now I see I goofed by trying to use quotes in the text... so I just replaced them with apostrophes instead. Much appreciated!
              MysticTempest likes this.

            Share This Page