Tool XNB Kit - XNB Node Interface

Discussion in 'Mods' started by HyperCrusher, Oct 18, 2016.

  1. HyperCrusher

    HyperCrusher Gotta Catch 'em All! Mk.2

    XNB Kit
    XNB kit is a graphical user interface for XNB node, allowing users to select folders to pack and unpack game files into and out of without using the command line.

    XNB Kit is meant to be a tool to help users who do no want to deal with command line, or managing several series of batch files, while still providing all the information one may want while unpacking or packing

    Currently XNB Kits only feature is to pack and unpack XNB Files, though in future releases I plan to add the ability to compare XNB directories so that you can easily extract the changed XNB Files after making graphical changes to several files without keeping track of them manually.

    Currently due to the nature of XNB Node, I can only provide a windows binary, however I will be looking into making a linux and mac replacement of XNB Node in the future to help broaden the mod community.

    XNB kit

    XNB kit 1.1.rar


      Attached Files:

      Last edited: Oct 20, 2016
    • HyperCrusher

      HyperCrusher Gotta Catch 'em All! Mk.2

      Updated Post:
      Clarified the applications purpose
      Added Attached Images for reference
      Included a image for reference for non-members to see / have visible​
      • SKKN

        SKKN Big Damn Hero

        OMG.. Where were you 8 months ago when I first started modding.

        CMD is a child's play now though but thanks for this, it really makes it so much easier. :D :D :D
          Zhuria likes this.
        • HyperCrusher

          HyperCrusher Gotta Catch 'em All! Mk.2

          Thanks, I agree thats Command prompt is easy, but I myself have 4-6 projects going on so instead of cleverly named batch scripts that I may have to change every re-vision or experiment I decided this tool would help myself and others
          • miryuo

            miryuo Zero Gravity Genie

            thank you!! (wanted this for so long.. working with command lines freaks me out dunno ^^; ..also looking forward to a mac version in the future)
            • Ichimatsu

              Ichimatsu Pangalactic Porcupine

              But this seems to be the version that messes with crystals in the cave, water, etc. What a shame.
              • HyperCrusher

                HyperCrusher Gotta Catch 'em All! Mk.2

                foghorn likes this.
              • Ichimatsu

                Ichimatsu Pangalactic Porcupine

                It does. I tested both Cursors.xnb and springobjects.xnb, which were the most problematic (as far as I remember) and the image files show properly :D Now this is a nice tool. :party:
                  HyperCrusher likes this.
                • Meevers

                  Meevers Scruffy Nerf-Herder

                  I can't seem to get this working. I set it to unpack some xnb's into a folder for me, it runs for less than half a second and says it's done but it's not actually unpacked them at all, the folders still empty. Not sure what I'm doing wrong here?
                  • fynx

                    fynx Void-Bound Voyager

                    i had this problem yesterday, but i was able to fix it pretty quickly- the problem was that, for some reason, two mac files (._Craftables.xnb and ._Craftables.xnb.ignore) had slipped into the folder with the files i was trying to decompress.

                    all i had to do to get it to work properly was shift those two files elsewhere, temporarily, and then the program worked like a charm.

                    conversely, today i'm having a problem with figuring out how to actually pack files, so i'll look into the documentation for xnb node to see if i can figure out what exactly i'm doing wrong, lol. time for more caffeine. :coffee:

                    ETA: oh my god, i'm an idiot, i figured it out. totally an error on my part, which is what i was assuming to begin with. :DD
                      Last edited: Nov 2, 2016
                    • Iomega0318

                      Iomega0318 Big Damn Hero

                      Very nice :)
                      • Minakie

                        Minakie Cosmic Narwhal

                        Thank you for this mod. All the other mods to extract files were messing up my Cursors.xnb file but yours works flawlessly. <3
                        • nevergrowingup

                          nevergrowingup Void-Bound Voyager

                          Hi, nice mod but it wont work for me. I tell em to extract or pack, it says it's done but nothing happend. is that normal or any error or so? I just wanted to merge some mail files so I could use both mods
                          • Jokerine

                            Jokerine Scruffy Nerf-Herder

                            Same for me, I put the folders on the desktop but nothing happens when I try to unpack :(
                            • RoastedCoconutz

                              RoastedCoconutz Pangalactic Porcupine

                              I've got the same problem as the last two posters. I'm trying to unpack a folder with four .xnb files in it to another completely empty folder, the thing says "Done" but the unpacked files aren't showing up. :( I triple-checked the filepath but still nothing doing.
                              • jedikitty

                                jedikitty Aquatic Astronaut

                                Same problem here - says it's done its thing, but there's nothing in the output folder. :(
                                • Kulturbanause

                                  Kulturbanause Phantasmal Quasar

                                  So much yes!!! But I have the same errors as posted above.
                                  • Maelily78

                                    Maelily78 Void-Bound Voyager

                                    I was able to unpack just fine (though this was over 2 weeks ago) but now that im done editing I cant seem to pack them back up to test them in game. Iv been doing this all separate from my game file since extraction, no chance of other files stilling into my work folder, so whats going wrong?
                                    • Tinkerbelch

                                      Tinkerbelch Void-Bound Voyager

                                      I am having this same problem now, have you figured out how to fix it yet?
                                      • louisadela

                                        louisadela Space Spelunker

                                        I had the same problem, wondering what's wrong there.
                                        To test if it's the tool's bug, I tried again to unpack a file then pack it back without editing anything, it has successfully been packed!
                                        So at least in my case there is nothing wrong with the software.
                                        Then I went back to double check the .yaml file I've edited, I found there're grammar mistakes in it. After fixed them I could pack my files now.

                                        Hope this could help you guys.

                                        Share This Page