Wineskin wrapper for Mac

Discussion in 'Support' started by DandoCalrissian, Mar 8, 2016.

  1. Aerthos

    Aerthos Space Hobo

    I got this and many other error messages during the installation, but even after all that, it worked just fine.
     
    • asdh

      asdh Seal Broken

      it ends the installation so it won't make any progress
      should i uninstall wine and maybe re instal it?
       
      • asdh

        asdh Seal Broken

        i fixed my problem of the error by opening the terminal putting in this code
        "defaults write com.apple.finder AppleShowAllFiles Yes" <shows hidden files which the cache is hidden
        "killall finder" <resets it or something then going to finder
        pressing go and than putting in the directory that wineskin was giving me
         
          DandoCalrissian likes this.
        • Waitsnake

          Waitsnake Void-Bound Voyager

          I primarily created an account to say thank you to DandoCalrissian for his post how to play the game directly on OSX !
          Before this workaround was found I set-up an bootcamp-partition with Windows to play SV. But I'm really happy there is now a way to play the game without the permanent reboots into Windows and back to OSX.

          I setup the Wineskin as DandoCalrissian explained here and than the game already starts in the mode where the game "thinks" it is in full screen, but this was actually no real full screen under OSX (I use 10.11.3). It was a kind of window that can not move and that was a bit bigger as the desktop, where the right part of the content was outside of the screen. On that not visible upper right corner the game has a switch to toggle between full screen an window mode. I played the game under windows before and because of this I know there was this button even if I can't see it under OSX. I move the mouse cursor in this upper right corner outside of the screen and press there with the mouse and could successfully toggle the game into window mode. When the game is in window mode you have now a OSX window titlebar with the 3 small buttons(red, yellow and green) on the left. If you press the green button you use the full screen function of OSX (at least since Mavericks 10.9) and this works really nice even if the game "thinks" it is in window mode you have real full screen now.

          Only issue I had with this is that from time to time you see two mouse cursers (the red one from the game and the black one of OSX) especially if you move the cursor down of the screen until the dock pops up it seems to forget from time to time to disable mouse curser of OSX when you move curser back into the window. Sometimes the second mouse curser even seems to appear even without moving it down. When see two cursors then move mouse upwards until the menu bar pops up and than back down into window. This removes the second mouse cursor again. This is a bit annoying.
           
            DandoCalrissian likes this.
          • DandoCalrissian

            DandoCalrissian Astral Cartographer

            You should be able to in the Options menu of the game by selecting Fullscreen or Windowed Borderless. You can also press the button in the upper-right of the intro screen to maximize the window.

            Hm, I didn't have to do that, but all you need to do is navigate to /Users/ash/.cache/winetricks/msxml3 (open Finder, click Go > Go To Folder..., and then enter that file path and hit Go), drop the file that you downloaded into there, and then run the Winetricks msxml3 again and it should install as expected.

            Edit: Looks like you got that all sorted! I'll leave this here incase someone else has this issue.
             
            • -GJ-

              -GJ- Void-Bound Voyager

              Did that twice. No succes :(. Would it be possible for you to upload a pre-made wrapper with all the plugins installed where I'd only have to install my copy of the game? Maybe that works. Or could it be the version of the game I'm installing? I could try the vanilla version and see if it works.
               
              • mshaleymichelle

                mshaleymichelle Space Hobo

                Hi, I have no idea what I'm doing or how wineskin works. I checked all those boxes from installing the wrapper and clicked run and now I have this thing that popped up and I'm not sure if I'm supposed to install it or not?? What exactly will it do if I do install it?

                Screen Shot 2016-03-15 at 6.29.28 PM.png
                 
                • carter1l

                  carter1l Space Hobo

                  Hey guys!

                  I have tried all of these steps multiple times and was able to get the game running on my Mac. Once I close everything down and try to open the game from the wrapper it will not open. It seems I have to do all the steps every time I want to play (not ideal) Everything ran properly in the script so Im confused as to what is wrong. please help, I'm in love with this game :(
                   
                  • sadhammer

                    sadhammer Lucky Number 13

                    Hi,
                    I must be making some stupid mistake because no one seems to have this problem. Whenever I try to Install Software, Choose Executable, I choose the SetupSteam.exe (I've tried both from steampowered and the one linked) and I get an error "Oops! No new executables found! Maybe the installer failed....?" Do you have any ideas about what I'm doing wrong?

                    Thanks!
                     
                    • Gossamer8

                      Gossamer8 Aquatic Astronaut

                      I created an account just to be able to post to say THANK YOU for these easy to follow instructions. I was such a sad panda after discovering Stardew Valley, and then discovering it was Windows only. Thanks to you, I've just spent a lovely evening cleaning up my farm and meeting people in town, and I can't wait to spend ridiculous amounts of hours on future nights farming and exploring and escaping reality. Not to mention lurking in the forums during the day for tips and tricks.

                      So massive high fives for you!! THANK YOU THANK YOU THANK YOU!!
                       
                        DandoCalrissian likes this.
                      • Sarcasthma

                        Sarcasthma Void-Bound Voyager

                        Yo Dando, your wrapper worked perfectly! Thank you so much!!!

                        *high-fives*
                         
                          DandoCalrissian likes this.
                        • juano

                          juano Space Hobo

                          Hi Dando, firstly - thank you. I'm wondering if you or anyone else can help me:
                          I seem to be able to load Steam and download Steam's Stardew Valley absolutely fine. But then, when I click 'Play', nothing happens. Not an error, but Stardew Valley doesn't open!

                          It might be worth noting that when I try to install dlls such as xna40, I get:
                          sha1sum mismatch! Rename /Users/myname/.cache/winetricks/dotnet40/dotNetFx40_Full_x86_x64.exe and try again.

                          I was able to install msxml3 without any issues (I think).

                          Any help would be great!
                           
                          • LeonBlade

                            LeonBlade Phantasmal Quasar

                            Go into Wineskin for the wrapper and click on Screen Options, then in the bottom left in Other Options check the "Use Mac Driver instead of X11". What this does, is override X11 for the window and allow the full screen button to work like normal OS X applications creating its own desktop space for it.

                            I have my own question for anyone who might be able to help.

                            I've got the wrapper to work just fine, thanks for the thread, but I'd like to get a mod working. I've seen others get it working, but I'm trying to get Storm to work. I installed .NET 4.5 through offline installation and not through winetricks (because of the conflict with dotnet20) and tried to get it to work. I get an unhandled exception thrown though.


                            Code:
                            [CecilInjectorFactory] Loaded 1524 injectors.
                            System.IO.IOException: No access to memory location.
                            
                               at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
                               at System.IO.FileStream.ReadCore(Byte[] buffer, Int32 offset, Int32 count)
                               at System.IO.FileStream.Read(Byte[] array, Int32 offset, Int32 count)
                               at System.IO.BinaryReader.Read(Byte[] buffer, Int32 index, Int32 count)
                               at Mono.Cecil.PE.ImageReader.ReadSectionData(Section section)
                               at Mono.Cecil.PE.ImageReader.ReadSections(UInt16 count)
                               at Mono.Cecil.PE.ImageReader.ReadImage()
                               at Mono.Cecil.PE.ImageReader.ReadImageFrom(Stream stream)
                               at Mono.Cecil.ModuleDefinition.ReadModule(Stream stream, ReaderParameters parameters)
                               at Mono.Cecil.ModuleDefinition.ReadModule(String fileName, ReaderParameters parameters)
                               at Mono.Cecil.BaseAssemblyResolver.GetAssembly(String file, ReaderParameters parameters)
                               at Mono.Cecil.BaseAssemblyResolver.GetCorlib(AssemblyNameReference reference, ReaderParameters parameters)
                               at Mono.Cecil.BaseAssemblyResolver.Resolve(AssemblyNameReference name, ReaderParameters parameters)
                               at Mono.Cecil.DefaultAssemblyResolver.Resolve(AssemblyNameReference name)
                               at Mono.Cecil.MetadataResolver.Resolve(TypeReference type)
                               at Mono.Cecil.TypeReference.Resolve()
                               at Storm.CecilUtils.DescriptionOf(MethodDefinition md)
                               at Storm.CecilExtensions.<>c__DisplayClass3_0.<GetMethod>b__2(MethodDefinition m)
                               at System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source, Func`2 predicate)
                               at Storm.CecilExtensions.GetMethod(AssemblyDefinition asm, String type, String name, String desc)
                               at Storm.Manipulation.Cecil.CecilEventCallbackInjector.Init()
                               at Storm.StardewValley.ManagedStardewValleyLauncher.<>c.<Inject>b__12_0(Injector injector)
                               at System.Collections.Generic.List`1.ForEach(Action`1 action)
                               at Storm.StardewValley.ManagedStardewValleyLauncher.Inject()
                               at Storm.StardewValley.ManagedStardewValleyLauncher.Launch()
                               at Storm.Program.Main(String[] args)
                            


                            If anyone has had luck getting Storm to work, please let me know.
                             
                            • asdh

                              asdh Seal Broken

                              So do i re get to the game after i close wineskin and everything, do i have to reinstall steam every time? if i do does that take up space on my disk? I'm not super tech savvy so Im surprised i even figured out how to do this
                               
                              • -GJ-

                                -GJ- Void-Bound Voyager

                                Update: I tried it again with the vanilla version of the game and it doesn't even boot up.

                                So what I've tried so far:

                                Both Dando's and Longbottom's methods on Stardew Valley GOG version 2.0.0.2, 2.3.0.5 and installing Steam which hangs at 'updating Steam' and then closes. I'm using a new iMac that I bought not even 2 months ago, I'm on Mac OS X 10.11.3 and I'm using a AMD Radeon R9 M395 2048 MB card.
                                 
                                • LeonBlade

                                  LeonBlade Phantasmal Quasar

                                  I got my fix working to get the StormLoader.exe to work with the Wineskin wrapper, I ended up having to create my own build to handle the exception it was throwing on load, I mentioned it to the developer, and I will research into the cause of the issue shortly. As of right now, if anyone is wanting to get Storm to work with their wrapper, the fix is really easy. I would provide a link to my build changes, but I'd rather just have it pushed out in the regular releases, so I will create an issue on the repo page if need be to fix this issue.

                                  Here is Storm running in the wrapper with TimeMod installed and it works just fine!
                                  [​IMG]
                                   
                                    DandoCalrissian and BL4ck like this.
                                  • BL4ck

                                    BL4ck Space Spelunker

                                    Hi. Thanks you dando. Your wrap is working very good :D

                                    And It's there somebody try to mods game?
                                     
                                      DandoCalrissian likes this.
                                    • alacazain

                                      alacazain Void-Bound Voyager

                                      The steam crossover engine in wine works always permanently for wrappers. Ive tested it in 20 wrappers for many years. So if you could try implement and build the wrapper on that engine it would be cool. Not sure though if star dew would run.
                                       
                                      • 8oo

                                        8oo Aquatic Astronaut

                                        Hi!

                                        The wrapper worked really well for me and I'd been playing the game off and on for about 17 hours now and I really appreciate the work you put in to this, but for some reason now the game won't open even though it had been opening over the past two-three days with no problems and I'm not sure what to do or what the problem is...

                                        I appreciate any help I can get! Thank you so much...
                                         

                                          Attached Files:

                                        • asdh

                                          asdh Seal Broken

                                          So when Ive been playing the game it will make my UI freeze and only the mouse works. I assume this is mostly because i need a fan for my laptop and it over heats and an error like that. So i have to hard reset my computer

                                          However Whenever i hard reset and I want to play again is their any other way of opening the game other than
                                          using wineskin to reinstall steam and have steam open that way. like i don't have to reinstall stardew valley but i have to do so for steam. can anyone help me with either of theses?
                                           

                                          Share This Page