Wineskin wrapper for Mac

Discussion in 'Support' started by DandoCalrissian, Mar 8, 2016.

  1. diav

    diav Void-Bound Voyager

    Thanks to both of you for replying me in both threads! I'll try that out and report back.

    Edit: Managed to get SMAPI working by running it directly from Wineskin! Thanks everyone!
     
      Last edited: Mar 13, 2016
    • DandoCalrissian

      DandoCalrissian Astral Cartographer

      No idea. I would say just delete the wrapper and redo the steps starting with a fresh download and then see if Winetricks will work for you. I tested on the newest wrapper and everything installs just fine for me.

      My coworker informed me of this as well and showed me it happening. I usually give Steam a few seconds to start up and never have this issue, but he was flying through the menus and starting the game up immediately, so I think it may have to do with Cloud Syncing and giving the client a few seconds to get everything ready.

      You're using an old version of the wrapper (1.2.1), so delete that and set the wrapper up again using the instructions on the first page (you should see DandoDew-v1.3 at the bottom of the wrapper now).

      Yeah, I'm not sure why that is happening, but as theorized above, I think it may be due to just needing to give the wrapper and Steam a few seconds to start up. I've never run into this issue, but I also let Steam start up and give it an extra little bit to get fully loaded up.

      Are you installing Steam using the SteamSetup.exe? I don't see any errors that indicate an obvious issue, so maybe just delete the current copy of the wrapper you're using and start with the beginning of the guide and make sure you're installing Steam as it states. Also, make sure you're installing all of the dlls from Winetricks as that could cause issues and weird crashes if you miss any of them.
       
      • DandoCalrissian

        DandoCalrissian Astral Cartographer

        I added step-by-step instructions that were made on the Reddit post to the guide! If anyone wants to make step-by-step instructions for getting the modding API to work, that would be fantastic. I don't have time or interest in modding at the moment to thoroughly test it and make a guide to get it working, so I will leave that up to you modders :D
         
        • Rose Fox

          Rose Fox Space Hobo

          I am, yes! I used the direct download link. And I made sure to install all the dlls listed, through Winetricks.

          What do I need to delete in order to entirely clear out and start over? rosefox/.cache/winetricks?
           
          • DandoCalrissian

            DandoCalrissian Astral Cartographer

            I would just delete the entire wrapper and re-download. You shouldn't need to go and modify or delete anything manually like that.
             
            • Rose Fox

              Rose Fox Space Hobo

              Ah, okay. I already did that and tried again, got no errors on DLL installations, installed Steam, it updated and then quit. Seems to be the same problem described here:

              https://www.reddit.com/r/Steam/comments/1k8943/
              http://www.tenforums.com/gaming/22236-steam-updates-verifies-install-then-closes-fails-launch.html

              I deleted everything from the Steam directory except steam.exe, tried running that--same thing, updated and then quit.

              :nurusad:
               
              • porcini

                porcini Intergalactic Tourist

                I followed the instructions and got my game running perfectly and sunk about 12 hours into it. Sadly, after quitting my game today I'm now receiving a heartbreaking "no saved games found" error.

                I'm only loosely familiar with wineskins. I'm assuming there might possibly be my corrupted save file somewhere, but does anyone have a wager on how it could be located inside my wineskin (if that's even possible) and repaired (if that indeed, too, is even possible).

                I don't really have the heart to start the game over from scratch, so hopefully there's a solution.

                EDIT: Oops, shoulda googled how to access wineskin files. I just realized I can open the wineskin app by Showing Package Contents, etc. I found my two save files, which seem to be XML, and they look normal. I'm not sure how they're corrupted, but they're there and not loading properly. Hmm.
                 
                  Last edited: Mar 14, 2016
                • 3rdFunkyBot

                  3rdFunkyBot Space Hobo

                  Hi Dando,

                  Thanks for the guide. I've gotten so far as to get Steam up and running, but when I hit play to launch the game the same thing happens every time. It says 'preparing for first launch, installing a couple things' then the game says 'Running' for a few seconds, but the never runs and the game no longer has the words 'running' next to it.

                  I have attached my logs. Would love to see if you know what I did wrong when you have some free time. Thank you!
                   

                    Attached Files:

                  • DandoCalrissian

                    DandoCalrissian Astral Cartographer

                    Someone else brought this up earlier and it seems like this happens every now and then where save files don't show up. Make sure you shut the wrapper and Steam down completely, then start it up again and give Steam a few extra seconds to load. My coworker had this same issue and I saw his save files pop up after a couple attempts.
                     
                    • DandoCalrissian

                      DandoCalrissian Astral Cartographer

                      Looks like you're getting a dotnet40 or xna40 error when loading Stardew. Go back through Winetricks and make sure to install msxml3, dotnet40, and xna40 and that should solve your issue!
                       
                      • DandoCalrissian

                        DandoCalrissian Astral Cartographer

                        It's weird that you're getting this with a fresh install of Steam. I'm at a loss since I have tested this wrapper countless times and haven't run into this issue. Maybe try downloading a fresh copy of SteamSetup.exe and try installing that in conjunction with a fresh wrapper with all of the Winetricks redistributibles installed. I'll try to see if there are any other solutions I can find, but it seems like it shouldn't do that with a completely fresh install of Steam on a fresh wrapper.

                        Sorry I don't have any for-sure solutions for you!
                         
                        • porcini

                          porcini Intergalactic Tourist

                          Ah, thank you! I realized there were "invisible" processes of my wineskin that never properly closed down. I went into Activity Monitor and found two different versions of the wrapper still running that I killed off—and after booting the wrapper back up, everything is working perfectly again. Yay!
                           
                            DandoCalrissian likes this.
                          • giottoblue

                            giottoblue Space Hobo

                            Thanks so much for putting this all together! I feel like I'm almost able to install it right now, but I've hit a problem:
                            I have the "Windows" version of Steam open and now I just need to download Stardew Valley, but "Windows" Steam is not connected to my internet and I don't know how to make it.

                            Am I supposed to download the game on my normal Mac version of Steam, and then trust it will be there in the "Windows" version? Or will it not translate because the "Windows" version isn't connected to the internet? I've never used Steam OR Wineskin before so I'm more or less flying blind here...

                            Thanks!
                             
                            • Chibi88

                              Chibi88 Aquatic Astronaut

                              Thanks for the Thread. It works on my MBP 13" Retina 2015 with the GOG Version.

                              Question: How do I uninstall everything if I want to remove the game from my mac?
                               
                              • alacazain

                                alacazain Void-Bound Voyager

                                Hi! Im so happy it works for me! Just one question, how do i make steam store, achievements page and workshop work? In steam? Is it ok to change engine? will it still work?
                                 
                                • DandoCalrissian

                                  DandoCalrissian Astral Cartographer

                                  You should be downloading it via Steam in the wrapper (Windows version). Are you sure it's not connected to the internet? Are you able to log in and then it just displays black windows for the Store? If that is happening, just click on Library and install the game. It's a known bug in Wine that there are black windows where you would normally get the store pages.

                                  Just throw the wrapper in the trash and that's that!

                                  There's a bug in Wine that is preventing those pages from being displayed (issues with Chromium as far as I can tell) and I have attempted to resolve it using submitted patches, but it still does not work. Changing the engine will more than likely give you the graphics card error that everyone was getting before due to Wine needing some patching to resolve it.

                                  I would just use the Mac version of Steam if you need to view those pages and use the wrapper exclusively for Stardew.
                                   
                                  • -GJ-

                                    -GJ- Void-Bound Voyager

                                    Hey,

                                    I tried both DandoCalrissian and LongBottom's methods with the latest GOG installer and both give me the same error message as a result.

                                    I'm on an iMac with a AMD Radeon R9 M395 2048 MB graphics card. What am I doing wrong?

                                    Error log:
                                    edit: If I try the Steam method it just opens the Steam update screen and then closes after ~5 seconds. So that doesn't work either.
                                     
                                      Last edited: Mar 14, 2016
                                    • pandahatbear

                                      pandahatbear Seal Broken

                                      Took me a while to get time to try this again. It works! You are amazing! And PurpleMentat who directed me here is a scholar and a gentlefolk and I cannot thank them enough either. Go watch their playthrough!
                                       
                                        DandoCalrissian likes this.
                                      • jlbarrios

                                        jlbarrios Space Hobo

                                        Hi everyone, I'm trying to install via Steam and I think I'm running into the same problem as giottoblue. Everything looks like it's working, the Steam window says "Preparing Stardew Valley for Install" and then I get an error saying I am having connection problems. What's weird is that I can see friends online... so I must have access to the internet. Anyone have any ideas?

                                        EDIT: Figured it out! Changed my steam location from US-NY to Canada and it's downloading! Just have to remember to change it back :)))
                                         
                                          Last edited: Mar 14, 2016
                                          DandoCalrissian likes this.
                                        • DandoCalrissian

                                          DandoCalrissian Astral Cartographer

                                          Can you click the Show Details button and screenshot or copy paste that? It might give us some clues as to what is happening... Also, are you using the M395 or M395X? Both should work fine, but I want to make sure these are set up properly.
                                           

                                          Share This Page