Wineskin wrapper for Mac

Discussion in 'Support' started by DandoCalrissian, Mar 8, 2016.

  1. Danjuro

    Danjuro Space Hobo

    Got my game purchased on GOG working as well - I thought I was WINE savvy, turns out I was hitting a wall with the XNA framework.
    Thank you a whole lot.
     
    • DandoCalrissian

      DandoCalrissian Astral Cartographer

      Do me a favor and check the Windows EXE field by right-clicking the chicken icon, select Show Package Contents, double-click Wineskin, click Advanced, and see if there is anything in the Windows EXE field. If there isn't, browse to the Steam.exe file, hit OK, then exit the wrapper. You should be able to successfully run the wrapper by double-clicking the chicken icon now. If there is already something in the Windows EXE field, try restarting your computer as there may be a rogue wine process still running and preventing it from starting again.
       
      • DandoCalrissian

        DandoCalrissian Astral Cartographer

        This is great! Did you try with Winetricks or did you just use the offline redistributable? It's weird that crackling and popping happened. I would try checking the Start.exe box under Windows EXE and see if that helps. Someone else has sound issues that were resolved by checking it, so it's worth a shot!
         
        • telgalad

          telgalad Aquatic Astronaut

          I just tried it both ways through winetricks and direct (starting from scratch each time...) and I couldn't get SMAPI running... Im using the steam install route, are you using The other route?
           
          • KnightBaron

            KnightBaron Space Hobo

            Tried winetricks but dotnet452 conflict with dotnet20 and it won't install at all. That's why I had to use the offline installer instead.

            I also checked "Use Start.exe" but there is still problem with sound on Windows 7. It seems that this is a legit wine bug. https://wiki.winehq.org/Sound
             
              Last edited: Mar 11, 2016
            • Bwolfiee206

              Bwolfiee206 Intergalactic Tourist

              Everything is working great! Thank you so much! This is one of the most unbelievable games i have ever played in my life!
               
              • chuckthefish

                chuckthefish Space Hobo

                When I try to run the dlls I always get the following .
                Any idea how I could fix this?

                wine cmd.exe /c echo '%ProgramFiles%' returned empty string
                 

                  Attached Files:

                • jimbo1111

                  jimbo1111 Void-Bound Voyager

                  Did all of this, game is running fine, played through the first day, game told me it had saved my progress, I quit the game and the next time I opened it said "no saved games found."

                  I looked in my Stardew Valley (Contents->Resources->drive_c->Users->Wineskin->Application Data->StardewValley->Saves) folder and the save game is in there, so it got saved, but the game doesn't seem to know where to look for it or something.

                  edit: nevermind, I reloaded the game and it finds the save. Not sure what happened there.
                   
                    Last edited: Mar 12, 2016
                  • bassguy

                    bassguy Void-Bound Voyager

                    Confirming that running the updated GOG installer in the configured Wineskin updated the game in place as you'd expect.

                    It's worth reminding everyone to grab a copy of your save files from [WHEREYOURAPPIS]/Contents/Resources/drive_c/users/Wineskin/Application Data/StardewValley to be safe
                     
                    • bushd

                      bushd Space Hobo

                      did not work for me. I got: "The program StardewModdingAPI.exe has encountered a serious problem and needs to close."
                      I changed it to win 7, the installer ran just fine and i switched back to winXP.

                      Edit: trying to run SMAPI 0.37.2A
                       
                      • dax

                        dax Space Spelunker

                        getting this any help? =(
                         

                          Attached Files:

                        • bushd

                          bushd Space Hobo

                          ok fixed it myself. Checking "Use Start.exe" helps. Awesome!
                           
                          • diav

                            diav Void-Bound Voyager

                            Did you do anything else apart from checking that box? I'm using the Steam route as well but can't seem to get SMAPI 0.37.2A working... it's giving me the serious problem and needs to close error.
                             
                            • bigsushi

                              bigsushi Space Hobo

                              I'm having some issues with the game saving.

                              I got the game to work through Steam but when I first launched there was no save file to load. I figured the steam syncing just wasn't working so I transferred my save folder from my PC to the correct folder in the wrapper, loaded up the game and was able to load my save. I played for a bit, saved, and then shut down the game.

                              The next day I loaded up the game and the game is saying there are no saved games, not just that my progress wasn't saved, the game just doesn't show up.

                              Anyone have any ideas?
                               
                              • bushd

                                bushd Space Hobo

                                I followed KnightBarons instructions, checked said checkbox and changed the path of the executable to the one of the modding api. I did nothing else.
                                 
                                • Sushidragon

                                  Sushidragon Space Hobo

                                  I registered an account for the forums entirely to say THANK YOU for putting together this guide! I was so disappointed I wouldn't be able to play the game but now I am farming in style thanks to the magic of wrappers. High-five!
                                   
                                  • Rose Fox

                                    Rose Fox Space Hobo

                                    Thank you so, so much for this!

                                    I keep running into an issue where Steam installs, and I check "Run Steam", and it downloads and installs updates--and then Steam closes, and I get a Wineskin error that says "Oops! No new executables found!". Then I realized that it defaults to installing on my desktop (via alias) even though it won't work unless the app is installed directly within drive_c. So I made a Steam folder in drive_c/users/rosefox and tried again, and got the same error. I cleaned out the entire Wineskin installation as best I could, started from scratch, put Steam directly into Program Files, and got the same error. I manually pointed Wineskin at Steam.exe and did a test run, and it checked for updates and then quit. How do I get Steam to actually run and let me log in and so on?

                                    Logs from the test run attached.
                                     

                                      Attached Files:

                                      Last edited: Mar 13, 2016
                                    • bigsushi

                                      bigsushi Space Hobo

                                      I was doing some more reading through the threads here and on reddit and I noticed that someone mentioned they had to relaunch their game multiple times for the game to find their save. When I made my previous post I had already relaunch the game at least 5 times. Probably more and the game never found my save. However, just now I tried and it worked. I hadn't changed anything as far as I know I had restarted my laptop previously thinking that might have some affect but attempts to load my save after that were the same so I don't think it was anything I did to make it work.

                                      The post I found mentioned that it might have something to do with Stardew Valley placing saves in %appdata% but I have no idea. Anyways, I just wanted to post this information in case someone ran into the same problem and to thank everyone who has helped make this possible.
                                       
                                        Last edited: Mar 13, 2016
                                      • KnightBaron

                                        KnightBaron Space Hobo

                                        @bushd @diav I launched StardewModdingAPI.exe directly from wineskin with "Use Start.exe" checked. Tried adding StardewModdingAPI.exe as an external game and launch it through Steam but it didn't work. Also tried launching StardewModdingAPI.exe and Steam.exe together with a BAT script but also didn't work.
                                         
                                        • Kakeycustard91

                                          Kakeycustard91 Space Hobo

                                          Hi all! Firstly mega thanks @DandoCalrissian for the instructions! You've made it easy even for someone like me who is a lot clueless :notworthy:
                                          I've managed to install it all for steam and the game is running fine, the problem I've got is that when I get to step 8, Winetricks has stopped working and it freezes on a "busy" pop up. I've tried deleting everything and trying again 5 times, but the problem is always the same! When I run the game before that part it is even saving my progress, but once I exit steam, I can't open them back up again because Winetricks has froze. Any ideas? Is it just a case of keep trying?
                                           

                                          Share This Page