Wineskin wrapper for Mac

Discussion in 'Support' started by DandoCalrissian, Mar 8, 2016.

  1. Vejur

    Vejur Intergalactic Tourist

    Does anyone know how to take a screenshot of your entire farm while playing through Wine? It looks like most people use GeDoSaTo, but I can't figure out how to get it to work.

    Also, thanks a ton for getting the game to run on Macintosh! I'm having a blast!
     
    • Frisacra

      Frisacra Space Hobo

      Hey Kokopod,

      I had a similar problem and got it to run; here's what I did.
      I deleted everything (the .zip file and the Stardew Valley icon with the chicken), and then I did steps 1-5 of the wrapper preparation. Accept and install whatever pops up (I don't remember if anything pops up for that step). Do not close out of the window that runs those files.
      Then select and run only msxml3. It should open a Finder window (don't close it) and send you to a website to download a file. Download the file, then open a new Finder window (by right clicking on Finder) and move that file from "Downloads" to the folder it opened up for you (if it doesn't open it up for you, look through these forums; I think someone posted how to command that folder to open up). Then run it again; if anything pops up, install it (I don't remember if anything pops up when you hit run again). Finally, run it AGAIN. And it should say something about skipping it because it already downloaded it (or some similar phrase).
      Then select and run only dotnet40 next; accept and install whatever pops up. Run it again, and it should say something about skipping it because it already downloaded it.
      Then select and run only xna40; accept and install whatever pops up. I vaguely remember this one being the one that takes longer to install? Anyway, run it again, and it might have you install something else. I think it said something about skipping it because it already downloaded it the third time I ran it.

      Then start the "To install using Steam" instructions. When you hit "play," it finally should have error messages for you. Hit "Ok" for the first one, and then install whatever it tells you to. I think it was the xna installer thing again. I don't remember if it didn't play after working through the error and installer, but it certainly worked the second time I hit play.

      Tl;dr: always accept and install whatever it tells you to; run msxml3 first on its own, then run dotnet40 on its own, then run xna40 on its own; and check that those ones are installed by running them until it says they skipped it because it's already downloaded it.


      I hope this helps, but if it doesn't, I can't help you beyond what I just told you. Someone with more technological expertise will have to help you if you don't have the exact same problem I did lol. Good luck!
       
      • alacazain

        alacazain Void-Bound Voyager

        Has anyone figured out how to make steam workshop, store page, achievements in steam, etc work? Dandy could you try getting it to work please?
         
        • SteveOfHouse

          SteveOfHouse Space Hobo

          Hey all,
          I'm a forum virgin so please forgive me. But I had a few questions.
          I can't wait to sink many hours into this game, but I have a mac. I've looked around but:

          1) is there any actual, really real, no-b.s., official word of when a mac version will be available if at all? How about PSN?
          2) If not, I'm going to attempt the Wineskin wrapper, do gamepads/controllers work with a wineskinned mac version?
          3) If an xbox 360 controller does work, does it have to be tethered to the computer somehow, or will it be wireless?

          Thanks for any help you can provide.

          -Steve
           
          • Kenneth2345

            Kenneth2345 Intergalactic Tourist

            How to update stardew valley then on GOG without losing my game file?
             
            • darkerix

              darkerix Space Hobo

              Thank you so much @DandoCalrissian. Hi-five and awesome job!
              I got Stardew Valley working smoothly on Mac OS 10.10.5 with Steam.
              Tried running it earlier on VMWare Fusion / Windows but couldn't get it to work.
              Your solution worked great every step of the way! Now time to play :D
               
              • kyokorain

                kyokorain Space Spelunker

                Thanks so much for all your hard work! The game is currently running like a dream on my mac. My farming fantasies are fulfilled <3 Is there anyway of installing mods? Thanks again
                 
                • miyano534

                  miyano534 Space Hobo

                  I just made an account here because I am very curious on Stardew Valley running on Mac!
                  I never used Wine before, so this will be my first attempt.

                  I hope there will be answers for the following questions (recapping from above posts):
                  1. [answered] How to update using GoG version?
                  2. How to install mod? (I heard there is this awesome fishing mod that makes life way easier!)
                  3. [answered] My own question: How do I access my savefiles (for backup purpose) if I play using Wine wrapper?

                  Thank you :)

                  =====
                  Edit:
                  Just found the answer to my 1st and 3rd question from another page in this thread:
                  "
                  Confirming that running the updated GOG installer in the configured Wineskin updated the game in place as you'd expect.
                  It's worth reminding everyone to grab a copy of your save files from [WHEREYOURAPPIS]/Contents/Resources/drive_c/users/Wineskin/Application Data/StardewValley to be safe
                  "
                  Thank you for the poster @bassguy !
                   
                    Last edited: Apr 6, 2016
                    kyokorain likes this.
                  • OnionBreath

                    OnionBreath Space Spelunker

                    Thank you for this!!
                    I've been wanting to play the game for ages and yesterday I found everything here, successfully installed and ran smoothle. Played the game happily for 2 hours, went to bed, and now that I'm attempting to play it again I'm getting problems with the steam client. It wants to run an update for stardew valley but nothing is properly connecting and stalling at every window, running but never completing any loading.
                    I ran Mac steam to see if it was a problem with all versions, but it's running fine.
                    Tried reinstalling the windows steam, but it didn't fix anything.
                    The game is stuck in update queue with no progress before mentioning something about connectivity errors.
                    Any ideas?
                     
                    • spiritslive99

                      spiritslive99 Void-Bound Voyager

                      It would be nice to have a comprehensive guide on how to install and run mods- I downloaded the installer for .NET 4.2.5 and have no idea how to run it- it just opens a Wine window when clicked. I really want to be able to run mods, and it seems like it's possible, so help would be nice!

                      EDIT: Personal update on how my attempts have been going- just installing the new .NET and SMAPI doesn't work, even when following all the instructions currently out there. (Opening the game with SMAPI gives an error message and a crash.) Doing a clean reinstall and installing dotnet35sp1 instead of dotnet20sp2 crashes winetricks every time without fail- the installation gets stuck and just breaks after a point. I'm honestly just stuck at this point.
                       
                        Last edited: Apr 9, 2016
                      • jojaboba

                        jojaboba Space Hobo

                        did everything according to the steps. it works!! THANK YOU!!!
                         
                        • LunarEpsilon

                          LunarEpsilon Space Hobo

                          I very much appreciate this forum, I dearly have been wanting to play this game, but I am having the same issue as kokopod. Though reading more in this forum I found Friscara's solution, but then more issues arose as a result:

                          I went back and specifically ran "msxml3" in which it opened my finder and a window to download a file, I downloaded said file and dragged it into the open folder in the finder. I did close the window as I saw no further use for it to be open after the download. Then I specifically went back to run "dotnet40", but instead of being prompted to install anything, it says: "The program Setup.exe has encountered a serious problem and needs to close. We are sorry for the inconvenience." with a description of, "This can be caused by a problem in the program or a deficiency in Wine. You may want to check the Application Database for tips about running this application." This comes up as well when running specifically xna40 too.

                          I have checked, and I still cannot actually "play" the game.

                          Can I get some help on this? I have never used Wine before and have had little luck in the past, so this is very disheartening to me. Thank you very much for even making this forum.

                          Screen Shot 2016-04-12 at 1.26.00 AM.png
                           
                          • ShellyC

                            ShellyC Intergalactic Tourist

                            I done all the steps correctly and have Steam installed however whenever I try to connect, it says that theres no internet connection (which there is). Neither of my Steam programs work until I uninstall the windows version and everything is fine again.

                            Anyone else had this issue?
                             
                            • Lixamarz

                              Lixamarz Void-Bound Voyager

                              Okay so honestly it worked PERFECTLY for me! My only question now is that - Is there away to open the files that allow me to put mods in on mac with the wrapper?
                               
                              • spiritslive99

                                spiritslive99 Void-Bound Voyager

                                You can open the files just fine- right click the wrapper and click show package contents. The Stardew Valley install is in the Program Files folder, under Steam/steamapps/common. Portrait mods and the like work, but it looks like nobody's been able to get SMAPI running- the game crashed every time when I tried to.
                                 
                                • Bensington

                                  Bensington Yeah, You!

                                  Okay, so I'm totally new to Wineskin and all this - but desperate to play on my Mac! I cannot for the life of me get dotnet40 installed in WineTricks. I get the following error message and it stops loading. If I try to cancel it doesn't work - I end up needing to Force quit. Any help would be greatly appreciated!!

                                  Executing w_do_call dotnet40
                                  Executing load_dotnet40
                                  ------------------------------------------------------
                                  dotnet40 does not yet fully work or install on wine. Caveat emptor.
                                  ------------------------------------------------------
                                  Current wine does not have wine bug 30707, so not applying workaround
                                  Executing w_do_call remove_mono
                                  Executing load_remove_mono
                                  err:module:load_builtin_dll failed to load .so lib for builtin L"winemac.drv": dlopen(/Users/kaitlyn/Downloads/Stardew Valley.app/Contents/Frameworks/wswine.bundle/bin/../lib/wine/winemac.drv.so, 258): Symbol not found: _kCGDisplayShowDuplicateLowResolutionModes
                                  Referenced from: /Users/kaitlyn/Downloads/Stard
                                  fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
                                  reg: The system was unable to find the specified registry key or value
                                  Executing rm -f /Users/kaitlyn/Downloads/Stardew Valley.app/Contents/Resources/dosdevices/c:/windows/system32/mscoree.dll
                                  fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
                                  fixme:process:SetProcessDEPPolicy (3): stub
                                  fixme:clusapi:OpenCluster ((null)) stub!
                                  fixme:clusapi:ClusterOpenEnum (0xdeadbeef, 4) stub!
                                  fixme:clusapi:ClusterEnum (0xdeadbeef, 0, 0x33f8a0, 0x144508, 261) stub!
                                  fixme:clusapi:ClusterCloseEnum (0xdeadbeef) stub!
                                  fixme:clusapi:CloseCluster (0xdeadbeef) stub!
                                  fixme:advapi:DecryptFileW (L"C:\\45bbf5d2d6ed2e7103654614417a\\", 00000000): stub
                                  err:winediag:nulldrv_CreateWindow Application tried to create a window, but no driver could be loaded.
                                  err:winediag:nulldrv_CreateWindow Unknown error (127).
                                   
                                  • Deekkru

                                    Deekkru Void-Bound Voyager

                                    Last edited: Apr 16, 2016
                                  • LogIsTyx

                                    LogIsTyx Intergalactic Tourist

                                    Hey! I quickly skimmed through these replies and wanted to see if anyone had the same problem as me.

                                    The game worked fine the first time, and, don't get me wrong, I was extremely appreciative. But when I click on it the next day to open it, the game won't open. I click on the wrapper, enter the special code near Windows EXE and whatnot and Test Run, but it'll always pop up saying that Wineskin had to close because of a problem. If I try it a second time, it'll say it can't Test Run because it's already running.

                                    I'm sorry if this post has already been made - I was just wondering if anyone could quickly give me any help? Anything is appreciated. Thanks!
                                     
                                    • modus_ataraxia

                                      modus_ataraxia Void-Bound Voyager

                                      EDIT: Game plays now (after doing a fix in the thread), but it frequently has runtime error crashes. Is there a fix for this?
                                       
                                        Last edited: Apr 18, 2016
                                        LunarEpsilon likes this.
                                      • spiritslive99

                                        spiritslive99 Void-Bound Voyager

                                        Can you describe how you got it to work? Because that was the workaround I was following and I could not get it to work for the life of me.
                                         

                                        Share This Page