1. Welcome to the Starbound support forums. Please check the support FAQs before posting: http://playstarbound.com/support

Closed Win7 "GraphicsException: Could not create a HAL device." Screenshot included.

Discussion in 'Starbound Support' started by Fa1c0n, Dec 5, 2013.

Thread Status:
Not open for further replies.
  1. Fa1c0n

    Fa1c0n Space Hobo

    [​IMG]

    This happens when I try to play the game.

    Sits on chucklefish logo for 5+ minutes, drops this error.

    Please note - I do not have an E:/ drive so I have no idea what it is going on about.....

    Windows 7
    4gb ram
    SSD
    Intel HD Graphics 3000
     
  2. Fa1c0n

    Fa1c0n Space Hobo

    Anyone else get this error?
     
  3. Noble Hermit

    Noble Hermit Space Hobo

    Hi, I actually came to the forums to report this issue as well. If anyone could help out, it would be greatly appreciated. I just want to play! :O
     
  4. Brannoncyll

    Brannoncyll Subatomic Cosmonaut

    I had the same error just now after I tried to save and exit:
    [​IMG]
    DXdiag attached.
     

    Attached Files:

  5. Respite

    Respite Yeah, You!

    I have this same error, happens after I press play on the launcher.
     

    Attached Files:

  6. Fa1c0n

    Fa1c0n Space Hobo

    Glad I am not alone.
     
  7. LXD

    LXD Space Hobo

  8. swiftlovebird

    swiftlovebird Big Damn Hero

    Hello all.
    I am not a developer or programmer for Chucklefish. I am, however, still a programmer and the issue you're experiencing is a programming issue.


    HAL (Hardware Abstraction Layer) is something that the program must use to load accelerated graphics because it's unable to access your graphic cards directly... it's simply not allowed to. An easy way to understand this weird "HAL device" is to look at it as a radio in a car. There's radio waves all around us. We don't have antennas built into our bodies but our cars do. We use the built in radios in our cars to function as our ears for these radio waves. We're unable to listen to the radio stations without requesting our radio to tune into them. I hope this makes sense!
    For Starbound to run, it must create a HAL device on your graphics adapter (i.g. GPU or on-board accelerated graphics, such as those found in common laptops). Starbound isn't allowed to access the graphics adapter directly, so it needs to request the creation of a HAL device in order to use accelerated graphics in Direct3D. If you're confused, just think of this as Starbound asking DirectX to use the computer's graphics to generate some fun stuff.


    So the problem experienced here is something related to the programming of the game. Though it may just be a bug, it may also just be your computer having a hard time dealing with the HAL request. I recommend trying a few things:
    1. If you don't already have it, download and run CCleaner. I couldn't tell you why dead registries and temp files corrupt information but they simply do. (https://www.piriform.com/ccleaner)
    2. Restart your computer and run the game as 'Administrator'.
    3. If after following the first 2 steps with no success in this HAL error, feel free to reply with your system specs so that I can attempt to assist you further on a more individual basis. (http://www.piriform.com/speccy)
     
    Electrose and Archs like this.
  9. Fa1c0n

    Fa1c0n Space Hobo

    You are a saint - this fixed my problem!
     
    swiftlovebird likes this.
  10. ArmyOfOne

    ArmyOfOne Orbital Explorer

    I did that and it still doesn't work. Here are my specs:

    Operating System
    Windows 7 Starter 32-bit SP1
    CPU
    Intel Atom N450 @ 1.66GHz 64 °C
    Pineview-N 45nm Technology
    RAM
    1.00GB Single-Channel DDR3 (5-5-5-15)
    Motherboard
    TOSHIBA PAV10 DDR2 (U2E1)
    Graphics
    DELL P2412H (1920x1080@60Hz)
    Generic PnP Monitor (1920x1080@60Hz)
    Intel Graphics Media Accelerator 3150 (Toshiba)
    Intel Graphics Media Accelerator 3150 (Toshiba)
    Storage
    232GB TOSHIBA MK2565GSX (SATA) 42 °C
    Optical Drives
    No optical disk drives detected
    Audio
    Realtek High Definition Audio
     
  11. swiftlovebird

    swiftlovebird Big Damn Hero

    Hey Army. I'm just wondering, are you running a netbook plugged into a full size monitor? Running an Atom on 1GB of memory is certainly going to be a hassle when it comes to gaming.

    But we'll keep troubleshooting!
    Do this for me:
    Click the Start Menu and where it says Search programs and files I want you to type Device Manager and click enter
    From the list of items, find the one that says Display Adapters and click on it so that the list drops down
    Right click on your Intel Graphics Media Accelerator and click Properties
    Click the Driver tab. Tell me what the Driver Date is and what the Driver Version is. You can attempt to click Update Driver but it may not work.
     
  12. ArmyOfOne

    ArmyOfOne Orbital Explorer

    Yeah it's plugged into a monitor because the launcher was too big for the regular screen, and it fully shows on the monitor.
     
  13. Archs

    Archs Yeah, You!

    Hi Swift..

    Thanks for trying to help.. much appreciated..

    I've tried what you suggested with no luck.. still getting the same error.. my system specs are:

    Operating System
    Windows 8.1 64-bit
    CPU
    Intel Core i7 3630QM @ 2.40GHz 51 °C
    Ivy Bridge 22nm Technology
    RAM
    8.00GB Dual-Channel DDR3 @ 798MHz (11-11-11-28)
    Motherboard
    TOSHIBA QFKAA (SOCKET 0)
    Graphics
    Generic PnP Monitor (1366x768@60Hz)
    Intel HD Graphics 4000 (Toshiba)
    2047MB NVIDIA GeForce GT 630M (Toshiba) 46 °C
    Storage
    931GB TOSHIBA MQ01ABD100 (SATA) 42 °C
    3GB SDHC Card (US:cool:
    7GB USB Device (US:cool:
    Optical Drives
    MATSHITA BD-CMB UJ160B
    Audio
    Realtek High Definition Audio

    Please Help!! If you can.. thanks.

    Archs
     
  14. swiftlovebird

    swiftlovebird Big Damn Hero

    Hey Archs. I'm happy to be of assistance!

    I notice you're using an HD4000 and that, though very good, is laptop hardware. Laptops seem to be the main victims of this error code. I'm still trying to piece everything together myself so that I can make a solid work-around.
    Try some things for me if you can:
    1. Start up Steam for me and go to Starbound in your Library.
    2. Right click it and go to Properties.
    3. See where it says Enable Steam Community In-Game ? Uncheck that.
    4. Try running the game let me know if it gives you the exact same error code.
     
  15. Archs

    Archs Yeah, You!

    Wow quick reply!!..

    I unchecked the 'enable steam community in-game' box and tried running the game again..

    It gave me the exact same error.. hope that helps =)
     
  16. swiftlovebird

    swiftlovebird Big Damn Hero

    Haha yes, I've been going at it in the support forum all day. I will be going to bed for the night after this post most likely:zzz:

    Do you have some type of control panel software for your GPU?
     
  17. Archs

    Archs Yeah, You!

    Yes..There is:

    'NVIDIA Control Panel' Which has a 3D settings tab and a video settings tab.. and,

    'Intel HD Graphics Control Panel' Which has Display, 3D, Video, Power and Options tabs.

    But i am unsure of what settings to try changing.. I have also tried turning off hardware acceleration.. only to find that this is not possible (as far as i can tell) with my GPU.

    btw.. if you're reading this before you've slept.. go to bed now!! Helping people on the starbound forums can wait until you are refreshed haha =P
     
  18. scramin

    scramin Seal Broken

    Ohh same prob here :(
    I've waiting this day for so much time and now, i can't play!
     
  19. swiftlovebird

    swiftlovebird Big Damn Hero

    I've been resurrected and I'm stronger than ever! :V

    So that Intel HD Graphics Control Panel would be what we would use if we were plugged into the motherboard's display adapter. However you're using a 630, hence why we've got the option for the nVidia control panel; we'll be using this one. But before we dive into those controls, do just a few things for me if you don't mind!:
    Open up Steam and find Starbound in your game library
    Right click it and choose Properties
    See where it says Enable Steam Community In-Game? Go ahead and uncheck that.

    And then, for consistency purposes, let's make sure Starbound has everything it needs to run correctly:
    With the Properties box still open, click on the Local Files tab
    Click Veryify Integrity of Game Cache... and let that dirty girl run
    Once this is complete, fire up Starbound and let's see what type of error message we get, if any :up:
     
    Nick1236 likes this.
  20. scramin

    scramin Seal Broken

    Hey, i did that, and... still appears the same error :cry::rofl::down:
     
Thread Status:
Not open for further replies.

Share This Page