Why Do I Suddenly Have to Face Things?

Discussion in 'General Discussion' started by Kilyle, Oct 9, 2016.

  1. Kilyle

    Kilyle Void-Bound Voyager

    (I think this is the update, but maybe it's something in the control settings or another factor. If it's the update: For Yoba's sake, change it back!! If it's the controls: Please show me how to get back to normal. If it's something else... what's going on??)

    I was watching a guy do a Let's Play of the update, and he was doing this move-water-move-water thing that was driving me nuts. Why would you move each time you have to water something? Stand in one place, click on each square in a 3x3 area, then move to the next 3x3 area and repeat. Simple, calming, doesn't require so much fiddly movement between each action.

    I mean, when I first started playing the game a couple weeks back, that was the main thing about the controls that I absolutely adored. Harvest Moon always made you face the thing, but here was a game with updated modern controls letting you stand in the middle of a section and water or harvest or chop or mine all the spots around you, anything within arm's reach. It was awesome!

    So I thought the Let's Player was just unaware of this simple and appealing technique. But now I just started a new game, using one of the new maps, and it appears that the behavior I saw as an aberration is actually what the game requires you to do now!

    I can't pick up items on the ground unless I use the keyboard to face them. I can't water all the squares around me unless I carefully change the direction my character is facing each time, and move to a new square to address each pair of corners. I assume I won't be able to mine or chop from one spot anymore either. This is nuts!

    The only control problem I was really annoyed by, with the earlier controls, was combat, wherein I would end up swinging my sword in the wrong direction due to where my mouse was. In that case I think the direction your character is facing should indicate which way you'll be swinging (because the alternative gets confusing, because you're effectively trying to get the mouse in the direction of a moving target). But I definitely want to be able to stand in the center of a 3x3 area and hit each and every spot with any of the major tools (I recall the hoe not wanting to hoe directly under my feet for some reason... mildly annoying, not a big deal though).

    So this is what I have come here and made an account to say: If you nixed the mouse-driven tool use, then please, either bring it back or allow players to choose which of the two general control schemes suits them. I see no reason to switch to a keyboard-driven system where you have to position your character facing specific spots in order to interact with them (except in combat).
    • Tamorr

      Tamorr Supernova

      Ummm... Wha? I do that all the time. Maybe your timing is off. did you have a controller plugged in? Don't know if that will cause a problem, but is possible even when just using mouse controls.

      The hoe thing I can understand why not below you, as you would be hitting your feet; literally. So the hoe is in front or where you aim the cursor. I had started a new game as well, after the update and was able to do so just fine. Did all my crops in that pattern 3x3 at a time. Love that about this game.

      Unsure is there is a control for such a thing in options, but might have to have a look at them; and maybe reset to default controls. Is there an option for that... I have not changed any of the controls, only settings related to the game above that area.

      Combat didn't bother me too much, just took a bit to get use to.

      I have no idea what might be going on with your install or config... confusing, as I have not heard of something like that happening before. hmm...
      • Kilyle

        Kilyle Void-Bound Voyager

        That turned out to be the issue -- which I only figured out after it started mysteriously moving my mouse to one side :rofl:

        My nephew had his controller plugged in, and apparently it was screwing up all the things. I'm not used to looking to see if there's a controller plugged in!

        I really panicked over this one, because I had just watched the Let's Play and my brain jumped straight to "intended behavior OH NOES" :D

        Thanks for trying to help! If I hadn't figured it out on my own, your comment would've led me in the right direction.
          Tamorr likes this.
        • Tamorr

          Tamorr Supernova

          Ah, so I had a good guess. Was the only thing I could think of, and glad it worked out. :nuruhappy:
          • Chlorruption

            Chlorruption Scruffy Nerf-Herder

            The thread's title made it seem so much more existential. :p
            • Borodin

              Borodin Oxygen Tank

              I figured he was an avatar for Camus.
              • Chlorruption

                Chlorruption Scruffy Nerf-Herder

                That'd be absurd.
                • Sorainthy

                  Sorainthy Void-Bound Voyager

                  Well nevertheless I have the feeling there is something wrong with keyboard and mouse control (no other Input Devices available).
                  Like 4 out of 10 3x3 Fields my Char is only watering the field infront of him even if the mouscourser is pointing to the correct crops.
                  Or if I fish... instead of in face view it goes above...
                  Or in Battle... instead of in front it goes above...

                  Always solved when I moved a bit. Anyone else with the same?
                  • Kickz

                    Kickz Space Penguin Leader

                    Yeah I've noticed some strange chopping direction while removing those stumps in the secret forest or trying to swing my sword.
                    • Sorainthy

                      Sorainthy Void-Bound Voyager

                      Anyone else? Before Bug reporting I would have at least 3-5 People with the same just to let Dev see it is easier to reproduce which can lead to a fast fix.
                      • Akanaro

                        Akanaro Great Scott!

                        The control scheme is the only gripe I have with this game. It's a little bit dumb because you basically have to be careful to click no further than any of the 8 squares surrounding your character or it goes of in some random direction. Even then it seems to sometimes just do what it wants to. Milking cows can be a pain sometimes because of this as the cows tend to move just as you click. In my opinion the whole control system needs to be changed to a smart cursor type setup like you get in Terraria. It's quite playable as it is but it can lead to a bit of frustration.

                        Share This Page