[WebApp] Stardew Checkup -- Achievement & Completion Progress

Discussion in 'General Discussion' started by MouseyPounds, Mar 10, 2018.

  1. Marley2011

    Marley2011 Lucky Number 13

    I don't know if I'm doing something wrong, or maybe it's my save file but I play single player and it just ends up not loading anymore then what is in the picture. This is my fist time trying to use this and it hasn't worked for me.

      Attached Files:

      otterden likes this.
    • prrprrprrprr

      prrprrprrprr Void-Bound Voyager

      Having the same issue as Marley2011, was working fine from start of game until I unlocked the island. Now it's choking at the same point as shown in their image. Running in Chrome, Game version current with two mods that alter the save serializer (PyTK and TMXL) and a handful of other QOL mods.
      • otterden

        otterden Intergalactic Tourist

        I would like to report a bug.
        That when I upload my recent save file, it says "working" with a blue loading stripe but never finished.
        Someone suggested me to use developer tool to check and appear to stuck at the NPC session.
        I triggered a group event that I entered Haley's house and all the ladies were angry at me. I think that might be the cause of it. Some says it will maintain the heart at 10 but they will became "single". If you need, I can upload related files

        Actually the same as Marley2011
        • dangerousdoris

          dangerousdoris Orbital Explorer

          I think it's definitely that cutscene that's triggering the bug. I also had the cutscene and couldn't get Stardew Checkup to work. The day the ladies forgave me, it worked again :)
          • oogpotlood

            oogpotlood Space Spelunker

            I have the same bug. Having some Javascript knowledge myself, I debugged the source. In stardew-checkup.js?v=4.0.3 on lines 1233 and 1235 the source uses npc[who].isDatable to count whether you have any Guys/Girls that you dumped, however it seems it should be meta.npc[who].isDatable as the npc-variable doesn't exist. When you have no dumped_Girls or dumped_Guys the source skips npc-variable (as the numeric check is already false), that's why it is automatically fixed the day the ladies/gentlemen forgive you.

            Edit: also I just noticed on line 1236 in the screenshot it says "nmeta.pc[who]" which I assume has to be "meta.npc[who]" as well

              Last edited: Mar 27, 2021
            • SeaBrightener

              SeaBrightener Space Hobo

              Update 1.5 spoilers

              Suggestion: Add a tracker for Qi's special orders

              Thanks for all your work!
              • kewlresist

                kewlresist Space Hobo

                What is this "mod fish"? I don't use any mods. I have been using this tool since long time and I have never seen this before.

                  Attached Files:

                • onejoeboy

                  onejoeboy Space Hobo

                  I read that some players have the same issue, but when i tried to get the information about my farmer it doesn't works. This file in particular it's played on a multiplayer, but all the singleplayer farmers works fine.

                    Attached Files:

                    • 1.PNG
                      File size:
                      27.7 KB
                  • chinsin24

                    chinsin24 Space Hobo

                    ah, now I know why my save wasn't working also. thanks!

                    I have the girls and guys mad at me atm...
                    • sandytiger

                      sandytiger Space Hobo

                      IDK why but I have gotten all checkmarks for my golden nuts but it still says I only have 129 of 130 gotten pic attached
                      • oddtom

                        oddtom Space Hobo

                        You're right- but also, the error is occurring because "npc" on line is supposed to be "meta.npc". Look at the variable name in the FOR loop on line 1231. That same error is made twice in that IF statement
                        • DDGamer

                          DDGamer Void-Bound Voyager

                          As stated at the bottom of the wiki page, you can (if you're on PC) open the chat window and enter /recountnuts to fix this problem. I don't know any way for consoles, sorry.
                          • DDGamer

                            DDGamer Void-Bound Voyager

                            Is it possible to add a list of items crafted to the Stardew Checker? I thought I had crafted everything in the game, but I can't buy the gnome hat from the hat mouse, for which crafting all items is a prerequisite.
                            • Spellbinder

                              Spellbinder Intergalactic Tourist

                              If you skip an event in Stardew will you get credit for it on the Checkup? I just had Emily and the sewing machine event and skipping half way through and I don't see the event noted in checkup. Please advise. Thanks in advance.
                              • susb8383

                                susb8383 Void-Bound Voyager

                                How is it possible to have an artifact "not found" but donated? How could I possibly have donated it if I didn't find it first?

                                  Attached Files:

                                • WhitneyFox

                                  WhitneyFox Void-Bound Voyager

                                  Hi @mousypounds
                                  I love this app and use it all the time. I recently added a bunch of mods that add NPCs and I've run into a problem with the social section of this app.

                                  Is it possible to add which mods NPCs come from in the Social section? I have a long list of NPCs showing as unmet, but I have no idea where they are coming from in order to find them and befriend them.

                                  • faeriemelia

                                    faeriemelia Space Hobo

                                    hiya! ive tried putting in my save file multiple times and it just wont load my info! I've restarted my computer, refreshed the website, closed my game, but every time I put the correct save file in it wont load, always just says it's "working" but the previous times I've done this it's loaded almost immediately :( any fixes? i haven't been doing this for long , and I haven't had any group cutscenes like mentioned previously in this thread so I'm not sure of the problem :)
                                    • CinnamonShake45

                                      CinnamonShake45 Space Hobo


                                      So i have completed all the puzzles, and found all the walnuts, but it showing like this on the tracker...
                                      when I checked using the Checkup-webapp it showed my like this... could this be because of doing all the gourmand crops at once???
                                      any way to fix this?
                                      • WhitneyFox

                                        WhitneyFox Void-Bound Voyager

                                        Hi Mousy, I love this mod, but I can never get to 100% met NPCs because several mods have "anti-social" NPCs that can't be befriended, so they always show as Unmet in your check up. Is there anyway to remove those NPCs?
                                        An example would be Ridgeside Village: https://www.nexusmods.com/stardewvalley/mods/7286. Belinda, Bliss, Helen, Lil Acorn, Raeriyala, and Sari are all Anti-Social and can't be befriended.
                                        • Kate57

                                          Kate57 Space Hobo

                                          First, thank you SO MUCH for making this tracker, as it has really helped me in finding the things I was missing!!

                                          I do have a question. I also play with SVE and Ridge Side mods and is there any way your tracker can check for things that need completed with mods, too? I have everything done except there appears to be one or two more things I need to craft and I don't have a clue about what is missing as I have crafted everything that I can make and get recipes for... or so I thought.

                                          Perfection Tracker.jpg Checkup - Perfection Tracker.jpg

                                          Share This Page