1. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Wargroove Release: Bugs and Fixes

Discussion in 'Support' started by Shubeans, Feb 1, 2019.

  1. Shubeans

    Shubeans QA Wizard Chucklefish

    *Edit:*
    A better running log of bugs can be found here:
    https://docs.google.com/spreadsheets/d/1aZZ-LKRLnSBvc2EtgPlFw3Fa_jyHy98niogZEYP_ZDc/edit?usp=sharing
    Please, please search for your issue before reporting it.



    Hello everyone,

    Wargroove is finally released!!
    Of course, as with any game, you may come across some bugs or issues that you'd like to let us know about. With any issues you find please use the tips below to help us understand the problem so we can get it fixed as quickly and smoothly as possible!

    Reporting Tips
    • If you're reporting a crash, please be as detailed as possible about what you were doing when it happened. This will help identify the issue much, much faster.
    • For any other issues as well, please be as detailed as possible about what you were doing in game so we can try to reproduce
    • Even if the issue has been reported, if you have new details please share!
    • Please let us know which platform you are having issues with; Switch, PC, Xbox, PS4?
    Below is a list of issues which we've identified since the release. If you're having a problem in this list marked 'need more details' it would be helpful to provide more info - we're still working on reproducing/determining a cause for these issues. If your issue isn't listed here then please be as detailed as possible reporting it so we can review. Always check you have the newest game/system updates before reporting an issue to make sure it hasn't already been fixed!


    Current Version:
    Steam: 1.2.0 #16507
    Switch: 1.2.0 #16404
    Xbox: 1.2. #

    Make sure you have the latest version before reporting issues. The game may have been updated.

    Colour Key:
    Fixed - This issue should be resolved in the recent update/next update
    In Develop - Fixed or have a solution in development for a future update.
    Investigating - We have reproduced or confirmed this is an issue, but are still developing a solution
    Need More Details - We're aware of the issue, but don't yet have enough information to reproduce/fix


    Reports
    Below are some reports from this thread, consolidated to make it easier to scan if an issue has been reported or to find common threads between reports for the same issue.

    Cannot launch on steam:
    Please try some of the fixes outlined here before contacting us about this issue:

    - Try Launching in Administrator mode:
    1. Navigate to your Steam install folder (Default: C:\Program Files (x86)\Steam).
    2. Right click the Steam executable.
    3. Follow the above steps to set it to Run as Administrator.
    4. Restart Steam.
    - Make sure your Media Package is up to date or installed: https://support.microsoft.com/en-us/help/3145500/media-feature-pack-list-for-windows-n-editions

    - Make sure that Visual C++ is update to date: https://www.chip.de/downloads/Visual-C-2010-Express_24081894.html

    - Remove any Joysticks and XInput Flight controllers you may have plugged in
    We're working on a fix for this!

    - Make sure all your drivers are up to date, including Windows updates

    - Run the game in OpenGL

    - Run the game with the launch peramiter '--skip-intro'
    1. Right click on wargroove in your library
    2. Go to 'properties'
    3. Select 'set launch options'
    4. Type --skip-intro into the text bar.
    - Run sfc /scannow in the command prompt; this will find and replace any corrupted files that might be causing the issue

    - If you are getting error message 'GL pixel Format not available' and are on Windows 7, you probably have your monitor set to use 16 bit colour depth. Here's a guide on how to change it to 32bit: http://www.sevenforums.com/tutorials/258-color-bit-depth-display-settings.html

    - Error message 'Node'~' (null) at "(1:1)" is not a map type' on launch.
    This is caused by corrupted save files, please make sure the game saves before turning off your pc or alt-F4ing.

    Fix: Take out the PlayerProgress file found in %appdata%/chucklefish/Wargroove/Saves
    Rename the file 'playerProgress.bak', and remove the '.bak' from the name.
    Make sure Steam Cloud is disabled for Wargroove
    Relaunch the game.

    If this doesn't work, try removing the 'achievements' file. Don't worry, you won't lose progress here!

    - Error message 'Node'~Language' (null) at "(1:1)" is not a string type' on launch.
    Go to %appdata%\Chucklefish\Wargroove\save_local and delete the options file there

    If none of these work please contact us either here, or with an email to contact@chucklefish.org with your PC specs and OS!

    All Platforms:
    • Using DPad while Battle animations/FoW is active will move the cursor and change viewpoint
    • Prologue displaying white cutscene
    • Directional keys still work during battle animations, causing view to be off-centre when returning to map
    Steam:
    • Game not launching on steam - Please see instructions above
    • Game not launching with Windows 8.1 - Please see instructions above
    • Crash After PC shutdown/crash - Error message 'Node'~' (null) at "(1:1)" is not a map type' on launch. - This is caused by corrupted save files, please make sure the game saves before turning off your pc or alt-F4ing. Please contact us if this happens to you.
      Fix: Take out the PlayerProgress file found in %appdata%/chucklefish/Wargroove/Saves
      Rename the file 'playerProgress.bak', and remove the '.bak' from the name.
      Make sure Steam Cloud is disabled for Wargroove
      Relaunch the game.
      Crackly/popping/skipping Audio
    • Workaround: Is OBS or another Streaming software running in the background?
      Workaround: Disable any Virtual Audio Cable and output directly to audio device
      Workaround: Try launching in OpenGL?
    • No Audio
      Workaround: Try launching with ' --audio-device=2 ' as a parameter in 'set launch options' of Wargroove steam properties
    • Game crashing after controller disconnects
    • Having 2 controllers plugged in causes game to crash when one disconnects
    • Crash when selecting Dpad on PS4 controller
    Switch:
    • Lost progress after saving
    • System Error after losing Online match
    • Non-Primary console crashes when returning from sleep mode
    • Audio issues when docking/un-docking console
    Xbox:
    • Unable to launch/install Might be caused by Xbox Live being down. Please check this, and restart the console.
    • Multiplayer game crashing when user goes to home screen
    If you are reporting a crash, please add the 'log' text document from the folder AppData/Roaming/Chucklefish/Wargroove to your comment.

    These reports are not confirmed bugs, this is just a list of report posts formatted for readablity. If your issue is not listed here that doesn't mean it's not being read/acknowledged! If an issue is determined not to be a bug it will be removed from this list to keep it readable.
    We plan to continue to collect reports and identify issues to include in updates, but we'll need player reports to be as detailed as possible in order to properly identify/fix bugs. Our priority obviously will be any bugs which impact gameplay like crashes.
    While some issues have threads dedicated to them - posting details either here or in the corresponding thread would be helpful - we'll do our best to make sure any new info/workarounds are communicated in both places to make sure players can find that info easily.
    If you're reporting a bug which was originally reported outside the forums please make sure to add a link to the original post - we may need to contact that player directly for more details.
    We're going to continue monitoring these and any newly reported problems, so please provide as much information as possible for any issues you may run into! We've worked really hard on this, and hope you enjoy Wargroove!

    Thanks everyone!!
     
      Last edited: Mar 6, 2019
      Captain Rage likes this.
    • some_guy_24

      some_guy_24 Space Hobo

      Hello,

      On attempting to launch a game through steam the game will provide the option for regular or open gl launch.
      After selecting either, steam will say preparing to launch then will just stop running the game.

      I was able to launch the game only when I launched steam in administrator mode. (tip mentioned in thread linked below)

      Edit - The game runs with steam in admin mode but the campaign appears to crash when trying to access it.
      Edit 2 - Also crashes if trying to launch a multiplayer game option


      System;
      Win 10
      i5 3570k
      nvidia 970
      8gb ram

      https://steamcommunity.com/app/607050/discussions/0/1778261844036899756/
       
        Last edited: Feb 1, 2019
      • Shubeans

        Shubeans QA Wizard Chucklefish

        Heya, sorry about the launch issues your having! I've just commented on the steam discussion as well.
        We think we've narrowed it down to Window usernames having non-English characters. Are you able to confirm that your user account has this?
         
        • Sleeper_Service

          Sleeper_Service Space Hobo

          On the tutorial mission where you first get to recruit things: I attempted to move my ranger before recruiting and now I'm softlocked in the move menu state. Wherever I click I just get the "We should select our barracks and recruit a new unit." message. Can neither recruit nor move nor exit the game. (Super small complaint, the game has some of the best pixel art and animation I've ever seen, I'm blown away overall. <3)

          /Edit: Oh hey, it even autosaved on the start of the turn, thanks for that, very considerate.
           
          • lukemasters

            lukemasters Space Hobo

            I cannot launch through Steam. My username doesnt have any strange characters and the game still will not launch.
             
            • Wargod Patriot

              Wargod Patriot Space Hobo

              E5A1B881-6B63-4CA3-BEFB-E725D6EC0E82.jpeg On my Xbox one in the campaign mode very first mission after I kill first guy then end turn the king says “ it’s time it’s time my daughter knows the truth but how do I tell her and then the game freezes I tried restarting and reinstalling the game every time it stops right there?
               
              • Jaizu!

                Jaizu! Big Damn Hero

                I have the same problem as the sir above me. The game does not freeze, audio still going, but I can't just press the A button. I tried with my arcade stick and my xbox 360 controller and isn't happening.
                It fixes when I use my mouse, but then, I can only play with my mouse and not with my controllers, which kinda sucks.
                I'm using Windows 10 and the Steam version, if you need more details please let me know, but looks like an xinput problem in the game, not happening in other games.
                Edit: The first small update was applied when I tested this, and still happening.
                 
                • Shubeans

                  Shubeans QA Wizard Chucklefish

                  Heya, I think this might be an issue with the controller, could you send me a quick screenshot of your controller properties?
                   
                  • Jaizu!

                    Jaizu! Big Damn Hero

                    Hi, my controllers are fine. I'm using the XBOX 360 wired by Microsoft and a MAYFLASH ARCADE FIGHTSTICK F101 in XINPUT mode. The game doesn't have any controller properties, but Windows do, so I asume you want those. They are here: https://imgur.com/a/vLlfcHv

                    Both, the xbox and the mayflash controller work fine in another games, just tested. They also work in those Properties windows, everything is fine. I can also skip the first dialogues with the A button, but then it doesn't let me to.
                     
                    • Shubeans

                      Shubeans QA Wizard Chucklefish

                      Does it work if you unplug the mayflash controller and only have the xbox one in?
                       
                      • Cairn1111

                        Cairn1111 Space Hobo

                        Hi guys!
                        I'm having very poor audio quality on Steam. It's cackling and I can hear some static.
                        I do have OBS installed but it is not running!

                        Thanks for your hard work.
                         
                        • Wargod Patriot

                          Wargod Patriot Space Hobo

                          It’s up and running now thanks guys not sure what you guys did but it worked
                           
                          • Shubeans

                            Shubeans QA Wizard Chucklefish

                            YAY! Xbox live was down, it could have been messing with your save files. Enjoy Wargroove ^_^
                             
                            • Jaizu!

                              Jaizu! Big Damn Hero

                              I tested more and more with the latest update. The XBOX 360 controller always works. My second controller (arcade stick, XINPUT) works at the start, but at some time stops working (I can still using the xbox controller). I tested my arcade stick in other games and it never happens. I think the bug happens when I press A too soon o not at the right time when a dialogue it's happening.
                               
                              • beattie-19

                                beattie-19 Space Hobo

                                Only a small spelling issue from me. On an early mission where the Knight is introduced 'seems' is misspelled as 'semes'. It tells me my image is too large to upload but I imagine it will be easy to find the string in the code.
                                 
                                • Dawncaller

                                  Dawncaller Intergalactic Tourist

                                  Switch: When pressing directional keys while a unit is moving or fog of war is being adjusted these selection field movements are still evaluated and once movement is over the selection field is out of your viewport. Using a directional key then will switch to the correct view again.

                                  Another issue: When you end your turn and the enemy turn plays outside your viewport then you don't refocus on the initial viewport once you return. If you open the menu by clicking A then, the menu is also opened outside of your viewport.

                                  Edit: Don't know if relevant but I am using the directional buttons, not the stick.
                                   
                                  • Shubeans

                                    Shubeans QA Wizard Chucklefish

                                    hehe, it's small but thank you for reporting it :) This one should be fixed in the next patch

                                    @Dawncaller thank you for these, I'll give them a test on my end!
                                     
                                      Dawncaller likes this.
                                    • Dawncaller

                                      Dawncaller Intergalactic Tourist

                                      Switch, Archer unit does not recalculate minimum movement distance needed to take a shot when switching between two enemy units that require different movement distances to shoot. When switching to a field tile in between, calculation is right again.
                                       
                                      • Dawncaller

                                        Dawncaller Intergalactic Tourist

                                        When scrolling through the border tiles of a map bigger than your viewport from the lower left to the lower right and from the lower right to the upper right corner, the viewport changes abruptly. Doing this from the upper right corner to the upper left and from the upper left to the lower left is a lot smoother.

                                        Edit: Act 3 Mission 1
                                         
                                        • Foree

                                          Foree Space Hobo

                                          Hello

                                          The game crash after the intro
                                          My cat unplugged my PC when I played and now I have this error
                                          I played 4 maps
                                          Uninstall and install the game and do not fix

                                          STEAM


                                          (This message is translated from Spanish, sorry for the spelling mistakes)

                                          Help me pls:(
                                           

                                            Attached Files:

                                          Share This Page