1. This forum is primarily for mobile related issues - for support for PC/Console visit the support section of forums.stardewvalley.net

Bug/Issue v1.2: Action key not working

Discussion in 'Support' started by jieun92383, Apr 26, 2017.

  1. jieun92383

    jieun92383 Intergalactic Tourist

    After my stardew valley was updated to the version 1.2, the action key (default: X) seems not working.
    For example, I can go in front of TV and press X to trigger an action on TV. But after that, X stops working at all.
    Pressing X does not select any options, and does not skip the letter-typing-motion either.
    I used to play mostly (99% except for dragging) with keyboards, and now I am forced to use a mouse ...
    Can you please look into this, and when the game is developed, please keep in mind that there are players who prefer to play with keyboards :)
     
      I'm so scared likes this.
    • Corraidhín

      Corraidhín Supernova

      Oh, have you tried rebinding the key? change it something different, try with that key, then change it back to X!
       
      • adh8vb

        adh8vb Void-Bound Voyager

        I'm having the same problem! It just randomly started this morning after nearly a year of normal game-play. The action button (X) will trigger a dialogue screen, but once that screen is up, X has no further actions (I have to left-click on the screen for the dialogue to disappear, X or esc won't. work. at. all).

        Tried rebinding the key
        Tried starting a new file
        Tried reinstalling Stardew
        Tried some stuff with anti-keylogger software (because I read some people had issues with that)

        Any other suggestions? They would be greatly appreciated!
         
        • Corraidhín

          Corraidhín Supernova

          Hmm... I do not seem to be able to reproduce this issue, the only thing I can suggest is to post your log file (most recent of course) here along with
          .
           
          • adh8vb

            adh8vb Void-Bound Voyager

            Latest log file (for the newest game I made just to test out my fixes). Still having the same problems. A good example is my interaction with Shane in this particular save, if that is any help...

            Thoughts? And thank you!

            (Is a .txt file what you would want? I literally have no idea)
             

              Attached Files:

            • margotbean

              margotbean Phantasmal Quasar

              Same problem here. The game constantly asks me if I want to eat <some item> -- it happens while collecting eggs in the coop and sometimes when filling rows of kegs/preserves jars. I used to be able to hit "E" (actually I rebound it to "Enter" since I use the arrow keys instead of WASD), but now I have to manually move the mouse to the dialog box and click "no." This is a deal-breaker.

              Please, please, fix this asap.
               
              • ellindsey

                ellindsey Space Spelunker

                I have this problem too. I can no longer use the X key to end a conversation, or the escape key to close out of the "Do you want to eat <something>?" dialog that so often comes up by error while I'm reloading my kegs. This is very annoying.
                 
                • jamessbonds

                  jamessbonds Space Hobo

                  I'm having a similar problem with my X key, but primarily I'm not longer able to separate a single item from the stack in my inventory. Are any of you also having this problem?
                   
                  • iamthepinky

                    iamthepinky Void-Bound Voyager

                    here to report the same issue with the X button no longer working. I can't fast forward through or close out dialog, can only do so with a hard click.
                     
                    • eteocles

                      eteocles Space Hobo

                      Same issue, please fix. Created an account just to post here.
                       
                      • ellindsey

                        ellindsey Space Spelunker

                        With the latest patch, I can now use the Escape key to exit out of the 'Do you want to eat/drink <item>?" dialog. Still can't use the X key to exit conversations.
                         
                        • azari

                          azari Space Hobo

                          I also have this issue. I can no longer use X to fast forward through or close any dialogue boxes. I prefer to use my mouse as little as possible and mostly play with the keyboard so this really hampers my gameplay. Would really appreciate a fix asap! :)
                           
                          • MeriStrawberries

                            MeriStrawberries Space Spelunker

                            Same here.. It's getting very annoying but now at least I know it's a bug and theres nothing wrong with just my game which is comforting.. I hope there is a fix soon..
                             
                            • Aarix

                              Aarix Space Hobo

                              This is happening to me as well! Hope it can be fixed soon :0
                               
                              • vfarew

                                vfarew Aquatic Astronaut

                                Hey I am returning the game after several months and I noticed this bug too. Any updates on this?
                                 
                                • sventastical

                                  sventastical Void-Bound Voyager

                                  I'm also having this issue. Is there any word on a fix? It's so annoying :'(
                                   
                                  • Snuugel

                                    Snuugel Intergalactic Tourist

                                    I have exactly same problem, did anyone find fix to this?
                                     
                                    • sundrop

                                      sundrop Orbital Explorer

                                      Registered to report I am also having this issue on Mac, not using any SMAPI mods currently. Anyone find any solutions or workarounds?
                                       
                                      • banannigans

                                        banannigans Space Hobo

                                        I'm running into this same issue on Mac as well, makes playing the game on a laptop without a mouse much more frustrating than it needs to be.
                                         
                                        • aaron-baugher

                                          aaron-baugher Intergalactic Tourist

                                          Same issue here with version 1.2.33 on Ubuntu 16.04. Any chance of a fix or mod for this yet? As much as I'd like to play the alternative maps and use mods, reaching for the mouse at every dialog is brutal. I may have to just downgrade to the old version.

                                          Edited to add: last night I forced myself to play with WASD and using the mouse for dialogs and questions. It's a little awkward for this old gamer who's used to either the keyboard OR the mouse, but I think I can get used to it. Seems like that's the way games are going these days anyway.
                                           
                                            Last edited: Feb 9, 2018

                                          Share This Page