1. Please be advised of a few specific rules and guidelines for this section.

RELEASED Uros IV (RAM's version) V 4.0

A ship that's a small, domed world.

  1. bk3k

    bk3k Oxygen Tank

    did you extract it from the zip? That would be my first guess.

    My second guess would be you did extract the files, but with too much folder nesting. Namely it looks like
    starbound/girraffe_storage/mods/Uros IV (RAM's version)/
    and within that are the folders
    Uros IV (RAM's version) - Apex
    Uros IV (RAM's version) - Avian

    etc. Those are the folders that should be in your mods folder directly. Starbound is looking for (whatever filename).modinfo and won't look more than 1 folder deep from the mods folder.
  2. Xward

    Xward Void-Bound Voyager

    Aaaaah yeah that was the problem, thanks
  3. greenRAM

    greenRAM Giant Laser Beams

    I see. With the next update I'll make sure to make that more obvious.

    The next update might be a little bit as I'm trying something new before releasing the 1.0 update. I'm crossing my fingers that it works out.
  4. greenRAM

    greenRAM Giant Laser Beams

    greenRAM updated Uros IV (RAM's version) with a new update entry:

    New version for 1.0

    Read the rest of this update entry...
  5. ryuguy20

    ryuguy20 Scruffy Nerf-Herder

    Hi I downloaded this ship and it works for all races except for the novakid it gives me an error. 20160723220324_1.jpg
  6. MrRazerWolf

    MrRazerWolf Void-Bound Voyager

    I get the same error as ryuguy20 with the Avali races, any idea what causes it?
  7. Zalexard

    Zalexard Subatomic Cosmonaut

    I hope you eventually port this one to the workshop too, been anxiously waiting for it. :p
  8. KattenM

    KattenM Void-Bound Voyager

    Super strange, I'm getting that too
    Last edited: Jul 28, 2016
  9. Dukoth

    Dukoth Big Damn Hero

    I get the error with the novakid, but it doesn't work at all with the Avali for me (I just get the default ship)
  10. greenRAM

    greenRAM Giant Laser Beams

    Darn. I'm going to have to figure this out. Looks like there was a name change in the material. After I figure it out I'll give this an update. I'll see if I can get the Avali up and working again too.

    Edit: got the novakid ships working again. The Avali ship is still giving me trouble. Maybe I'll sleep on it for now. If I can't figure out what's wrong with the Avali tomorrow then I'll just upload the novakid fix at least.
    Last edited: Jul 31, 2016
  11. greenRAM

    greenRAM Giant Laser Beams

  12. greenRAM

    greenRAM Giant Laser Beams

    greenRAM updated Uros IV (RAM's version) with a new update entry:

    v3.2 Rain!

    Read the rest of this update entry...
  13. Fire_snake

    Fire_snake Scruffy Nerf-Herder

    Found a bug. When you havnt install apex ship, the avian and other (tested only on avian) ship crashed with this error:
    [Error] UniverseServer: error during world create: (ObjectException) No such object named 'apexrainmaker2000'
    P.S. Sry for my eng :nurutease:
    greenRAM likes this.
  14. greenRAM

    greenRAM Giant Laser Beams

    Thanks! Sounds like I fumbled something related to the references to their respective object names. I'll go back in and have that fixed. I guess I didn't catch that on testing because I was using them all at once to save time. Thanks again for letting me know.

    edit: Looks like it was just the Avian that had the error.
    Fire_snake likes this.
  15. greenRAM

    greenRAM Giant Laser Beams

    greenRAM updated Uros IV (RAM's version) with a new update entry:

    Quick bug fix!

    Read the rest of this update entry...
  16. greenRAM

    greenRAM Giant Laser Beams

    greenRAM updated Uros IV (RAM's version) with a new update entry:

    v3.3 More fixes and details

    Read the rest of this update entry...
  17. Crusism

    Crusism Big Damn Hero

    Is there a way to change the ship of a save game?
    Because I'm playing as the Argonian custom race, and I'm not exactly sure how to have my custom race use this ship along with me wanting to preserve my save (is this even possible?). My current save uses a tier 3 ship.

    But I've tried this mod on one of the common races (i.e. Glitch) and I really love it. Some insight and help would be greatly appreciated on guidance to achieving this mod. >_<

    Also, is it possible to make this mod optional (as I'd like the option to switch to this ship or to keep to the normal ship)? Maybe through a quest?
  18. BlueLeafeon

    BlueLeafeon Cosmic Narwhal

    Somewhere between the first and second ship size is the perfect size for me. Can you release an alternative version with a size between the two?
    Crusism and Fire_snake like this.
  19. greenRAM

    greenRAM Giant Laser Beams

    Unfortunately, you need a new character for this ship. To make the blocks not respawn with each upgrade I had to make it so this is only usable with new characters starting from the t0 broken ship. This was made usable for the Avali custom race already. Making it available for other custom races would require the same amount of care. For instance, the Avali ship has a slightly altered blockkey.config file, it's own rainmaker object, renamed ship structure files, and a universe_server.config patch. Using the Avali ship as a base, you should be able to make other custom race ships. I'm not all that interested in making a lot of custom race support myself; though, feel free to use any of my files as a base to put something together for yourself. If you decide to publish the custom race support, please get the permission of the original mod author first, as he put a lot of love and creativity into the original design.

    Do you mean something smaller then the first full upgrade, but bigger then the dropship? If that's what you mean, it would require new art being added. I'm not willing to put that much effort into something like that right now, but it sounds like a really neat idea. It would be neat to add a gradual increase in size from T0 to the main T4 upgrade. That would require creating three new ships... I'll keep the idea in the back of my mind and if I get inspired or bored I may end up working on it.
    Crusism likes this.
  20. TenkoKuugen

    TenkoKuugen Scruffy Nerf-Herder

    EDIT: Looks like it IS a general bug after all as even people without mods get it.

    For some reason my ship is reset to default state of the current tier after updating to 1.1
    I spent close to a 100 hours building my ship, that's not something I want to go through again, not to mention the myriad of containers I would lose
    I virtually haven't changed anything but updated frackin universe, which shouldn't matter.
    It isn't a general bug as my other character, using a vanilla ship, still has the same vanilla (but heavily re-walled) ship as the save file says.
    I basically tried using the exact same mods, using only the absolutely necessary mods (frackingraces, universe, uros) and various in-between (copying the backup save file folder entirely, just in case, about 40 times), login, save the reset ship, override with shipworld file and login again, nothing works.
    The log is not showing any errors either.
    It's like something in the Uros causes it to reset when you enter it in 1.1 for the first time. I saves changes after that fine but if you update from 1.05 to 1.1, you are going to lose your Uros
    I hope you find a fix for this because I am not gonna build a big ship again, I'll just stack stupid containers everywhere.

    Unrelated but also: 1.1 is throwing a lot of Avati errors in the log that 1.05 did not throw and I never touched any Avati mods. Turns out you can get rid of that by deleting the avati uros folder from the mod directory.
    Last edited: Sep 10, 2016

Share This Page