Modding Help Updating mods for Stardew Valley 1.4

Discussion in 'Mods' started by Pathoschild, Jul 2, 2019.

Thread Status:
Not open for further replies.
  1. Ellie'sFarm

    Ellie'sFarm Void-Bound Voyager

  2. Van_Tastic

    Van_Tastic Space Hobo

    Does this still work with the latest SDV and SMAPI releases ? This is what I get when I try to run it:
    • jvvbarros

      jvvbarros Space Hobo

      the deluxe auto grabber insnt working, can u fix it pls? when i put the auto grabber he dosent pick up the truffles for exemple, even when i put true on the config to pick up truffles
      • zStormborn

        zStormborn Orbital Explorer

      • AkaneSaikyo

        AkaneSaikyo Void-Bound Voyager

      • revalleria

        revalleria Void-Bound Voyager

        Hey man...
        Sometimes the grabber doesn't work, the smapi log says "Global Forager is full" when that happen ..

        Any way to fix that ?

          Attached Files:

        • honorelle1702

          honorelle1702 Void-Bound Voyager

          The original mod author is working on it, but RL and the complex changes made to 1.4 are making it slow progress. If Teh is already working on it, noone else is going to interfere.
          • Theotherore

            Theotherore Intergalactic Tourist

            I second this!!! Being able to have a second farm / a way to buy a second plot of land is perfection! wish it worked though..
            • BunnyX

              BunnyX Aquatic Astronaut

            • Mendaere

              Mendaere Space Hobo

              Here's an unofficial update for TehPers.FishingOverhaul for SDV 1.4 and SMAPI 3.5. I have sent a pull request to the author, who asked that I post this unofficial update until an official one is completed.

              Changes since last official version:
              - Updated code to work with SDV1.4/SMAPI 3.5
              - Fixed a bug that could result in a second catch starting while opening a treasure from a first catch, putting the mini-game into a loop.
              - Added fish data for the new 1.4 "four corners" map. Not sure if its correct.
              - Fixed bug where white algae was not catchable in the mines
              - Fixed bug where green algae was incorrectly catchable on the submarine (sub trash should be seaweed & pearl only)
              - Changes to make fishing from fish ponds work correctly
              - Fixed night market version of the beach so fish were catchable (not just trash)
              - Fixed a display bug in the HUD when there were 6 available fish. Made the maximum number of fish displayed in the HUD configurable.

                Attached Files:

              • Akira Kido

                Akira Kido Space Hobo

                This version can't work on my android can you fix it?
                • zStormborn

                  zStormborn Orbital Explorer

                  Guess what... Someone did. Also, if you went on TehPers Nexus page and did some reading you would have seen that he is willing to allow someone to update it.
                  • smilethief

                    smilethief Void-Bound Voyager

                    The addon loads fine, but the none of the warps work. I looked at the config.json file and the FastTravelPoints had been set to null. I replaced the config.json with the config.json from your previous update for 1.3 and the warps are working again. I also added an entry for the Movie Theater (duplicated JojaMart entry and changed MapName). I hope this helps with any future updates or anyone troubleshooting issues with the mod.

                    "MapName": "Movie Theater",
                    "GameLocationIndex": 46,
                    "SpawnPosition": "95, 53",
                    "RerouteName": "Town"

                    -EDIT- Through testing, there were entries for Abandoned JojaMart and Pam and Penny's upgraded home missing as well. Added the below entries.
                    "MapName": "Abandoned JojaMart",
                    "GameLocationIndex": 46,
                    "SpawnPosition": "95, 53",
                    "RerouteName": "Town"
                    "MapName": "2 River Road",
                    "GameLocationIndex": 11,
                    "SpawnPosition": "72, 71",
                    "RerouteName": "Town"
                      Last edited: Jun 17, 2020
                    • Dakmordian

                      Dakmordian Subatomic Cosmonaut

                      I was wondering if it'd be possible to get an update for Catty's Safe Lightning mod? It's been quite a few months and still doesn't appear to be working correctly. Besides my own experience with it not protecting my crops, there's been others who posted on the mod page with issues, and none of us have seen SMAPI list any actual errors for us to post logs from.
                      • angelyuki

                        angelyuki Void-Bound Voyager

                      • wally232

                        wally232 Void-Bound Voyager


                        We have an unofficial version.
                        Doesn't it work?
                        • Dakmordian

                          Dakmordian Subatomic Cosmonaut

                          Well, SMAPI says that one is out of date, but the real issue is neither of them seem to be fully protecting the farm.
                          • daylightstanding

                            daylightstanding Yeah, You!

                            Are you using Android? The unofficial update for Prismatic Tools doesn't properly display the updated tool icons in Clint's shop. I recommend just using the sprinklers if you're on Android. It works fine for PC/Mac though.
                            • forthepatch

                              forthepatch Void-Bound Voyager

                              Would it be possible to get another update for Deluxe Autograbber? I know it already got one, but it doesn't seem to be working for me...
                              • hellsangel101

                                hellsangel101 Aquatic Astronaut

                                Hi all!
                                Sorry to bug you guys but I've run into a problem with Expanded Fridge. I have the unofficial update and it was working for a while but now when I try to access it the fridge menu doesn't pop up, the fridge stays open, and my game lags really badly. Heres my Smapi log:
                                Thank you!
                                Thread Status:
                                Not open for further replies.

                                Share This Page