Modding Help Updating mods for Stardew Valley 1.4

Discussion in 'Mods' started by Pathoschild, Jul 2, 2019.

  1. MouseyPounds

    MouseyPounds Cosmic Narwhal

    You don't have the most recent unofficial update. You have unofficial-2 and the version in the post you are quoting is unofficial-4.
     
    • Inalleon

      Inalleon Subatomic Cosmonaut

      Oh okay. Didn't notice without the key reminders lol
       
        Last edited: Dec 30, 2019
      • Digus

        Digus Ketchup Robot

        Here's FeTK updated for Stardew Valley 1.4, SMAPI 3.0 and compatibility fix for Mail Framework Mod. (I sent a pull request to the author.) Not compatible with Stardew Valley 1.3.36.

        Changes since the official versions:
        • Updated for Stardew Valley 1.4 and SMAPI 3.0.
        • Internal refactoring.
        • Compatibility with
         

          Attached Files:

          Neferatem, Echy and asqwedcxz741 like this.
        • limeplupo

          limeplupo Aquatic Astronaut

          dont worry! theres actually a project for that in the works; martyrpher is developing a mod called 'get glam' that will try to add the functionality of kisekaes personalization into 1.4 to the new clothing system. customize anywhere is still going to be in place for all clothing. but for accessories and body/face shape, get glam will be the mod to use. shoes still arent considered items so where theyll fit into all of this is really tricky! my work in get glam right now is trying to create different body presets for farmers. this is most likely going to be a lot of work and take a lot of time, but it will definitely be worth it in the long run :)
           
            Frostnovafive and roflblah like this.
          • SorryLate

            SorryLate Poptop Tamer

            HopeWasHere likes this.
          • ahhh_reptar

            ahhh_reptar Void-Bound Voyager

            Anyone able to update Stardew Valley Randomizer?

            Code:
            [04:09:46 TRACE SMAPI]    Stardew Valley Randomizer (from Mods\Randomizer\Randomizer.dll)...
            [04:09:46 TRACE SMAPI]       Broken code in Randomizer.dll: reference to StardewModdingAPI.IAssetDataForDictionary`2<TKey,TValue>.Set (no such method).
            [04:09:46 TRACE SMAPI]       Broken code in Randomizer.dll: reference to StardewModdingAPI.IContentHelper.NormaliseAssetName (no such method).
            [04:09:46 TRACE SMAPI]       Broken code in Randomizer.dll: reference to StardewModdingAPI.Events.SaveEvents.add_AfterCreate (no such method).
            [04:09:46 TRACE SMAPI]       Broken code in Randomizer.dll: reference to StardewModdingAPI.Events.SaveEvents.add_AfterLoad (no such method).
            [04:09:46 TRACE SMAPI]       Broken code in Randomizer.dll: reference to StardewModdingAPI.Events.GameEvents.add_UpdateTick (no such method).
            [04:09:46 TRACE SMAPI]       Broken code in Randomizer.dll: reference to StardewValley.Game1.currentSong (field returns StardewValley.ICue, not Microsoft.Xna.Framework.Audio.Cue).
            [04:09:46 TRACE SMAPI]       Broken code in Randomizer.dll: reference to StardewValley.Game1.changeMusicTrack (no such method).
             
            • vickimed

              vickimed Aquatic Astronaut

              Either QP or AQP is not working correctly for me. Everything comes out base value regardless of the quality of the items I put into the machine (any machine but base ones currently). No errors in my smapi log, and I have these versions of the mods. Is this to be expected, or should the products coming out be the same as the items going into the machine?
               
              • MouseyPounds

                MouseyPounds Cosmic Narwhal

                Here's an unofficial update for Animal Chooser with BFAV integration. It is based off of Paritee's fork but with a small fix to avoid index out of range errors.
                 

                  Attached Files:

                  snowflakexlove and Neferatem like this.
                • Wingyl

                  Wingyl Void-Bound Voyager

                • Benigni

                  Benigni Aquatic Astronaut

                • Raiyna

                  Raiyna Scruffy Nerf-Herder

                  Hey, there! I've got an issue with my greenhouse and I'm really not sure which mod is causing the bug, because it didn't happen until today.

                  Here's the link to my SMAPI error log: https://smapi.io/log/e4b01a9451f14b6fa65fe9ed2727285d

                  I can enter my greenhouse and walk around it just fine, but when I try to walk into my garden, the player model gets stuck and the error messages flood the SMAPI console.
                  It looks like it's saying something is wrong with the HoeDirt tiles and they're preventing me from walking on them. This does not happen in the overworld, though, because
                  I've dug up artifacts and have been able to walk over them just fine. I can plant winter seeds to see if the seeds have any effect, if you'd like.

                  The most recent mods I've installed are Looking for Love, NoClip Mode, Zoom Mod and Lunar Disturbances - but I had them installed last night and didn't have this issue with
                  the greenhouse then. One other thing of note is the bridge to the quarry was broken last night? But this afternoon when I started up the game again, the bridge was repaired.

                  I do not use a mod manager, I just place them directly in the Mods folder. I play in Windows 10. If you need any other info, let me know!
                   
                  • Wingyl

                    Wingyl Void-Bound Voyager

                    Where's the rest of your log, Raiyna? That's only part of it. I'm surprised the site didn't complain about the incomplete log.
                     
                    • Raiyna

                      Raiyna Scruffy Nerf-Herder

                    • Wingyl

                      Wingyl Void-Bound Voyager

                      Firstly you have outdated mods.

                      Secondly, something is null, and you deleted all objects from your farm and then things are null a lot, according to the log.

                      This might require save file editing; can you post your zipped save file?
                       
                      • Raiyna

                        Raiyna Scruffy Nerf-Herder

                        Those mods have been "outdated" for a couple of weeks now... I've tried redownloading and reinstalling them, but it keeps saying the same stuff. I've checked
                        the dates that the mod updated the files, too, and none of them should be newer than what I have (unless I'm just f'ing blind LOL)

                        I actually didn't delete all objects, I put in the command and it asked if I really wanted to do so, and told me to input a new command to delete which I didn't enter.

                        I can post my save file, though! One sec.

                        EDIT: hopping in the shower rq, brb
                         

                          Attached Files:

                        • Jellysie

                          Jellysie Intergalactic Tourist

                          Hi! When I tested FeTK for Tool Upgrade Delivery Service (I got the unofficial update from Pathoschild here), the recipe letter I received was blank at the bottom of the letter where the supposed new recipe is. I removed FeTK and opened the letter again and the recipe was there so I assumed that this was the issue.
                           
                          • Creepydark

                            Creepydark Aquatic Astronaut


                            I have a problem with the mod, I do not know if I am the only one, I already have 3 skills at level 10 and none detect me to continue generating experience in smapi, the mod is active and everything but I do not find an answer on how to solve that error: (
                             
                            • DuskTake

                              DuskTake Void-Bound Voyager

                              Space didn't updated the nexus version, download they mods from here https://spacechase0.com/mods/stardew-valley/more-buildings/
                               
                                Benigni likes this.
                              • Raiyna

                                Raiyna Scruffy Nerf-Herder

                                I've gone and updated all of the mods that needed it (after deleting them entirely from the mod folder before doing so) and will let you know how it goes.

                                EDIT: OK. SAD TO SAY but this issue really wasn't fixed. I went and rolled back a save to Fall 24 of year 2 and replayed the same week again with no hiccups. None. I went into the greenhouse plenty of times and had no issues. Then, again on Winter 4, I had the issue. The same day it happened before I tried all of these fixes.

                                I'm really at a loss for what the issue is, because everything points to the custom FARM map that I'm using. When I uninstalled it and played Winter 4 (before rolling back saves) it was working fine. I don't understand why on Winter 4, specifically, the map decides to not work?? I even went forward another day to Winter 5 and the issue was still there. And why, too, the map affects the greenhouse... Of all things.

                                I'm going to try and uninstall the map for a few in-game days and then re-install it. Maybe that will help? If anyone can go digging through the code and figure something else out, that'd be helpful.

                                Logs: https://smapi.io/log/433be416ccf140e4841b90e70940d3dc

                                ** Also, if someone could tell me what the hell "Hobbit Hole House" is, I'd be really grateful. I have no f'ing clue what mod that is or why SMAPI tells me I have it.
                                 
                                  Last edited: Dec 31, 2019
                                • vickimed

                                  vickimed Aquatic Astronaut

                                  Yep, this is my issue. Vanilla seems to work, but AV does not. Let's hope it does in the future! Thanks so much for the reply, and answer. :)
                                   

                                  Share This Page