Modding Help Updating mods for Stardew Valley 1.4

Discussion in 'Mods' started by Pathoschild, Jul 2, 2019.

Thread Status:
Not open for further replies.
  1. Courtesan

    Courtesan Void-Bound Voyager

  2. huancz

    huancz Subatomic Cosmonaut

    Ok, this one was nasty. I'm still afraid that the code I wrote will bite me if I look at it wrong. But the fix seems to work - buying animals, animals going for a walk and returning inside in the evening, hoppers pulling hay from silos (on main farm), autofeeders... I'm not sure what else could have been affected.


    Here's bugfix release for Farm expansion for Stardew Valley 1.4.2 and SMAPI 3.0.0 Not compatible with Stardew Valley 1.3.36. (pull request is still pending)

    Changes since the last unofficial release:
    • buying animals into buildings on expansion works
    • restored gamepad navigation for switching between main farm and expansion in Robin's dialog (LS/RS)

      Attached Files:

      AlphaCenturion and Adil007 like this.
    • jkinnaly

      jkinnaly Void-Bound Voyager

      I'm having the same problem with the upgrade to prismatic not showing up at the blacksmith, and I am using the unofficial mod update you list here. I don't know about the log being the same. No doubt I'm somewhat dim, but I don't know where to find them.
      • Benigni

        Benigni Aquatic Astronaut

        Thanks eversomuch!
        • Asra Fantasy

          Asra Fantasy Void-Bound Voyager

          I have the same problem with seawolf's unofficial prismatic tools update, only the sprinklers work. I can't even SPAWN IN the tools. They are non existant.
          • Mizzion

            Mizzion Phantasmal Quasar

            Attached Files:

            Last edited: Dec 8, 2019
            Jadzi, Vandon, tashas12 and 17 others like this.
          • weyrbound

            weyrbound Master Chief

            EDIT2: Made a new post with working Magic Bunnies and Frogs for download!

            EDIT: Nevermind, tried loading it up again and now it's not working at all - if anyone wants to take a look at what I've done and see if they can work from there to fix it, they're welcome to - otherwise I'll keep working on it myself until I figure out what the problem is.

            I think I managed to update Magic Bunnies and Frogs for the new BFAV.

            I am getting a debug message:
            13:24:15     DEBUG     Paritee's Better Farm Animal Variety     Cannot replace "641" produce: "641" is not a known Object. Will be set to "none" (-1).
            13:24:15     DEBUG     Paritee's Better Farm Animal Variety     Cannot replace "639" produce: "639" is not a known Object. Will be set to "none" (-1).
                repeats [5] times.
            13:24:15     DEBUG     Paritee's Better Farm Animal Variety     Cannot replace "643" produce: "643" is not a known Object. Will be set to "none" (-1).
                repeats [3] times.
            The first message comes from the data string for the updated Crows, which I found a few pages back in this thread. The other two are from Frogs and Magic Bunnies respectively. The issue seems to be one of the last few numbers in the data string for each animal. For instance:

            "Data": "3/5/86/70/croak/36/64/64/64/36/64/64/64/0/false/Coop/16/16/16/16/15/5/null/639/800/Green Frog/Coop",
            You can see the 639 it's taking issue with towards the end there. The SDV wiki page for animal data strings tells me that's supposed to be the sell-back price for the animal, so I'm not sure if this will cause issues or not. This is my first time really messing around with SDV mods so I'm not sure if it's something that needs fixing or not, or how to fix it.
              Last edited: Dec 9, 2019
            • jkinnaly

              jkinnaly Void-Bound Voyager

              Thank you! Thank you!
              • minervamaga

                minervamaga Pangalactic Porcupine

                You mean the serpents? It's on my features list to add, just been too busy with my other mods to do it!
                • Drake1427

                  Drake1427 Void-Bound Voyager

                  You don't know me and I don't know you, but I love you so much. You're my hero :D

                  That is the same error people were reporting with my faulty update.
                  I don't know what to tell you, other than to double check that you're using seawolf's version and not mine (completely delete the mod folder and then copy/paste it again), do that and then look for the mod name/info in the smapi console on startup to make sure it's the right version.
                  If you're 100% sure that you're using seawolf's version only thing I can suggest is posting the smapi log (I think there's instructions in the wiki) so someone with more knowledge can help you, sorry :(
                    Last edited: Dec 8, 2019
                  • Senthyril

                    Senthyril Tentacle Wrangler

                    i totally thought i had gotten seawolfs version. that makes sense if i didnt. thanks.
                    • acidbaby

                      acidbaby Void-Bound Voyager

                      Oh! you made the redux version? which, thank you btw! but yeah, the serpents haha. Ohh, okay! no worries, I'll keep an eye out for when you update the redux <3
                      • Neechan13

                        Neechan13 Void-Bound Voyager

                        Platonymous's "The Harp of Yoba Redux" mod seems to be throwing the error message everyone is talking about, once removed, the pytk error goes away
                        • Xuomi

                          Xuomi Phantasmal Quasar

                          After testing, I can confirm that this changes the Dinosaur Egg into 2 Mayonnaise instead of Dinosaur Mayonnaise, and all of the Honey items turn to regular Mead instead of the flower-specific Mead. Otherwise the quality transition aspect does work it seems.
                            Th3Tob1 likes this.
                          • jkinnaly

                            jkinnaly Void-Bound Voyager

                            I'm having two problems at this point, one with Prismatic Tools and one with (I think) Quality Products. In Prismatic Tools, my tools can't be upgraded to prismatic--they don't appear either at the blacksmith or in the item spawner. I think the updated Quality Products is interfering with my ability to put roe from my fish ponds in the preserve casks for aging--that worked fine until I added the updated Quality Products version. Here is (I hope) a link to my error log: Thank you to anyone who can help. I love this game and am finding myself getting really frustrated.
                            • Xuomi

                              Xuomi Phantasmal Quasar

                              I don't think the Quality Products was updated to factor in the new items in the game, only patched to work with the new update. So anything exclusive to 1.4 (Roe, Dinosaur Mayonnaise, Caviar, etc.) doesn't "exist" in the system. We'll have to wait until someone can factor in these things.
                                dashblitz2 and jkinnaly like this.
                              • Wingyl

                                Wingyl Scruffy Nerf-Herder

                                Courtesan likes this.
                              • Kyttynjirr

                                Kyttynjirr Void-Bound Voyager

                                I am having this same problem exactly. I am using the Customer Furniture quick fix, and several Custom Furniture packs. I've been trying to figure out what's causing it, but I don't really understand what I'm doing and I'm concerned I might do worse damage. Anyone have any ideas?
                                  NylaJune, xbukimina and sophiafairy like this.
                                • Benigni

                                  Benigni Aquatic Astronaut

                                  The concept of this mod is awesome.
                                  I installed it, as well as the automate patch, and my kegs and jars went nutso!
                                  The quality factors all seem fully functional, but the processing time of the machines went way down. I'm producing wine and jam almost instantaneously.
                                  I wonder whether it is a conflict with another mod I have, or if it is something inherent to your update.

                                  Please advise?

                                    Th3Tob1 likes this.
                                  • Benigni

                                    Benigni Aquatic Astronaut

                                    Too bad Sauvignon isn't compatible with Farm Expansion.
                                    Probably it would be a lot of work to get them to go together, I'll wager.
                                    But one can daydream about it...
                                    Thread Status:
                                    Not open for further replies.

                                    Share This Page