Modding Help Updating mods for Stardew Valley 1.4

Discussion in 'Mods' started by Pathoschild, Jul 2, 2019.

  1. strobelight

    strobelight Void-Bound Voyager

    Attached Files:

    Last edited: Jan 18, 2020
  2. r-r-w

    r-r-w Master Chief

    SasukeTa, leahesefton and kittenchann like this.
  3. midnightsky

    midnightsky Void-Bound Voyager

  4. Moragaine

    Moragaine Existential Complex

    @ladywolfram21 MTN is being worked on by it's author. Better Quary is not open source and would have to re-written; take a look at FarmTypeManager.

    @Purson To generate a config file you run the game, then close it before the config will show up.
     
    • Purson

      Purson Aquatic Astronaut

      Thank you for responding! I did that, but the config file didn't generate. My only guess is that I'm downloading it wrong somehow. I've been downloading the file, and dragging it to the Vortex launcher to be installed, and then installing and enabling it (which is what I do for all my mods, including the ones that work). I've also tried opening the folder and copying all the contents into a folder I make in the mods folder, and that doesn't work either. I don't know if this affects anything, but when I uninstall and remove the mod, the Replanter folder in my "mods staging folder" gets deleted, but the one in my "games mod folder" stays (although it only contains the config file and the "folder managed by vortex" file). I've copied the config file from one folder and added it to the other and I've also tried manually deleting the lingering folder, but the mod still doesn't work when I reinstall it.

      Thank you again for you help and responding, and I'm sorry to bother you again!
       
      • Eilonwy74

        Eilonwy74 Aquatic Astronaut

        Spacechase hasn't updated Nexus yet, but Custom NPC Fixes is live on their personal website, along with quite a few others: https://spacechase0.com/mods/stardew-valley/custom-npc-fixes/

        According to aedenthorn on Nexus mods, PathosChild has put in a pull request for Kisekae with updated code, but hasn't incorporated the changes yet. So in the mean time, they posted a compiled, temporary unofficial update to Kisekae, which can be found here:
        https://drive.google.com/file/d/1NTjsaS7S_HGmKRNIZR1nELIAbZCUDyrF/view

        I haven't tested it yet, but most people are saying it works until you use it to change the pants option. Until we get a different unofficial Kisekae update or a new Kisekae lite, this might work for most appearance needs such as hair or face type.
         
          Last edited by a moderator: Nov 29, 2019
          blouwho? and Medicell like this.
        • Carolina2067

          Carolina2067 Yeah, You!

          Some mods I really would like to be updated are...

          Happy Birthday
          Wear More Rings
          JSON Assets
          Kisekae
          Prismatic Tools
          Giant Crop Ring
          Oasis Greenhouse
          BJS Time Skipper
          BJS No-Clip

          Thanks!
           
          • vickimed

            vickimed Aquatic Astronaut

            My Norton Antivirus is convinced the .dll file in the Kisekae download is unsafe, and I have never had that happen with any other of the many mods I have downloaded. Something seems weird, especially since PathosChild is a trusted source. Just FYI....
             
              Last edited: Nov 29, 2019
            • strobelight

              strobelight Void-Bound Voyager

              Wear More Rings, JsonAssets, Prismatic Tools have been updated. For the no-clip, search for Pathoschild's no-clip mod.

              Kisekae is obsolete with this patch

              Oasis Greenhouse should be fine as well! (since no changes were made to the greenhouse)
               
              • Bonster42

                Bonster42 Aquatic Astronaut

              • vickimed

                vickimed Aquatic Astronaut

              • Eilonwy74

                Eilonwy74 Aquatic Astronaut

                This does not come from PathosChild. I will check it with my anti-virus, thanks for the heads up. But to be clear, this is a compiled file, not posted by PathosChild. I can't even endorse it, I'm just letting people who don't check Nexus know that it's out there.
                 
                • Bonster42

                  Bonster42 Aquatic Astronaut

                  There are two buttons - Shift+1 changes physical features, Shift+2 changes clothes. You can't save outfits, but apparently it's a work in progress, so that may change
                   
                  • Allayna

                    Allayna Pangalactic Porcupine

                    something goes wrong with replanter when coffee plants are in play. When I have a ready to harvest coffee plant, i get this SMAPI error

                    [Replanter] Exception: System.DivideByZeroException: Attempted to divide by zero.
                    at Replanter.Replanter.GetHarvestedCrop(HoeDirt dirt, Crop crop, Int32 tileX, Int32 tileY) in C:\source\_Stardew\Mods.jwdred\Replanter\Replanter.cs:line 432
                    at Replanter.Replanter.PerformAction() in C:\source\_Stardew\Mods.jwdred\Replanter\Replanter.cs:line 249
                    at Replanter.Replanter.OnButtonPressed(Object sender, ButtonPressedEventArgs e) in C:\source\_Stardew\Mods.jwdred\Replanter\Replanter.cs:line 161
                     
                    • brianaalbert

                      brianaalbert Space Hobo

                      I will name my firstborn child after anyone who can fix Ship Anything
                       
                        Eilonwy74 likes this.
                      • Purson

                        Purson Aquatic Astronaut

                        I'm getting the same (or at least a very similar) message! For me, nothing happens when I press the harvest keybind button. Are you having that problem too? Also, does it harvest all crops except coffee beans, or does the mod not work at all if coffee beans are part of what's supposed to be harvested? Sorry for bothering you!
                         
                        • Allayna

                          Allayna Pangalactic Porcupine

                          It's like... the mod works up until it tries to harvest the coffee beans. Like if the first coffee plant is item 20 out of 40 it tries to harvest, all until that get harvest/replant/water. But then once the coffee plant is first in line (now 1 out of 20 it's trying to harvest) the mod just does nothing, not even the message pops up.
                           
                          • Purson

                            Purson Aquatic Astronaut

                            Weird... I'm using a greenhouse size mod, so I would understand if that were the reason why nothing in my greenhouse is being harvested, but I have plants outside too, and those aren't being collected either! How do you tell what order the crops are harvested in? I'm wondering if the priority order is my problem, as when I press the keybind, nothing happens (including no message at all). Is there a way to change the order, or should I try blacklisting coffee in the config file?

                            (Note: I am also having problems with the config file's creation. For some reason, when I download the latest Replanter update, 2 different Relanter folders are generated in two separate places, and even after I run and close the game, the config file is only generated in 1 of the folders, and copying it to the other folder does nothing).
                             
                            • erinjean

                              erinjean Seal Broken

                              I wonder if that's what's breaking the unofficial auto-grabber mod. Because it's intermittently working now in my greenhouse, except when there's coffee beans to pick up. Then it's empty. It throws errors in SMAPI every in-game day, though.


                              [Deluxe Auto-Grabber] This mod failed in the GameLoop.DayStarted event. Technical details:
                              System.DivideByZeroException: Attempted to divide by zero.
                              at DeluxeGrabber.ModEntry.GetHarvest(HoeDirt dirt, Vector2 tile, GameLocation location) in C:\source\_Stardew\Mods.CoopGrabber\DeluxeGrabber\ModEntry.cs:line 334
                              at DeluxeGrabber.ModEntry.AutograbCrops() in C:\source\_Stardew\Mods.CoopGrabber\DeluxeGrabber\ModEntry.cs:line 246
                              at DeluxeGrabber.ModEntry.OnDayStarted(Object sender, DayStartedEventArgs e) in C:\source\_Stardew\Mods.CoopGrabber\DeluxeGrabber\ModEntry.cs:line 132
                              at StardewModdingAPI.Framework.Events.ManagedEvent`1.Raise(TEventArgs args) in C:\source\_Stardew\SMAPI\src\SMAPI\Framework\Events\ManagedEvent.cs:line 88
                               
                                Last edited: Nov 29, 2019
                                craig_prime likes this.
                              • mettiboe

                                mettiboe Yeah, You!

                              Share This Page