1. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Modding Help Updating mods for Stardew Valley 1.3

Discussion in 'Mods' started by Pathoschild, Apr 15, 2018.

  1. Moragaine

    Moragaine Big Damn Hero

  2. Pathoschild

    Pathoschild Cosmos Killer

  3. Pathoschild

    Pathoschild Cosmos Killer

    Attached Files:

    MAsker likes this.
  4. Koihime Nakamura

    Koihime Nakamura Ketchup Robot

    Stardew Notifications
    SDV 1.3.33/SMAPI 3.0
     

      Attached Files:

    • SpringsSong

      SpringsSong Scruffy Nerf-Herder

    • Drake1427

      Drake1427 Void-Bound Voyager

    • drjonzw

      drjonzw Void-Bound Voyager

      Thank you for all your hard work!

      I'm having an issue with Prismatic Tools tho - the sprinklers don't work as lamps. They do work as scarecrows and when I'm holding them they light up but the light turns off as soon as I place it. I know this isn't your mod and you're just keeping it updated but do you maybe have any suggestions? Thanks!
       
      • Pathoschild

        Pathoschild Cosmos Killer

        @drjonzw Do you know if they were working as lamps in the previous unofficial update? (It's easier to look into if I know when it stopped working.)
         
        • drjonzw

          drjonzw Void-Bound Voyager

          They haven't worked in any of the updates, I've tried them all.
           
          • Pathoschild

            Pathoschild Cosmos Killer

            Do you know if it worked in the last official update (before it became incompatible)?
             
            • drjonzw

              drjonzw Void-Bound Voyager

              Unfortunately, I have no idea, I only started using it recently and just your version, the official version was already broken at that point. Never saw any complaints about this issue on the nexxus page so I'm assuming it worked
               
              • rosei21

                rosei21 Starship Captain

                on loading you get this message "uses a deprecated code" then says "legacy events are depreciated since smapi " and then says the version 2.8 or 2.9 which ever the mod is so needs updating before it stops working for
                tappers dream :- https://www.nexusmods.com/stardewvalley/mods/260 author not been on since oct
                better RNG :- https://community.playstarbound.com/threads/halted-development-smapi-0-39-7-zoryns-mods.108756/ not modding now

                also getting on Jsons assets have also posted on one of their pages have only mentioned it here as I know there have been a few bugs for some folks
                the other's I use I have posted on nexus for the authors cheers
                 
                • drjonzw

                  drjonzw Void-Bound Voyager

                  @Pathoschild FYI - I just tried your latest unofficial update on a brand new save with only one other mod active (CBJ Item Spawner so I could get a sprinkler to test) and the sprinklers don't work as lamps once they're placed on the ground just like in my usual , heavily modded save.
                   
                  • revalleria

                    revalleria Seal Broken

                    [23:22:22 ERROR SMAPI] Skipped mods
                    [23:22:22 ERROR SMAPI] --------------------------------------------------
                    [23:22:22 ERROR SMAPI] These mods could not be added to your game.

                    [23:22:22 ERROR SMAPI] - Magic 0.1.4-unofficial.2-pathoschild because it's no longer compatible. Please check for a new version at https://mods.smapi.io.
                    [23:22:22 ERROR SMAPI] - Prismatic Tools 1.7.1-unofficial.4-pathoschild because it's no longer compatible. Please check for a new version at https://mods.smapi.io.


                    sir pathoschild just updated it today right ? but its already incompatible?
                     
                    • arokken

                      arokken Void-Bound Voyager

                    • Moragaine

                      Moragaine Big Damn Hero

                    • revalleria

                      revalleria Seal Broken

                    • Moragaine

                      Moragaine Big Damn Hero

                      You need to update your game to 1.3.33, then; game was updated yesterday.
                       
                      • Pathoschild

                        Pathoschild Cosmos Killer

                        @drjonzw I'll look into it and release a new update later today.

                        @rosei21 It's safe to ignore the 'deprecated code' messages for now. Those mean the mod will stop working in SMAPI 3.0, but the authors still have a couple of months to update. I suggest letting the authors know about the message if someone hasn't already. I'm submitting PRs and preparing unofficial updates for the mods that aren't updated by the authors, so by the time SMAPI 3.0 releases at least 95% of open-source should be fine.
                         
                        • rosei21

                          rosei21 Starship Captain

                          yes I have let the authors know by posting on their nexus pages the ones I posted here are ones I could not find a page for or are being updated here good to know I have a couple of months
                           

                          Share This Page