1. When making a thread, please tag your thread accordingly using the menu to the left of the textfield where you name your thread where applicable. Server Advertisements and Mod Releases should be contained to their respective subforums.

Tutorial [Updated for 1.0] Server setup for Multiplayer Without Steam!

Discussion in 'Multiplayer' started by Hel, Jul 25, 2016.

  1. reiwanderley

    reiwanderley Void-Bound Voyager

  2. Anubite51

    Anubite51 Void-Bound Voyager

    What is the point of creating user accounts on a server that just me and my friends are using? Cause whenever I try to change the config file and save it it resets. Been extremely frustrating to deal with!! So i guess i can't change the name of my server now either :/ I don't know why it would do that lol. Anyone have any ideas?
  3. Hel

    Hel ✨ Johto's Finest ✨ Forum Moderator

    The point of them is mainly for Admin privileges.

    You're welcome c:
  4. Anubite51

    Anubite51 Void-Bound Voyager

    This dedicated server has proven to be impossible for my friends to connect to. I tried port forwarding and hamachi and neither will allow him to connect. The server doesn't seem to want to use the config file to change anything about the server. Which config file do i evne use theres one thats starbound server and another thats just starbound. Why isn't there a config file for the 64 bit folder? Does the server just use the one from the storage folder for soem reason or do I need to add one?

    UniverseServer: listening for incoming TCP connections on Why does it say instead of my ip address?

    ok i figured out how to get my friends connected but i can't invite the to my party once we're all in. Any idea why i cant and how i fix this, i havent seen any other people with this issue :/ Dedicated server not through steam.
    Last edited by a moderator: Nov 27, 2017
  5. Hel

    Hel ✨ Johto's Finest ✨ Forum Moderator

    Firstly. Please use the edit button to make changes to previous posts if nobody has replied instead of double and triple posting.

    Secondly, so you have people in your server but people cannot join up parties? You need to type in their Characters name into the invite list. It has to be identical. So spacing is important, capitals, numbers? And on on the super rare occasion if a characters name is coloured you need their colour code.

    Just make sure everything is spelled correctly. Easiest way is to check the server log for them joining and it will show their characters name properly.
  6. ThSmoke

    ThSmoke Intergalactic Tourist

    Hel, we have some way to setting a spawn planet or system on the server? Sorry any typing error, i'm from brazil, and my english it's not of best.
  7. Hel

    Hel ✨ Johto's Finest ✨ Forum Moderator

    Not as far as I know, I'm sorry
  8. lazarus78

    lazarus78 The Waste of Time

    Does the "defaultWorldCoordinate" in universe_server.config not work anymore? Not used it in a while, so Im not sure.
  9. Hel

    Hel ✨ Johto's Finest ✨ Forum Moderator

    Im not sure myself honestly
  10. Iris Blanche

    Iris Blanche Pudding Paradox Forum Moderator

    It still works.

    ~ Iris ~
  11. Cyniko

    Cyniko Space Hobo

    Everything is setup but when i try to sign in I get "No such account "(my character name) or incorrect password.

    But I triple checked that everything is right. Suggestions?

    EDIT: ok it seems my issue is that even though I am saving my config file it resets back to default and removes anything I add. Cant seem to figure out why :rofl:
    Last edited: Mar 25, 2018
  12. Hel

    Hel ✨ Johto's Finest ✨ Forum Moderator

    Try setting your decument to read only, so the game wont wipe it when it starts up
  13. super mario star

    super mario star Void-Bound Voyager

    But will the plants and trees and farming works normally? Like if I farm the pealpea and I watered the place but it just doesn't grow or do anything. How can I grow them as normal as the normal game? (What I mean is will farming works in server?)
  14. lazarus78

    lazarus78 The Waste of Time

    yes farming works. It is no different than single player.
    Hel likes this.
  15. Webdings

    Webdings Void-Bound Voyager

    I don't understand what I did wrong. I ran the exe, I checked my ipv4...
    I tried my ipv4 and the hamachi's, and i tried both 21025 and 21026, but nothing is working. I checked my server config file, and everything seems fine, but... i dunno, it just keeps popping up that error.

      "allowAdminCommands" : true,
      "allowAdminCommandsFromAnyone" : false,
      "allowAnonymousConnections" : true,
      "allowAssetsMismatch" : true,
      "anonymousConnectionsAreAdmin" : false,
      "bannedIPs" : [],
      "bannedUuids" : [],
      "checkAssetsDigest" : false,
      "clearPlayerFiles" : false,
      "clearUniverseFiles" : false,
      "clientIPJoinable" : true,
      "clientP2PJoinable" : true,
      "configurationVersion" : {
        "basic" : 2,
        "server" : 4
      "crafting" : {
        "filterHaveMaterials" : false
      "gameServerBind" : "*",
      "gameServerPort" : 21025,
      "interactiveHighlight" : true,
      "inventory" : {
        "pickupToActionBar" : true
      "maxPlayers" : 8,
      "maxTeamSize" : 4,
      "monochromeLighting" : false,
      "playerBackupFileCount" : 3,
      "queryServerBind" : "*",
      "queryServerPort" : 21025,
      "rconServerBind" : "*",
      "rconServerPassword" : "rabbit",
      "rconServerPort" : 21026,
      "rconServerTimeout" : 1000,
      "runQueryServer" : false,
      "runRconServer" : true,
      "safeScripts" : true,
      "scriptInstructionLimit" : 10000000,
      "scriptInstructionMeasureInterval" : 10000,
      "scriptProfilingEnabled" : false,
      "scriptRecursionLimit" : 100,
      "serverFidelity" : "automatic",
      "serverName" : "spellopteron",
      "serverOverrideAssetsDigest" : null,
      "serverUsers" : {
      "tutorialMessages" : true
  16. Hel

    Hel ✨ Johto's Finest ✨ Forum Moderator

    Honestly the unreliability of Hamachi could be the issue.

    Have you tried connecting locally through your local IPv4?
  17. Webdings

    Webdings Void-Bound Voyager

    The one from the command prompt ipconfig bit? Yeah, I did. I tried that one first, and it didn't work, which is when I tried the Hamachi, which also didn't work.
    I dunno, it's weird.
  18. Speire

    Speire Aquatic Astronaut

    Help. upload_2018-12-24_18-26-26.png
    This appears every time I open the server then go "start game" I checked my storage/universe folder and universe.lock is there. I don't really know how to fix this.
    Last edited: Dec 24, 2018
  19. lazarus78

    lazarus78 The Waste of Time

    You have the game already running with the universe file in use. You can run the server at the same time as you are actively using the universe file.
  20. Speire

    Speire Aquatic Astronaut

    Sorry but, I don't get what you are saying.

Share This Page