Modding Help Unpacking xnb files on a Mac

Discussion in 'Mods' started by frozenfarmer, Jan 30, 2018.

  1. Amu Tsukiyomi

    Amu Tsukiyomi Master Chief

    I downloaded the newest version of Xnbcli, which does not have or It has pack.command and unpack.command which made me think it had fixed files compared to the ones from back in January. Unless the guy didn't actually fix those files in the most recent version... Should I just replace them and hope for the best?
    • springacres

      springacres Phantasmal Quasar

      You can. Just be sure to rename the fixes to pack.command and unpack.command and they should work.
      • Amu Tsukiyomi

        Amu Tsukiyomi Master Chief

        Yup, that fixed the issue.......I guess the newest version didn't include fixing anything.
        • Ches713

          Ches713 Void-Bound Voyager

          I know this thread is old but I'm having the same issue springacres did, except with my pack.command file. It says:
          "The file “pack.command” could not be executed because you do not have appropriate access privileges.
          To view or change access privileges, select the file in the Finder and choose File > Get Info."​

          But I'm the admin. And it's just for pack.command, unpack.command works fine. Tried downloading the fixed files here, even though I checked and my files seemed to be the exact same code, still doesn't work. Anyone know how to fix this?

          Edited to add that I tried downloading the latest version of xnbcli from GitHub too, except with that version I can't open pack.command or unpack.command because of access privileges. Again, I'm the admin and the only one who uses this computer. I tried going in to Get Info and changing permissions to Read & Write for "staff" and "everyone" in addition to myself, still no luck.

          EDIT2: GOT IT TO WORK. Definitely a Mac issue, and definitely the wrong error message for the problem. Here's the solution for anyone else experiencing this!
          1. Open Terminal, type/paste in this: chmod u+x
          2. Right click on pack.command (or unpack.command, whichever one is giving you the error, could be both), hold Option, select Copy "path.command" as Pathname
            • NOTE: Make sure your path name (i.e. all your folder names leading up to the pack.command file) contains no spaces! So for example if you have xnbcli in a folder called "Stardew Valley Modding" change it to "StardewValleyModding" or "Stardew_Valley_Modding"
          3. Paste the path name into Terminal, next to chmod u+x. It should look like this:
            • chmod u+x /Users/YourUserName/path/file/example/[xnbcli-macos]/pack.command
          4. Hit enter to run it, and you're done! You should be able to run your pack.command file now! Repeat for any file that's giving you that privileges error.
          Found the fix here on a StackExchange forum. I vaguely remember doing this now with my unpack.command file actually, guess I never did it with my pack.command.

            Last edited: Dec 22, 2018
            whatalovelydisaster likes this.
          • krizpp

            krizpp Void-Bound Voyager

            i downloaded the most recently posted xnbcli-master. when it didn't work i tried replacing the files as suggested above, although it seems to be the same code.

            /Users/kristin/Desktop/stardew\ valley/xnb\ stuff/xnbcli-master/unpack.command ; exit;
            MacBook-Pro:~ kristin$ /Users/kristin/Desktop/stardew\ valley/xnb\ stuff/xnbcli-master/unpack.command ; exit;
            /Users/kristin/Desktop/stardew valley/xnb stuff/xnbcli-master/unpack.command: line 3: ./xnbcli: No such file or directory
            Saving session...
            ...copying shared history...
            ...saving history...truncating history files...

            [Process completed]​

            since it says "No such file or directory", @Pathoschild mentioned a packed folder, and i was missing that folder, i created one and placed my .xnb file in there in the hopes that might be the missing piece. no suck luck; i got the same result.

            so then i tried out @Nanogamer7 's tool and the same thing happened, even though the packed/unpacked folders already existed. :(

            MacBook-Pro:~ kristin$ /Users/kristin/Desktop/stardew\ valley/xnb\ stuff/XNB-Convert/XNB-Convert/\'UnPack.command ; exit;
            /Users/kristin/Desktop/stardew valley/xnb stuff/XNB-Convert/XNB-Convert/ line 5: wine: command not found
            Saving session...
            ...copying shared history...
            ...saving history...truncating history files...

            [Process completed]
            i am using High Sierra now. could that be what's wrong?

            help a farmer out please

              Attached Files:

            • Pathoschild

              Pathoschild Tiy's Beard

            • krizpp

              krizpp Void-Bound Voyager

              @Pathoschild omg thank you!! i feel kind of silly, but now i know >:3

              love your mods btw!!
                Pathoschild likes this.
              • krizpp

                krizpp Void-Bound Voyager

                THANK YOU. i redownloaded the files, had "privileges" errors, tried this, and now it's working! you guys have been so incredibly helpful. thank you!
                  Ches713 likes this.
                • pastelpink

                  pastelpink Space Hobo

                  Just wanted to say that you are AMAZING. I was struggling so hard to get this to work and your instructions took care of everything. Thank you thank you!
                  • swapz

                    swapz Void-Bound Voyager

                    I've been trying to unpack xnb files on my mac for like a week and nothing has worked until this! Thank you so much!!

                    I changed .sh to .command and it worked perfectly.
                    • Emiedigital

                      Emiedigital Orbital Explorer

                      Hey, I'me having trouble re packing the content
                      • whatalovelydisaster

                        whatalovelydisaster Scruffy Nerf-Herder

                        any luck? I'm having the same problem...
                        • fahlman

                          fahlman Void-Bound Voyager

                          Right click on unpack.command and choose open. If that doesn't work see:
                          • Blendwolf

                            Blendwolf Space Hobo

                            I'll be posting a video on my Youtube channel soon with how to do this on a Mac!
                            • hanster98

                              hanster98 Space Hobo

                              Hey there, I just wanted to say this was profoundly helpful as I was digging around for a solution to the same problem! Thank you for sharing and I hope the new year is treating you kindly :)
                              • stardewsweetheart

                                stardewsweetheart Aquatic Astronaut

                                I am on Monterey and while I can get unpack to run, Monterey wants me to trash the actual shell script XNBCLI file because it can't be verified. What can I do?

                                Share This Page