Modding Help Trouble with the Workshop

Discussion in 'Starbound Modding' started by evendel, Feb 23, 2017.

  1. evendel

    evendel Scruffy Nerf-Herder

    I hope this is the correct place to put this. It is modding related. So I've been having an issue recently where I wanted to look at a race mod or two and when I manually installed them the game didn't seem to recognize them. I thought it was weird, but kind of set it aside since it wasn't that imperative that I play one of them. I mostly had wanted to look at some of their assets which I can do even if the race doesn't function in my game. But then I remembered today that I had wanted to try playing around a bit with the Weapon Assembly mod and try Frankenstein-ing some of the weapons I've found together. I manually installed that from this site as I usually would...and it doesn't appear to work either. The only thing I could think, to make sure that I wasn't crazy, was to try subscribing to a mod from the Steam Workshop, since I recalled doing it once before and everything went fine. Sure enough, I popped in a race mod and it worked. Then another. I subbed to a mod that opens up all racial crafting to every race and that worked. This makes no sense that only Workshop subbed mods would work, so I jumped back to here and tried installing The Universal Uncrafter. Download complete, drop the .pak file into my mods folder...and nothing. It should be in my Inventor's Table to build and nothing.

    So I guess it's time to ask here...WTF!? Does using the Workshop just once mean that I can't ever manually download a mod? Because I'd hate to uninstall and reinstall the game just to be able to manually install a mod again...but I'll do it. There are mods here that just aren't on the Workshop. The only reason I can think to really sub to a mod, short of it only being available on the Workshop, is if it updates constantly. Like Frackin' Universe. Sometimes they update three times in one day! Is there anything I can do to fix this without an complete wipe and reinstall? Has anyone else even had this problem?
  2. The | Suit

    The | Suit Agent S. Forum Moderator

    Which mods folder?

    The old mods folder used to be in Starbound \ Storage \ Mods
    The new mods folder is starbound \ mods \ pak_file_goes_here.pak
  3. evendel

    evendel Scruffy Nerf-Herder

    Yep, my full address for a manual install is; D:\SteamLibrary\steamapps\common\Starbound\mods\ "omgwtfbbq".pak

    Not sure where exactly the Steam Workshop mods are downloading to...since I don't see them in the Starbound\mods folder either.

    ::EDIT:: At another glance...there's a small chance I may have figure it out and will have to investigate after I wake up. I think, when I was trying to fix my computer and add a new SSHD, that I wound up keeping my Steam games flashed to the old drive...even after I had copied them to the new. So it is very, very possible that through my own idiocy...I've been trying to mod the Starbound folder that isn't recognized by Steam. It would make sense, at least, why everything I put in there isn't being added. But that's for later. Now is bed.
    Last edited: Feb 23, 2017
  4. The | Suit

    The | Suit Agent S. Forum Moderator

    Easy way to check is run the exe in that starbound folder directly and see if the mod is loading.

    Or to confirm it is a different directory from steam.

    Right click on Starbound in Steam
    Properties -> local files -> open local files.

    It will show you which directory the steam is connected to.
  5. evendel

    evendel Scruffy Nerf-Herder

    Yeah...false alarm. Double checked my directory and Steam is supposed to be working off the C:\ so I just dragged a mod from the folder I'd been trying to use to the correct one and everything works fine now.

Share This Page