1. When making a thread, please tag your thread accordingly using the menu to the left of the textfield where you name your thread where applicable. Server Advertisements and Mod Releases should be contained to their respective subforums.

Server Help Too many ports needed for connections to work.

Discussion in 'Multiplayer' started by Monviech, Aug 13, 2016.

  1. Monviech

    Monviech Intergalactic Tourist

    I have just created my own dedicated server on a seperate Windows 10 machine and set it up.

    I have an issue with the port forwarding range though. Just opening and forwarding port 21025 doesn't work.

    After a good 2 hours of testing, I have found out, that I have to open the range 16000-21025 for connections to be working.

    If I reduce the range to 16000-21024, the connection to the server fails.
    If I reduce the range to 17000-21025, the connection to the server fails.

    I don't understand why that is happening. I want to only open the ports that really need to be opened for connections to work.

    In the server connection tab, it shows that a random port in the range of 16000-16999 is used when a connection works. But when I just open ports 21025 and a range of 16000-16999 it also doesnt work. There has to be something inbetween 16999 to 21024 that isn't documented anywhere, or its a bug of my router (D-Link DSR-250N).

    If anybody has some experience with this issue, please help me.

    Thank you.


    Now that port range stopped working all of a sudden, and I have to put my server as exposed host with all ports open, in order for it to work.
    Last edited: Aug 13, 2016
  2. You only have to open one port. It can be any port, it is in the config file in starbound. If it doesn't work It would have to be on your end. On my dedicated server I told it to use port 21026, and opened it in pf sense and it worked. I am going to guess it is windows 10. If you don't shut off windows fire wall, windows defender, in the services, it is going to cause all sorts of problems.
  3. Monviech

    Monviech Intergalactic Tourist

    Thanks for the input, I actually troubleshooted the problem completely now. My Router seems to have a bug. When I want to enable ports, I have to create custom services, which I then have to refer to as firewall rules. Every custom service doesn't work, only the default services that come with the router work.

    Running the Starbound server on the POP3 Port (110 TCP) works fine through the firewall. Its really strange, I might try a different firmware on my router sometime. I never expected that from a professional router!

Share This Page