RELEASED TimeSpeed (unofficial) 2.0.3

Provides time speed configuration.

  1. Taroven

    Taroven Void-Bound Voyager

    Something similar has happened to me twice now actually. When entering the farmhouse (time frozen), time instantly goes to 2am and continues forward at what seems like 10 minutes per frame until alt-F4. I'm not even sure what time it was when it occurred just now, but it killed a good bit of progress. :(
    • MbahGondrong

      MbahGondrong Seal Broken

      This is just perfect, thanks for this, helped me a lot. :)
        Roskii Heiral likes this.
      • LasurDragon

        LasurDragon Astral Cartographer

        LasurDragon updated TimeSpeed (unofficial) with a new update entry:


        Read the rest of this update entry...
        • MbahGondrong

          MbahGondrong Seal Broken

        • LasurDragon

          LasurDragon Astral Cartographer

          Replace manifest.json and TimeSpeed.dll in mod folder.
          No need to replace config.json if you modified it.
            MbahGondrong likes this.
          • TenkoKuugen

            TenkoKuugen Scruffy Nerf-Herder

            I lost like 4 or 5 days to the bug by now but granted, that's in like 270 hours of gameplay, so still very rare
            • ChibiBerry

              ChibiBerry Void-Bound Voyager

              Wanna thank FieryChaos for showing me this~

              Altho as soon as I freeze time, I can't move. Also when I unfreeze time I cant move? How do I fix this o:

              Also if possible how do I make time freeze in the mines automatically?
              • LasurDragon

                LasurDragon Astral Cartographer

                Does this happen when only TimeSpeed is enabled? If not, I will need the list of mods you use.
                "UndergroundMine": null
                to "TickLengthByLocation"
                • ChibiBerry

                  ChibiBerry Void-Bound Voyager

                  I removed all the mods which didn't work and it works now, should of thought of that xD thank you

                  But I had
                  Working Mods:
                  -CJB (Shows prices of items)

                  -Stamina Regen
                  -Social Editor
                  idk why they dont work xD

                  I'm guessing since they were not working, with or without any other mod, it must of made the working mods spazz out xb
                  ty so much for the help ^^ !
                  • Hogweed

                    Hogweed Void-Bound Voyager

                    Cant get it to work. Time is still 7 sec for 10 min tick. The config.json reads 14 as the default, which is fine.
                    Getting this error in the DOS box after it loads.:
                    ..\common\processpipe_any.cpp (232) : Assertion Failed: OpenFileMapping returned NULL (errno=2)
                    Assert( Assertion Failed: OpenFileMapping returned NULL (errno=2) ):..\common\processpipe_any.cpp:232

                    I put the 3 files in the steamapps/common/stardew Valley/Mods folder. I got these from the TimeSpeed- zipfile. (I also tried it with the 2.0.1 version)
                    The version of SMAPI I used was SMAPI-1.5.

                    I opened steam and added [ StardewModdingAPI %command% ] (no brackets) under the Set Launch Options as well, then opened the game from the steam page.

                    I have no other mods, and the game works just fine as vanilla.

                    Is this the right version? There should be no problems with running this, so I must have done something wrong..
                      Last edited: Jan 4, 2017
                    • LasurDragon

                      LasurDragon Astral Cartographer

                      Oh, it looks like I missed a lot of SMAPI releases. I will check it with the latest version.
                      • MbahGondrong

                        MbahGondrong Seal Broken

                        Thanks! Will update also to 1.5 when a new update is available for this mod. :)
                        • MizoreYukii

                          MizoreYukii Void-Bound Voyager

                          I have an error to report. I have no idea how this happened, but it did and I hope it can be fixed! :eek:

                          Here is what happened, in case someone can replicate it. My settings for this is paused time indoors, with default and outdoor time set at 9, rather than 14 (didn't touch anything else). I went to the saloon at around 5: 30 pm or so to talk to Shane, talked and gifted him, then left the building. I realized I didn't talk to everybody else before I was barely 2 feet from the door, so immediately turned around to go back inside. As soon as I got inside, I received the "It's getting late" message, checked the time and it was now 2 am, so I passed out.

                          I'm not sure why this happened. This was my first time using the mod, and I didn't touch anything else, just the configuration file, and it worked great up until this point. I did install other mods, but I don't think they would mess this up. In case they did, here they are:
                          • CJB Show Item Sell Price
                          • Enemy Health Bars
                          • NPC Map Location
                          • Display Grid Mod
                          • Easier Fishing
                          • ReRegeneration
                          • Simple Sprinkler
                          • And of course SMAPI
                          I'll see if it will happen again first, and if it does I'll try the mod without the others and see if it still happens. Hopefully this was a one time thing though.
                          • Drifting_Spaceman

                            Drifting_Spaceman Space Hobo

                            Just installed all the necessities to get this to work. I use to have the mod Freeze Time inside of buildings back when it used the Storm loader. Came here to try to alleviate that. I'm looking through the commands one uses to tweak stuff, is there a specific one that just freezes time when you are inside of buildings? Thats all I want. o_O

                            EDIT: Am I suppose to go into the json files for the freezetime thing? Not really familiar with going this in depth. Sorry.
                              Last edited: Jan 23, 2017
                            • quirkyquark

                              quirkyquark Astral Cartographer

                              Open config.json in the TimeSpeed folder under Mods. Replace line 4 & 5 with:
                              "UndergroundMine": 28,
                              "Indoors": null
                              This will freeze time indoors, set 10 minutes = 28 seconds in the mine/cavern (change this if you like), and everywhere else 10 minutes will be the value of line 2 DefaultTickLength (default 14 seconds, can change.) Save config.json and start the game.
                              • MizoreYukii

                                MizoreYukii Void-Bound Voyager

                                I'm starting to think Shane is cursed! Went for his cut scene for 4 hearts in his house (I forgot which time exactly), came out of the cut scene and it was suddenly 2: 30 am! And then I was stuck in a loop for a few days, so I eventually had to close the game. Thankfully it rained those days I was stuck in.
                                But eesh, Shane makes me uneasy now. :lod: :rofl:

                                I'm not sure how this one happened. I'm pretty sure it was around 9 to 10 am when I went to their house, and time was paused indoors.

                                On my previous post though, I haven't been able to replicate it yet. Game has been working peachy, just been careful to not immediately turn around and enter a building after I exit.
                                • LasurDragon

                                  LasurDragon Astral Cartographer

                                  Roskii Heiral likes this.
                                • LasurDragon

                                  LasurDragon Astral Cartographer

                                  Sorry for long delay in replying.
                                  Unfortunately, I don't have much time now to work on this mod, so not sure when I'll manage to try to reproduce this.
                                  If you will find this yourself, please post steps here - it will probably be much easier and faster for me to fix it then.
                                    Roskii Heiral likes this.
                                  • quirkyquark

                                    quirkyquark Astral Cartographer

                                    Just wanted to thank you for keeping this mod updated and adding features!
                                    • birdsquirrel

                                      birdsquirrel Void-Bound Voyager

                                      Is there a way to disable keybinding entirely? I don't intend to ever use it, and I'm sort of a klutz, so sometimes I hit keys I don't intend to.

                                      Share This Page