Modding Help "Tiled" help, unknown issue

Discussion in 'Starbound Modding' started by Dekadrachm, Jun 3, 2016.

  1. Dekadrachm

    Dekadrachm Heliosphere

    Hello, recently I learned that the program called "Tiled" is now useable to make starbound dungeon files. I went through the basic tutorial that was made for starbound mission dungeon editing. I want to make a random encounter dungeon for the ocean biome, I load the template, fix it up to what I like, save, test, and when I try to enter the ocean biome, the game teleports me back to my ship.

    The error in the log won't be any help, It just tells me that the game couldn't load the ocean dungeon because of and error in properties, obviously presented in the new dungeon "chunk" I tried to make. I then decide to remove all objects, including anchors.

    Now the random encounter dungeon chunk spawns, almost everywhere. I then decided to add the chest back with my custom loot parameters. It works fine. I try adding another object besides the chest. It gives me the same error and teleports me back to my ship.

    I tried adding anchors back in the hopes decreasing spawn rate due to the restriction anchors add. It teleports me back to my ship once again with the same error.

    I then reload the template, remove all objects but the anchors, I add my chest and a few material items such as gravel. The game once again teleports me back to my ship with the same error.

    I know anybody who does help will want to see the error regardless so here...

    [21:48:44.112] Error: WorldServerThread exception caught: (DungeonException) Error loading dungeon '/dungeons/microdungeons/biomes/ocean/oceanmicrodungeons.dungeon': (JsonException) No such key in Json::get("properties")
    [0] 7ff60c493e13
    [1] 7ff60c4907a8
    [2] 7ff60c1a87d5
    [3] 7ff60c1a49f6
    [4] 7ff60c695fd4
    [5] 7ff60c5e0bb0
    [6] 7ff60c5ddba4
    [7] 7ffaaa3990e3 RtlCaptureContext
    [8] 7ff60c19ab07
    [9] 7ff60c1aa24a
    [10] 7ff60c1a4cd6
    [11] 7ff60c19aa14
    [12] 7ff60c19ac69
    [13] 7ff60c475ef1
    [14] 7ff60c44edb5
    [15] 7ff60c30535b
    [16] 7ff60c3052a1
    [17] 7ff60c3052a1
    [18] 7ff60c302b91
    [19] 7ff60c20c507
    [20] 7ff60c23a819
    [21] 7ff60c23a5a2
    [22] 7ff60c4a849d
    [23] 7ffaa7708102 BaseThreadInitThunk
    [24] 7ffaaa34c5b4 RtlUserThreadStart
    [21:48:44.212] Error: UniverseServer: World thread has stopped due to an error, removing world CelestialWorld:-668634801:-668355202:51544184:5:3
    It only gives this error when adding any objects of any sort aside from a chest with my custom loot parameters. This includes anchors.

    Any help will be appreciated since I am drawing blanks. Tiled just doesn't seem to like any objects besides the chest I put. Before anyone asks, Yes, each item is in its correct layer.

    I won't be surprised if I get told that the modding forums are only for anything starbound and not for external applications used to mod starbound. An example, asking about an error with your text document.
  2. Inf_Wolf14

    Inf_Wolf14 Parsec Taste Tester

    My guess is that Tiled is omitting the "properties" element of objects in the dungeon. In the case where you have a chest, the properties will contain the treasure pool information; However, general objects have no properties.
    I haven't used Tiled for dungeons (I'm used to manual file-writing), but I think it omits that element if it is empty. The engine is searching for that property nonetheless if it is empty or not.

    Again, only my guess. Check the files from Tiled and see if this is the case. I'll download Tiled and check this myself later on.



    Sorry for the delay but I just got around to downloading Tiled and spent today learning how to use it.

    The .json files exported from Tiled do, in fact, omit the "properties" element in the object definitions.

    In my case, as I use NP++, a simple replace command to add the line everywhere needed worked out. My dungeon properly loads as an instance world and all objects load properly
    Last edited: Jun 6, 2016
    foxtails likes this.

Share This Page