1. Please be advised of a few specific rules and guidelines for this section.

Outdated The Tabula Rasa 2.1

Unified Crafting Bench for Mod Content

  1. Mrmii21

    Mrmii21 Pangalactic Porcupine

    I installed this mod recently and I have the most recent version, but it doesn't seem to appear in any crafting menus. What's wrong?
  2. LowestFormOfWit

    LowestFormOfWit Pangalactic Porcupine

    It should be right there in basic player crafting ("C" key). If not, Tabula Rasa may not be installed correctly or another mod is conflicting.
  3. Mrmii21

    Mrmii21 Pangalactic Porcupine

    Yeah, it's not here.
    These are my mods:
  4. SnoopJeDi

    SnoopJeDi Void-Bound Voyager

    It does work, but one of those mods is probably using __merge in the overwrite mode (or possibly not at all). We can't support other mods, so it's up to you to find which one is conflicting. Just uninstall them (renaming your mods folder to mods.disabled/ is the easiest thing to do), then install Tabula Rasa and then other mods one by one. When it breaks, that mod is the culprit.
  5. Mrmii21

    Mrmii21 Pangalactic Porcupine

    What would be an example of a __merge that would conflict? I might be able to find the problem if you do.
  6. LowestFormOfWit

    LowestFormOfWit Pangalactic Porcupine

    An overwrite __merge.

    "__merge" : [ [ "overwrite", <StuffandThingsHere>....

    Or something similar.
  7. Mrmii21

    Mrmii21 Pangalactic Porcupine

    Found the conflicting one.
    The Medical Bed mod has a really long player.config that is unnecessary and screws it up.
  8. intervencion

    intervencion Existential Complex

    And no_mod in the recipe. Tomorrow I'll edit the player.config with _merge.
    Thanks for the advise :D
  9. FerrisSJ

    FerrisSJ Orbital Explorer


    I am having a small problem with the mod, but it might be me, figured I would ask here regardless.

    I have the mod installed, I am able to craft the Tablet in the game, but when I go to place the object on my ship, it disappears when I click to place it, and there is no evidence that it ever existed. Any insight or thoughts you might have on what I might be doing wrong would be greatly appreciated.

    I installed this mod in order to use Unique Drills.
  10. LowestFormOfWit

    LowestFormOfWit Pangalactic Porcupine

    This generally happens when you try to place Tabula Rasa on a multiplayer server that isn't running the mod, or running the correct version of the mod.
  11. FerrisSJ

    FerrisSJ Orbital Explorer

    AHhh, gotcha, thank you very much.
  12. LowestFormOfWit

    LowestFormOfWit Pangalactic Porcupine

    For everyone's ease, I've updated the main page of Tabula Rasa with a visual walkthrough on how to create a Custom Filter Button for your mod, in case the written wall of text was too convoluted!
  13. Nekoyoubi

    Nekoyoubi Subatomic Cosmonaut

    Hey there! I have a quick question about the general "mod" tag from a modder's perspective. In my mod, I'm attempting to duplicate some of your functionality. Obviously not to the level of detail that you've given it, just working off of the standard that you've gotten going in the community (of tagging with "mod" for compatibility). My "Tinker's Workshop" worked fine in Angry by simply appending "mod" to the list of "filter" under "interactData". Now in Furious, however, it appears to only be pulling the "roboticcraftingtable", "anvil", etc. filters, but no longer "mod". Did a change come in Furious that made that process more complicated, by chance? I would have tried looking through your mod, but I'm trying not to infringe - I merely want to continue your progress in giving the community a standard.

    EDIT: Nevermind. I figured it out. I had wiped my player.config and so I didn't have the defaultBlueprints listed but TR picked up my modded items anyway. They only showed in my Tinker's Workshop after re-adding them to the player.config. Sorry for any bother. I am kind of curious why TR's letting everything through though.
    Last edited: Feb 4, 2014
  14. LowestFormOfWit

    LowestFormOfWit Pangalactic Porcupine

    Tabula Rasa has a parameter that doesn't require the player to know the blueprint to craft "mod" tagged recipes at it. When you're working with any crafting station (especially vanilla ones), the player has to know the blueprint before they can craft it. Adding them to deftaultBlueprints obviously adds them to tier1/starting recipes, with Tier2, Tier3, etc being blueprints learned through progression. This is something you can't do with Tabula Rasa. Since blueprints are globally not required, you can't separate what's intended as a Tier 1 recipe from what's intended as a Tier 5 recipe; if the player has the material, and the recipe is tagged "mod", they can craft it at Tabula Rasa.

    For the most part it looks like you answered your own question though! Glad it's working again.
  15. jdpls

    jdpls Space Hobo

    Say I wanted to include this as an unlock at some tier to replace all the basic crafting in the game, what's the easiest way to go about that?
  16. LowestFormOfWit

    LowestFormOfWit Pangalactic Porcupine

    Add a recipe for Tabula Rasa using appropriate components for that tier level. __merge a blueprint for the player to learn into this tier so that when the player gets to the point they should craft it, they know the recipe. This also determines where the player crafts TR from. Then you would have to tag every recipe you wanted with "mod".

    Easiest way would be to batch edit with Notepad++, but there's a LOT of recipes...not sure if you should try to add all of them. aMannus' Creative Mode might be a better option if you're just looking to access everything in the base game whenever.
  17. jdpls

    jdpls Space Hobo

    I don't really know anything about modding this game, I just wanted to add this as an unlock after the jelly boss so I could compact all crafting down into one station since it looks so darn spiffy.
  18. Ixantir

    Ixantir Ketchup Robot

    Lol wasn't paying attention when I grabbed the Unwrecked props mod. The next thing I know I have an angry puffer fish bleeping at me. Missing dependency tabularasa2.0 <3 silly me
  19. Sadron

    Sadron Ketchup Robot

    Please fix this for Enraged, thank you. ^_^
    Relydukno likes this.
  20. LowestFormOfWit

    LowestFormOfWit Pangalactic Porcupine

    Fix for the patch is coming. Give us a day. :)
    penguinscout and Relydukno like this.

Share This Page