Modding Help Tenants die on interacting with colony deed

Discussion in 'Starbound Modding' started by YeetusSkeetus9, Jul 15, 2019.

  1. YeetusSkeetus9

    YeetusSkeetus9 Space Hobo

    Hello, I am having troubles with my colony, in that whenever I interact with a tenant's colony deed, they die, then respawn a few moments later. This ends up interrupting rent collection, as the tenants die before dropping the rent. I looked through my log, and found the error, but I am not sure what is causing the error.
    The error says:
    [Error] Exception while invoking lua function 'update'. (LuaException) Error code 2, [string "/npcs/bmain.lua"]:162: (StarException) Lua Exception caught running action node sayToEntity in behavior villager: (LuaException) Error code 2, [string "/scripts/actions/dialog.lua"]:18: (AssetException) Error loading asset /dialog/arrivedhome.config:beacon

    The whole Starbound log is attached as well.

    If anyone can tell what the issue may be or point me in the right direction to fix the issue, that would be great.

    Thank you
     

    Attached Files:

  2. DrPvtSkittles

    DrPvtSkittles Parsec Taste Tester

    I'm gonna guess that the custom race you are playing as is missing some dialog config patches
     
  3. projectmayhem

    projectmayhem Ketchup Robot

    Some simple steps to narrow it down...
    Is this happening with tenants from different species or only one species?
    If its multiple species, one of your mods probably messed up on a dialog patch or they altered an important file and cause incompatibility issues with other mods you have installed
    I would check the steam page of each species mod you have, to see if anyone else is complaining about the issue
     
  4. YeetusSkeetus9

    YeetusSkeetus9 Space Hobo

    I can confirm that this is happening with all species, vanilla and modded.
    As for if it is my custom race, I will look into that.

    Edit: I tried switching to another race to see if it was the custom race that was causing the problem, and it doesn't appear to be so. I created a new avian character, and the problem remained. I also looked around on the mod pages and couldn't find any bug reports that were similar to this.
     
    Last edited: Jul 15, 2019
  5. projectmayhem

    projectmayhem Ketchup Robot

    It you dont have too many modded races, I would unsub from one... try it...then another.....try it....repeat till they stop dying.
     
  6. YeetusSkeetus9

    YeetusSkeetus9 Space Hobo

    Did some unsubbing and was able to find find the mod that was causing the issue. Thanks for the help.
     
  7. projectmayhem

    projectmayhem Ketchup Robot

    Which mod was it, so everyone knows
     
  8. YeetusSkeetus9

    YeetusSkeetus9 Space Hobo

Share This Page