1. This forum is archived for reference. For support & bug reports visit the help section of forums.stardewvalley.net

Bug/Issue Switch - Corrupted save file? Sleep crash bug

Discussion in 'Support' started by Typhoon, Oct 7, 2017.

  1. Vaetilda

    Vaetilda Space Hobo

    I have the same issue on the Switch - when I hand in one of my tools for upgrading (now in 1st winter season), it crashes on sleep/save. I've been able to upgrade some from basic to copper before, but this is from copper to iron.
    Saving without handing in a tool for upgrades is totally fine.

    I hope you make a proper fix for it even though there's the whole crate space fix now.
    • supernet2

      supernet2 Existential Complex

      The solutions don't work for me. I have over 20+ chests and I manually emptied each one. Nothing overcomes my issue with going to the skull mines, farming any type of iridium or heck getting a prism item. Second I just go to the skull cavern and then teleport.back, ride the bus back, regardless of time or item on my character, the save crash happens. After wasting 5+ hr's attempting to figure this out I've come to the conclusion this games a bust. It's like starbound all over again, but this time it's on the Nintendo switch, and with zero debugging tools or access to a sdk and source to correct it myself I'm at my wits end. If I avoid going to anypart of oasis or skull cavern I never suffer from any type of save crash. To me this is a pretty extreme game breaking bug as farming iridium on the island mines on mine floor 115-120 is a god awful way to farm. It's just horrific. Once that patch comes along I'll be happy, hopefully it's not gonna take as long as it did with starbound during its first few months where the community got tired of waiting for fixes so we started building fixes using our own redeveloped wrappers. Mind you this time around as I mentioned prior that's not a viable option not with out breaking a few laws tampering with reverse engineering game code on the switch, that is
        Last edited: Oct 26, 2017
      • Typhoon

        Typhoon Spaceman Spiff

        "I ran into this bug last night, and while fussing with all my chest contents also found my iridium fishing rod was also acting weird. I couldn't equip bait and tackle at the same time, the second one would replace the first on the same slot. Once I successfully saved and got into the next day, the rod was behaving normally. I haven't seen anyone mention the fishing rods acting up in particular with this bug so I thought I'd mention it."

        • LokiTheKhajiit

          LokiTheKhajiit Space Hobo

          I've been trying the ways to fix the sleeping error crash but it only seems to work sometimes for me. I'm getting frustrated because I am about halfway through winter year one. I want to upgrade my axe from copper to steel but can't. I want to progress through the game more but it seems I cannot do much until they fix this bug which didn't start for me until the ice festival. I'm feeling like sure I can get through the days on the game by just not doing anything hardly but that's no fun. I am hoping for a patch soon. I want to enjoy this game and currently cannot.
          • Typhoon

            Typhoon Spaceman Spiff

            This tells you all you need to know:

              LokiTheKhajiit likes this.
            • jerven8

              jerven8 Space Hobo

              I know y’all are working on the Switch Save Bug and trying to replicate the issue. I am year 2 Winter and it happens randomly. So far Winter day 7-12 it happens on some days. I do things differently if I can’t save. But my Bug revolves around Linus and the Dish o’ The Sea. Every time I give it to him I can’t save. However it happened again without interacting with him. I have a few full chest but nothing crazy.

              Will stop playing the game for now since I’ve had to relive 8 days over and over trying to not have save issues.

              Cheers! Best game ever.
              • Typhoon

                Typhoon Spaceman Spiff

                Have you read this and applied what's suggested, it should help to avoid the crashes:

                • LokiTheKhajiit

                  LokiTheKhajiit Space Hobo

                  Typhoon likes this.
                • Typhoon

                  Typhoon Spaceman Spiff

                  Brilliant, happy that it helped. :)
                  • pokepicker

                    pokepicker Space Hobo

                    New here.
                    Should I make a new thread for my bug, or just leave it here? And I have been investigating a couple bugs. Does one create a new thread for each bug, or should we make one thread covering them all at once?

                    There seems to be a gamepad problem when it comes to using containers (chests, cheese presses) that are placed in corners to the north, or above the player.

                    Looking at the wiki article for the optimal shed layout, we are finding ourselves with six unusable containers.

                    This issue is reproducible, and consistent. Image attached with description. We are two Nintendo Switch players, and one PC gamer with this issue. The PC user is using a Xbox One controller.
                    We have tried with the "Use controller-style menus" both ON and OFF with no difference.

                    • Ldyjadette

                      Ldyjadette Space Hobo

                      I need to upgrade my pick axe from copper to iron but the game keeps crashing. I understand that other things can make it crash and I've been able to get past those. How can I get around the upgrade process when the game takes my pick axe out of my inventory? When is this bug going to get fixed?

                      • to-the-unterzee

                        to-the-unterzee Intergalactic Tourist

                        Hi! I report the same sleep crash as many people here.
                        It happened to me several times in winter. I re-played the days when the game crashed several times, doing the exact same things, and removing one action on each re-play; and it seems to have a link with completing bundles / a room in the community center: when I completed one it often crashed. One day it also solved itself when I didn't go mining (levels 80-85).

                        Share This Page