RELEASED [Storm] and [SMAPI] TimeSpeed Mod--Configurable Day Lengths

Discussion in 'Gameplay Mechanics' started by cantorsdust, Mar 4, 2016.

  1. Igosama

    Igosama Void-Bound Voyager

    I have the same problem that Aristatide has. I'm cool with the 14 second timer, but sometimes I just want to accelerate and is really annoying to keep doing that in every single area.
    • Trixie9819

      Trixie9819 Void-Bound Voyager

      Aaand I'm back for help. Got it working, changed the config thanks to the helpful chart, I can freeze time, or make it go back to 'normal', but every tick is 7 seconds, no matter what I do. If I change it in the config to 20 seconds, still 7 seconds. If I use the keys to increase the time per tick, it SAYS that I did, but it's still 7 seconds.

      This was happening this morning, and so I updated to SMAPI 1.12 (just released), uninstalled SMAPI 1.11 then installed 1.12. Still happening. Obviously there's something weird in reading the config, though the keys I mapped it to are giving me the time speed message (10 minutes feels like 21 seconds) though they don't actually increase or decrease the time tick.

      I should note that I'm not having the same problem as Igosama and Aristatide, it's not working properly no matter where I am.

      Edit: True weirdness. I played a saved game that I made a few weeks ago but had done nothing with, literally, still hadn't picked up the parsnip seeds from the floor. It's having no problems with the time, it does 20 second ticks, and doesn't reset like others have seen. Freeze time, unfreeze time, increasing time tick, decreasing time tick, and 'go back to default' are all working in this save, but not my 'main' game! grrrrr

      Here's the config, just in case it might help.

      "DefaultTickLength": 20.0,
      "TickLengthByLocation": {
      "Indoors": 20.0,
      "Outdoors": 20.0
      "EnableOnFestivalDays": false,
      "FreezeTimeAt": null,
      "LocationNotify": false,
      "Keys": {
      "FreezeTime": "F",
      "IncreaseTickInterval": "Up",
      "DecreaseTickInterval": "Down",
      "ReloadConfig": "Z"
        Last edited: May 6, 2017
      • Aristatide

        Aristatide Tentacle Wrangler

        I actually figured out how to solve the default time problem I was having--in an embarrassingly obvious case, I wasn't realizing which bit of the config was overriding what--but yes, the zoning reset remains. My issue with it is opposite yours: I slow time down on certain occasions and that flat-out just doesn't work when every time you so much as nip inside your house to put something in the fridge, it resets.
        • missvy

          missvy Space Spelunker

          I'm actually having the same problem as you. Neither of my saved games seems to work with this mod but I created a new game just to test it and it worksed fine in this new game file when I first loaded it. When I exited the game and reloaded in that same file the mod stopped working.
          • springacres

            springacres Phantasmal Quasar

            Having the same issue as @missvy and @Trixie9819. I haven't touched the config, but ticks are now only lasting 7 secs instead of the 14 they should be lasting.

            [Update] Using SMAPI 1.13, SDV 1.2.30 on a Mac. I can still freeze time, but it would be nice if the ticks would last 14 secs like they're supposed to. SMAPI's not giving me any debug errors either, so whatever's going on is something even SMAPI isn't picking up on.

            [Update x2] Reloading the config file seems to get it working properly at least temporarily. You have to do it individually for each save and each time you quit to desktop, but at least it's a workaround.
              Last edited: May 23, 2017
            • frozentomorrow

              frozentomorrow Void-Bound Voyager

            • Trixie9819

              Trixie9819 Void-Bound Voyager

              I'm determined not to update my SMAPI any more, every time I do, it totally screws up the time mod. Installed 1.13 and the only thing I could do was freeze time. Tried uninstalling and reinstalling everything (just in case) and nada. I'm currently trying to get the ascii codes to hit the right keys (I run a non-standard keyboard layout) but I'm tired of losing all progress on my farm *cry* I'll update if/when I get it working again, even if it's for new saves (the only thing I have not tried yet.)
              • Pathoschild

                Pathoschild Tiy's Beard

                TimeSpeed is open-source if anyone wants to submit a fix, but if not I'll look into the recent issues soon (after the current SMAPI push and after updating my own mods). :)
                • Arkista

                  Arkista Void-Bound Voyager

                  Hallo, lurker here. Having similar issues with timespeed randomly not working, but still being able to freeze time. I've been experimenting with it for a couple days trying to get it to work, thought maybe this might help someone til a more permanent solution comes out :3
                  Seems like for me it works after you play for a day then sleep, but I haven't tested enough for that to be consistent. Changing the DefaultTickLength and both the TickLengthByLocation settings to 21.0 (my preferred, but could be whatever you want of course) and pushing the reload config key in game like springacres suggested works for me, but again I haven't tested enough to be sure it's consistent. Will add more if I find out anything else useful. I know these haven't been working for everyone, but I hope it will help some.
                    Last edited: May 27, 2017
                    Acerbicon and HopeWasHere like this.
                  • Pathoschild

                    Pathoschild Tiy's Beard

                    Arkista, frozentomorrow and Acerbicon like this.
                  • mblade01

                    mblade01 Big Damn Hero

                    The mines counts as indoors and this freezes times in the mines which I don't want to happen. Is there an option to unfreeze/slow down time in the mines only like the previous versions of TimeSpeed? I tried a bunch of stuff in the config files and the best I got is when I put ' "Mine": 7.0 ' underneath the Indoors line and this unfroze the time of the top floor of the mine, Floor 0 if you want to call it, but as soon as I went down into the mines time froze again.
                    • kelticpete

                      kelticpete Big Damn Hero

                      hi. this mod was working super awesomesauce.

                      I died in the mine, and after I slept, even though the game says I am increasing the time, it moves at normal pace.

                      so. yeah. smapi is not sure how I screwed up

                      smapi is working, other mods are working. I totally deleted stardew and smapi. reinstalled.

                      when you hit . it adds seconds. and it says it is going from 15 to 16 seconds.

                      this mod is so addictive. I don't think I want to play until I sort this out.
                        Last edited: Sep 14, 2017
                      • mistwick

                        mistwick Void-Bound Voyager

                        I may have overlooked some information - but I'm utterly lost right now. The default tick is at 14, It's tedious having to click . every time I change location. I'd like to set my default tick to 25, but Im not sure how? I use a .json editor and changed 14 to 25 everywhere, saved and popped the file back but it did nothing. =( Help!
                        • kelticpete

                          kelticpete Big Damn Hero

                          So I loaded a new game. saved it, tried old game. works!
                          • CaptainFoxx

                            CaptainFoxx Pangalactic Porcupine

                            Mm, this mod seems to be incompatible with the latest version of SMAPI
                            • Verne

                              Verne Astral Cartographer

                              What version of the mod are you using? You should be using 2.2.1. If you're using one of the versions from the first post in this thread, they're outdated.
                              • kecchin

                                kecchin Space Hobo

                                Hi, I literally made an account hoping someone can help me. I have the latest version of the mod - 2.2.1. I also have the latest version of SMAPI.

                                I installed the mod, and SMAPI says it's loading properly. I just don't know how to set it to freeze time indoors and in the mines - that's what I want to do. But the options for doing so aren't in config.json, and I'm not sure how to add them so that it works properly.

                                The config file only reads:

                                If someone could be kind enough to guide me in turning on freeze time indoors and freeze time in mines, I would be grateful. Thanks!
                                • Pathoschild

                                  Pathoschild Tiy's Beard

                                  @kecchin I think this should set the default time everywhere, but freeze it indoors and in the mines:
                                  "DefaultTickLength": 7,
                                  "TickLengthByLocation": {
                                     "Indoors": null,
                                     "Mines": null
                                  (Keep the other settings as they are.)
                                  • Cpt Obvious1994

                                    Cpt Obvious1994 Void-Bound Voyager

                                    Maybe I'm doing something wrong, but the tick rate doesn't seem to be completely "accurate." I have the tick rate set to 30.0, but 10 in-game minutes actually take about 38 seconds. When I set the tick rate to 60.0, 10 in-game minutes took about a minute and a half.
                                    • Garland01

                                      Garland01 Void-Bound Voyager

                                      I was wondering if there was a way to let machines run while indoors and time frozen?

                                      Share This Page