RELEASED [Storm] and [SMAPI] TimeSpeed Mod--Configurable Day Lengths

Discussion in 'Gameplay Mechanics' started by cantorsdust, Mar 4, 2016.

  1. Nurio

    Nurio Scruffy Nerf-Herder

    You should edit the config.json file with a simple text editor (like Notepad or Notepad++). The config.json file looks like this:
      "OutdoorTickLength": 14.0,
      "IndoorTickLength": 14.0,
      "MineTickLength": 14.0,
      "ChangeTimeSpeedOnFestivalDays": false,
      "FreezeTimeOutdoors": false,
      "FreezeTimeIndoors": false,
      "FreezeTimeInMines": false,
      "LetMachinesRunWhileTimeFrozen": false,
      "FreezeTimeAt1230AM": false
    If you need an explanation of each setting, feel free to ask, but I think it should be self-explanatory. If you want a certain setting to be 'true', just simply write "true" instead of "false". You can also adjust the Tick Length to your liking.

    (It's possible the config.json file doesn't show up until after you've run the mod in-game at least once.)
    • esclavealiberte

      esclavealiberte Yeah, You!

      Question: If you wanted to adjust the timespeed for a real-time time scale, what would be an accurate numerical scheme to go with for the first 3 settings?

      • foghorn

        foghorn Pangalactic Porcupine

        Real-time would be 600.
        • shushu

          shushu Yeah, You!

          Question: Anyone has tested if it works with SMAPI 0.40 or not?
          • renbear

            renbear Scruffy Nerf-Herder

            Works for me on 0.40. Never used it on any other version, actually.
            • aule11

              aule11 Intergalactic Tourist

              Hmm I have run into this problem that the timespeed dont work any more. I have tried to install and reinstall stardew, with a compleete wipe of all data, and edited the Json files. ETC. It just wont make the time go slower. I can stop time with N, no problem, but the lenght of the day i cant do anything with.

              1. What do you have your time tick length set to? 14 tried 21 and 28, dont work.
              2. Does it still occur if you remove my time mod?
              3. Does it still occur if the tick length is set to 7?
              4. Did this occur upon saving or upon loading your save? it randomly started after a new day.

              Edit. Now i got it to work, BUT 10 minutes are now 21 sec. long and not 14 as the edit say it should be.
                Last edited: Jul 6, 2016
              • Greyshe_wolf

                Greyshe_wolf Space Hobo

                I'm sorry if this is an obvious question but I did a search in the thread and couldn't find any reference to the Skull Caverns, if I stop time in the Mines does the skull cavern count too?
                • tilyene

                  tilyene Aquatic Astronaut

         maybe I am just dumb... but I have this installed and it is not working (i think). How do I configure the time? how do i KNOW it is working?
                  --- Post updated ---
                  nevermind... I figured it out finally. I AM dumb... do you think you could make a note in the main post that to edit the config you need to open the file in a wordpad? I feel... sheepish...
                  • taintedwheat

                    taintedwheat Master Astronaut

                    ...uhm....nah. It's already implied you need to open the config though to edit your preferences, it matters not if its notepad, notepad += or adobe code.

                    Also, the author of this mod hasn't been on since late April.
                    • SectionZ

                      SectionZ Void-Bound Voyager

                      Whenever I try to use this mod, while the time controls work, my game options get reset to default no matter what I do. Even after I remove the mod itself, and my options resetting themselves remains until I salt the earth and do a clean slate install after deleting my appdata too.

                      1: Happens regardless of config settings (14 or 7, etc). (I have frozen time indoors turned on).
                      2: Removing the mod does NOT solves the problem (However, the problem doesn't happen until I put the mod in)
                      3: Still happens at set to 7. Which was my preferred setting anyways.
                      4: Happens no matter what I do, loading saves, new games, sleeping to save after I put my options back to what I want, etc.

                      The normal options just always get forced back to default when I have this Mod put in.

                      If I do a clean install after erasing everything, with or without a couple other mods (A default walkspeed mod, and callender tooltips mod), it will save my options.

                      But once I put in this mod, my options get set to default whenever I load saves (even after changing them back to what I want, sleeping, etc) even after I remove the mod.

                      I wish I knew what the heck this mod was doing that makes it so my options settings won't stick, even after I remove this mod.


                      Oh dear.
                      • LuthienNightwolf

                        LuthienNightwolf Parsec Taste Tester

                        I just have a small question:

                        I have noticed that sometimes when I go into a coop and an egg has hatched, or when I buy animals from Marnie, the time will get stuck after I name the animal and exit out of the screen. I'm wondering, after reading through some of the comments you think hitting the N key while typing in the name can still trigger the mod to pause time? It seems like it only happens some of the time, and I've never really paid attention to whether or not the N key was pressed since I completely forgot about that feature.
                        Just curious...the issue is mildly annoying but doesn't really affect too much since I've learned to work around it. (I wait to buy/name animals until after 9, for example, so I can still get into shops and houses.)
                          renbear likes this.
                        • Davrial

                          Davrial Sandwich Man

                          Probably. Honestly I hate that feature and wish it was able to be turned off or at least had a configurable key binding instead of a set key.
                            Jokerine and LuthienNightwolf like this.
                          • LuthienNightwolf

                            LuthienNightwolf Parsec Taste Tester

                            Okay, I tested that theory a couple times in my game and it appears I was correct. So if anyone else has trouble with this mod freezing the time when they name animals, this is why. If you hit the "n" key while you're naming your animal, the mod will think you're telling it to pause the time, so you'll need to hit the "n" key again to unstick it.

                            I wish I would have known this on my last playthrough, I had my plans spoiled on more than one occasion because of the time getting stuck before 9am. >u<
                              Jinxiewinxie likes this.
                            • TheDeadOne

                              TheDeadOne Aquatic Astronaut

                              So... Does this mod still works after the new update, or we have to wait for a new version?
                              • ekffie

                                ekffie Subatomic Cosmonaut

                                for me it works. have fun :)
                                  renbear likes this.
                                • LuthienNightwolf

                                  LuthienNightwolf Parsec Taste Tester

                                  I think it still works but you'll need to upgrade to the new version of SMAPI as well.
                                    MoonlitBrenya and renbear like this.
                                  • NekoiNemo

                                    NekoiNemo Scruffy Nerf-Herder

                                    Did anyone else encountered an issue on 10th of Spring 1st year (when Pam brings you your new cat) which makes time stuck permanently on 6am?
                                    • LuthienNightwolf

                                      LuthienNightwolf Parsec Taste Tester

                                      That has happened to me a few times when cutscenes occur. Try hitting the N key, I think it gets stuck when you name your pet.
                                      • NekoiNemo

                                        NekoiNemo Scruffy Nerf-Herder

                                        Thank you, i'll try if it happens after other morning cutscene
                                          LuthienNightwolf likes this.
                                        • Mobscene

                                          Mobscene Space Spelunker

                                          I can't seem to get this to work. People say it still works but every time I try to launch I get a black screen(DOS window?) that pops up then a crash error.

                                          I believe I have the mod in the correct folder. But I'm unsure about the SMAPI stuff. There's a Mods folder in the zip along with the EXE. Is that supposed to go in the same Mods folder as Timespeed. The installation instructions just say to put the EXE in the Stardew Folder, and nothing about the extra files with it.

                                          It's the most recent version of Stardew Valley and the SMAPI version is the 40.1.1 one, I've tried the 40.0.0 one as well.

                                          Share This Page