1. Note: Nightly builds are not officially supported and things that appear broken might actually just be broken with no way of fixing it, but community members may still be willing to assist you with common problems.
  2. Hey Guest! Our new game Wargroove has released! Check out the forums or wiki for more information!
    Dismiss Notice

Closed Steam Starbound update disk write error

Discussion in 'Nightly Builds Support' started by Blue_Narye, Mar 6, 2016.

Thread Status:
Not open for further replies.
  1. Blue_Narye

    Blue_Narye Void-Bound Voyager

    Woke up to play games but Windows 10 was all lets update, so I updated and let it do it's thing. After I started Starbound nightly and Steam starts downloading the usual nightly update all is good I let it update. When the 10 minutes or so of time had passed I check Steam download and it says disk write error. I go to D (where I put Steam) , open properties, go to tools, and check the drive. The drive is fine no errors. I uninstall Starbound and re install it (completely forgetting to go to the Beta tab to switch to nightly) it install fine no problems. I start playing and realize it isn't Starbound nightly so again uninstall. Change the beta tab to nightly, reinstall, and disk write error again. Am I just bad at computering and things or is this an issue others are having? Haaaalllppp!
     
  2. Loismustdie555

    Loismustdie555 Void-Bound Voyager

    Having the same issue here. Had 2 other friends verify and they also are having the same problem.
    Anyone know of a fix?
     
  3. Iris Blanche

    Iris Blanche Master-Pudding Forum Moderator

    Same issue here. I think we'll have to wait for the next update.
     
  4. Blue_Narye

    Blue_Narye Void-Bound Voyager

    I sort of found a work around. I noticed that it fully downloaded and then stated disk write error. I restored a Starbound nightly I recently deleted and opened Starbound from there. The folder I went to was the win64 and launched from the Starbound penguin icon (D : \SteamLibrary\SteamApps\common\Starbound - Unstable\win64). It could be different for you (C:\Program Files (x86)\Steam\SteamApps\common\Starbound - Unstable\win32). I seem to be able to play and it does seem updated. There is a new loading emblem in the corner like wings that fill up or something not the rotating circle so eh? (it was the file I deleted after the failed Steam update). Hopefully this helps anyone that just has to play tonight. If anyone knows something better please inform me.
     
  5. jakecool19

    jakecool19 Big Damn Hero

    The same issue for me too. I almost had a heart attack because I thought my hard drive was failing, but three hardware scans later it seemed it was just a usual nightly bug.
     
  6. Blue_Narye

    Blue_Narye Void-Bound Voyager

    Yeah. When it happened I was all damn you Win10 update but then it was all screw you Steam my drives are golden goddesses of the dawn how dare you accuse them of trickery. Now I am okay because I know it's not my computer and I am able to play the nightly. Granted it took about 3 hours of trying and cursing all the fixes that didn't work but I found a work around. My fiance has a Mac and the nightly downloaded fine and he has the same loading screen change. I just had to restore the file I deleted and not go through Steam to launch. Hopefully it will be fixed to use the usually way soon.
     
  7. cloud-bro

    cloud-bro Void-Bound Voyager

    I can't get my game to update to the latest nightly, and when I try that way that Blue_Narye said it just bring up the regler starbound. I'm not sure what to do here??
     
  8. Blue_Narye

    Blue_Narye Void-Bound Voyager

    When you tried to update did it go through the full update and then say disk write error or did it not update at all?
    Also are you going to your Starbound - Unstable game file not the regular Starbound file?
    Last, All the steps I took that lead to my fixing the problem: I let Steam download the update, the update downloaded completely and then stated disk write error, I deleted the files from the Steamapps common folder by placing them in the recycling bin, I went to my Steam library to Starbound - Unstable properties and deleted all local content, I tried numerous fixes which can be found on reddit and none worked, I tried to reinstall and I got the same disk write error and I noticed that it fully downloaded, I went back into Starbound - Unstable properties and deleted all local content and exited Steam, I went to my recycle been and restored the deleted Starbound - Unstable file, and went into the file for Starbound. Yours could be in a different location but normally it is C:\Program Files (x86)\Steam\SteamApps\common\Starbound - Unstable and go to the file with your operating system on it. In that file should be 2 penguin icons one says Starbound and the other says Starbound server.

    If you don't have a backup and you deleted your files through Steam's delete Local Content I don't know what to do because I always manual delete and I backup Nightly a lot. I hope this was helpful.
     
    Last edited: Mar 6, 2016
  9. cloud-bro

    cloud-bro Void-Bound Voyager

    it doesn't update the game on steam I try to launch the launcher and it immediately close is out and brings up a steam Error, and I try all of that but none of it works? so I guess I'll have to wait for a new update.
     
  10. Blue_Narye

    Blue_Narye Void-Bound Voyager

    Yeah that is totally different from what I experienced. Hopefully it will be fixed soon, they're always on the ball when things get a little super buggy.
     
  11. Jetter

    Jetter Subatomic Cosmonaut

    So glad it's an issue multiple people are having, I thought my drive was failing on me.
     
  12. ODST 4900

    ODST 4900 Pangalactic Porcupine

    who on windows 10 can actually find where the tool tab went, i can't seem to find it anywhere?
     
  13. noobsqoou

    noobsqoou Big Damn Hero

    Glad to see I wasn't the only one experiencing this. I was about to lose my shit over a writing error because I only built this computer just last year.

    I'll just wait for another update. I've got other games I need to catch up on anyway.
     
  14. Sean Mirrsen

    Sean Mirrsen Scruffy Nerf-Herder

    I basically just copied the complete update - which is sitting in the "downloaded" folder - over what I have in my Starbound - Unstable install. Seems to work so far. Steam is complaining of a write error, but I'll just chalk that up to Nightly and wait for a fix later.
     
    Dynaflame likes this.
  15. lazarus78

    lazarus78 The Waste of Time

    You... just uploaded the entire game folder. You do know that is illegal, right? The game has no DRM, so right now anyone can download it and play it.
     
    ODST 4900 likes this.
  16. ODST 4900

    ODST 4900 Pangalactic Porcupine

    and now his post is gone, but what damage has been done now..?
     
  17. lukas__lk

    lukas__lk Void-Bound Voyager

    Oh my god ;-;
    I just noticed that it didnt had any DRM or stuff.
    I deleted the Uploaded Game Folder, Sorry that i caused this Trouble.
    Sorry Starbound Team.
     
  18. Blue_Narye

    Blue_Narye Void-Bound Voyager

    The tool tab on Windows 10 is under properties when you right click on the drive go to the bottom of the little menu and it say properties. Left click on properties and the the tool tab is to the right of the general tab.
     
  19. Blue_Narye

    Blue_Narye Void-Bound Voyager

    Yeah it seems to be similar to the launching issue with Starbound nightly that happened a few times last year where you couldn't launch through Steam. I've been able to play Starbound nightly with my little fix but I wasn't able to download the update that came in last night. I just couldn't deal with spending another weekend minute on deleting and restoring when I should be having fun.
     
  20. Gumballtoid

    Gumballtoid Void-Bound Voyager

    I attempted this myself, but the game just kinda crashes upon selecting a character -- even a freshly-made one. I'm not sure where to go from here.
     
Thread Status:
Not open for further replies.

Share This Page