1. Please be advised of a few specific rules and guidelines for this section.

RELEASED StarReader: Starbound Web-Based Player Save File Editor

Discussion in 'Other' started by Gear, Dec 10, 2013.

  1. DaPotato

    DaPotato Void-Bound Voyager

    Warn: Missing inventoryIcon for chestplant1, using default
    Warn: Missing inventoryIcon for barvent, using default
    Warn: Missing inventoryIcon for wreckvent, using default
    Info: Done loading Star::Root.
    Info: Writing Star::Configuration to '..\starbound.config'
    Error: Failed to valid player with uuid 682cbcd6f2cb4261ae1d78f98ea0c06c : StarException: Item name missing.
    00588D0A (/Users/builder/starbound-slave/releasebuilder-windows/build/source/game/StarItemDescriptor.cpp:30)
    0059F5FA (/Users/builder/starbound-slave/releasebuilder-windows/build/source/game/StarItemDatabase.cpp:98)
    ... (2)
  2. DaPotato

    DaPotato Void-Bound Voyager

    I started a new save, but i noticed something, when i try to export a generaded gun and import it, when i get on star bound, it is displayed as perfectly generic item
  3. Juzztn

    Juzztn Void-Bound Voyager

    I'm also getting generic items when I export a seed from one character and import it to another character.
  4. Aronos

    Aronos Void-Bound Voyager

    Same issue with he generated item.
  5. Marxon

    Marxon Supernova

    Whenever I change any generatedgun it breaks and returns in the log "Error: Could not instantiate item '[generatedgun, 1, {}]'. StarException: Instancing a generated gun but no level was provided."

    It seems a recent update changed something, or starreader is saving guns wrong.
  6. Starbeak87

    Starbeak87 Phantasmal Quasar

    I, like others, am experiencing the perfectly generic item issue when attempting to import (even known working) items. It seems that it is not saving any data on the item past it's name. why is this?!
  7. Marxon

    Marxon Supernova

    I'm just going to assume this is an abandoned project.
    SeedyAztec likes this.
  8. Bradicus300

    Bradicus300 Big Damn Hero

  9. Gear

    Gear Subatomic Cosmonaut

    Sorry guys, i'm way too busy at the moment with life to maintain this at the moment. Maybe in the future as we get closer to a full release I can have more time for it, sorry!

    Feel free to use Starcheat for your cheating needs in the meantime!
    Bradicus300 likes this.
  10. Andrek79

    Andrek79 Orbital Explorer

    It looks like this thread doesn't exist any longer. How can we find the StarCheat.699 program?
  11. Jessen

    Jessen Scruffy Nerf-Herder

    The creator of Starcheat has officially ended his work on it, because he felt underappreciated and that everyone wasn't reading the documentation. Someone else can always pick up the project...
  12. MaybeADragon

    MaybeADragon Aquatic Astronaut

    Question (unsure if this has been asked): Since many weapons are randomly generated could I change some of the values in the import/export section to change a weapon's stats or function? When I have tried changing items I have gotten a perfectly generic item.
  13. Kashmir

    Kashmir Giant Laser Beams

    Thank You!!!! I've been trying to change my character name for some time and couldn't get it right. This is so easy. You are brilliant.
  14. Chaos265

    Chaos265 Master Chief

    How do you change the color of your eyes?
  15. Kn16h7

    Kn16h7 Void-Bound Voyager

    I see you updated StarReader, and I gave it a shot with some basic item additions, and one modification to energy. Loaded my game and my character just doesn't show up. I'm going to try again from my backup, this time without the energy modification, and see if that works.

    Could it be something to do with the player.metadata conflicting with the new .player?? I noticed back in the unstable version of upbeat that the game would crash because of log files, and sometimes the config file, because they didnt match up with a new file that was edited out of the game. For instance, I backed up my unstable saves without deleting my config and letting it create a new one, and my game would crash. That didn't used to happen before, and it seems like the messed with a lot of the ways the game stores information.

    EDIT: Wait is this update of starreader for upbeat giraffe update 1, or update 2?
    Last edited: Jan 29, 2015
  16. Eraldoe

    Eraldoe Aquatic Astronaut

    Starreader does not appear to be working with the stable version, at least not for me. If I place an edited save in the player folder, the game crashes on open.
  17. ilibromhit

    ilibromhit Void-Bound Voyager

    Starreader works and changed my Pixel # , but it doesnt changes the items in my inventory
  18. Gear

    Gear Subatomic Cosmonaut

    Hey Guys, I didn't expect anyone to see any of the changes I made to the site so I hadn't announced anything.

    I'm currently working on updating Starreader to be able to properly save again, for the moment i've just got it reading the files and outputting some information.

    I'll work on it this weekend and have a formal update hopefully, i've got a bit of a cold so it might be as slow as I feel. D:

    Kn16h7, Milavelo and Jessen like this.
  19. Jessen

    Jessen Scruffy Nerf-Herder

    Gear, perhaps you can look into starcheat's source files to see if you can start an offline version?
  20. Olloth

    Olloth Space Hobo

    I screwed up. :(

    I accidentally trashed a magnetic crucible instead of placing it in game..

    Then I tried your save editor without backing up in my haste (I'm a programmer I should really know better than this...)

    I seem to have corrupted my save but it's not heavily edited.. I just tried to add one item in an empty inventory slot..

    Any chance someone could at the very least point me to any documentation or known information about save files so I can fix it? lost my 12 hours of save...

    EDIT: I found the website on a google search and missed all the THIS DOESN'T WORK YET stuff and just didn't think about it very hard before saving over it. It says it works for the latest release on the website.

    EDIT EDIT: Found the error in the log...
    Error: Failed to valid player with uuid fed21cb34ea37a6a0fd013c4bb18e93c : (VersioningDatabaseException) Could not bring versionedVariant with identifier '' and version Nothing forward to current version of 2, best version was 0
    Last edited: Feb 1, 2015

Share This Page