Stardew Valley Switch Multiplayer Patch #1: Known Issues & Fixes

Discussion in 'Support' started by Katzeus, Jan 21, 2019.

  1. Gandalor 75

    Gandalor 75 Star Wrangler

    Just putting in what I had contributed back on the first page of this thread. "
    Just wanted to corroborate with some of the above mentioned single player issues. Framerate is better but not the same as pre 1.3 on the farm. Also, there is still the dropped frame that occurs randomly that had been a well reported issue pre-multiplayer update.

    I also wanted to report some of the issues that seem to have been fixed in1.3.33. I am no longer walking through fences for no reason. I am also going between floors in the mines like I used to.
    Thanks for the fixes and keep up the great work!

    Last edited: Jan 31, 2019
    "
    Hope we get some updates before the 1.4 update comes along and adds new bugs with the new content. Good luck organizing everything.
     
      Shubeans likes this.
    • Shubeans

      Shubeans QA Wizard Chucklefish

      I really do understand the frustration and I can only wholeheartedly apologise for it. I genuinely promise that I'll not let it get this bad again.
      Not even a company promise, this is a personal one!

      We are aware of a lot of issues regarding the Local and Lan connection games, and everything is being passed along to the Switch Port developers.
      If you could double check some (annoying) follow up questions and troubleshooting that would be great:
      - Please ensure you have your profiles as friends
      ~~- Both have the latest patch~~
      - Both be using the online communications mode.
      - Try having the host build an extra cabin
      If none of this works, does local communications work when you're physically co-located?
       
      • Captain Nadine

        Captain Nadine Aquatic Astronaut

        Good to see that our concerns are being heard now, going to repost my list of bugs that I had found while playing the switch version!

        Multiplayer with myself as host:
        * A portion of the screen would show a different lighting than what is reflected in the game day/night - occurred for both myself and one of my friends
        * Villagers would keep walking for a second after talking to them
        * Latency issues
        * Random jolting of the screen when moving or friend moving - possibly related to latency, it's hard to describe, but imagine a pokemon battle and you use a certain move that makes the screen shake
        * Delays in picking up items drops from rocks in the mines

        Multiplayer with friend as host:
        * Latency going to different areas of the map
        * Villagers would keep walking for a second after talking to them
        * Sometimes the trees would be extremely green, even the trunks when walking through the path from your farm up to the mountains
        * Latency with friends' actions on my screen, sometimes player would appear to 'float'
        * Random jolting of the screen when moving or friend moving - possibly related to latency, it's hard to describe, but imagine a pokemon battle and you use a certain move that makes the screen shake
        * A portion of the screen would show a different lighting than what is reflected in the game day/night
        * Animals would not move upon walking into them, would have to wait until they moved to keep walking
        * Delays in picking up items drops from rocks in the mines
        * High amounts of lag in the mines, game would frequently have a noticeable lag anytime either of us went down the ladders
        * Issues with ladders spawning right where I'm standing, therefore getting stuck and only able to go down to the next floor to fix the issue

        Single player:
        * Latency issues - game looks like it's going to possibly crash because it freezes before continuing
        * Going to bed there is a stall with it getting to the save/profits screen
        * Lag when doing actions, screen jumps and no action has been done as a result - example during watering plants while walking, uses the button to water while walking, skips and jumps ahead a couple steps and action was not completed
        * A portion of the screen would show a different lighting than what is reflected in the game day/night
         
          Gandalor 75 likes this.
        • Pandadude

          Pandadude Intergalactic Tourist

          game crash for unknown reason:
          While i, the host player, was playing Journey of the Prairie King in the salon, and another player online was planting a pepper seed, the game crashed for both players. The crash did not seem to happen immediately after any player action.

          mine elevator progress lost:
          After reaching floor 15 in the mines and unlocking the elevator checkpoint and saving the game several times, upon opening the save during the next play session and returning to the mine, only the floor 5 checkpoint was available via the elevator. No other progress loss was noticed.
           
          • Shubeans

            Shubeans QA Wizard Chucklefish

            There is currently a crash in Prairie King that we know about, which we are currently looking into.
            Is the pepper seed one reproducible at all, or did it only happen the once?
            Did you happen to die in the mine at any point?
             
            • Shubeans

              Shubeans QA Wizard Chucklefish

              Hello!
              So I've been playing around with this and doing some googling. It's an annoyance on the PC version as well.
              In my build (which is a dev build, not the current one) I can place both floors and wallpaper in the corridor.
              - Floor tiles need to be placed separately, they do not get included when changing the rooms either side.
              - Wall tiles are offset slightly, in order to place one you need to be standing at the left, or right of the wall and find the 'sweet spot' as it were. Hint: The panelling does not change, so you are only changing the square of wallpaper above it:
              [​IMG]
              (I stole this from another support thread)

              If you still can't get it working on yours, then rest assured as it has been fixed at least ^^;
               

                Attached Files:

              • Shubeans

                Shubeans QA Wizard Chucklefish

                So this could be a controller issue. On any vibration error change the "change grip/order" in the controller setting on the HOME page. Even if the joycons are on the switch.
                They apparently sometime disconnect slightly from the switch and don't send vibration info correctly.

                Let me know if that helps!
                 
                • 8tMviZYvWQrKSzjEs8bVHI

                  8tMviZYvWQrKSzjEs8bVHI Poptop Tamer

                  Hello I have recently started playing stardew and have enjoyed it a lot. I have also encountered many bugs (most if not all are probably known). All of the bugs I have listed here appeared in the latest patch as of posting this (1.3.33) on the Nintendo switch in portable mode and in single player (I have no friends to play with).

                  -Frame rate/hitching issues on my farm as well as in the mines (I know this is the biggest known issue lol). For me at least it seems to always be present even in smaller farms, but much worse with larger farms and with more light sources and weather effects such as rain. https://imgur.com/iPR3Vlx

                  -Duplicate mayor's shorts. I guess my gathering perk doubled the shorts when I picked them up. Kinda weird since I cant trash them, but also fun since I got to complete the quest and do cool stuff with the shorts.

                  -Sebastian's head cut off. In the cut-scene where I go into Sam's room and tell them what kind of music I think they should play Sebastian is missing the top part of his head. https://imgur.com/a/xFQFLtD

                  -Walking animation broke. I went to pick up something and it got weird. I fixed it by pressing a on my sword and I think that is what triggered it too. https://imgur.com/a/Mh6WtCy

                  -Soft-lock at the community center. When I am holding an eatable item it seems and interact with the billboard at the community center after I exit the billboard the whole game soft-locks and must be closed in the switch menu. I have been able to recreate this several times. Here are images of how my progress on that part of the community looks like in case it is a contributor. https://imgur.com/a/BHuIVRo

                  -Controller select screen. I only play this game in portable mode and every time I put my switch to sleep and wake it up I get prompted with this screen. I dont mess with the configuration of the controllers while I am playing or while it is asleep. It only happens in this title and not in any of my other games when doing the same thing. https://imgur.com/a/4tpbkuv
                   
                    Gandalor 75 likes this.
                  • shanefricker69

                    shanefricker69 Space Hobo

                    I got the exact same glitch. Same scene and everything.

                    I also got a glitch during the Festival of Ice, where casting my lure caused the fishing rod to be stuck upright and unable to continue the event. Eventually the event ended at the end of the timer. Apparently though this is a common issue, since googling it showed me many others having the same problem. Still sucked though.
                     
                    • pengirl55

                      pengirl55 Space Hobo

                      I've found the following two bugs:

                      I've been having an issue adding items to the community center bundles ONLY when there are two rows of item slots. For example, the Dye Bundle has six item slots as two rows of three slots. I can place items in the top row but I cannot place items in the second row of item slots. This happens on any bundle that has two rows. No matter what.

                      When in the Adventurers Guild shop, the mouse icon does not appear when scrolling through items or when hovering over my inventory. I can still sell items from my inventory, but it's challenging.
                       
                      • Gandalor 75

                        Gandalor 75 Star Wrangler

                        Hey Shubeans, wanted to let you know that in single player, as that is all I play, the music is still being quite weird. It is still doing the thing where your first day playing it works normally but on subsequent days it won't start the morning music untel you leave the farm. This is kinda annoying but not game breaking and I just wanted to make sure that it was known. Good luck and I hope you guys are able to get a patch out for this stuff soon. ^_^
                         
                          Last edited: Jul 16, 2019
                        • okaycomputers

                          okaycomputers Space Hobo

                          Since the Switch patch, I'm having a huge problem with a glitch where my cursor disappears after I go to sleep. When my sales tally up for the night, it's not there, but I'm able to escape by hitting a different button. The real trouble comes in when any kind of pregnancy happens. At first, one of my goats gave birth in the night, which was cool -- but then when the screen asks what to name them, the cursor went blank. I couldn't type in anything, hit the randomize button, or escape otherwise. I was able to work around this by restarting the switch, replaying the day, and disabling the pregnancy of my farm animals before I went to bed, but it happened when Penny was pregnant, as well. When the screen asked "what should we name him?" the cursor was gone yet again, only this time, I'm kind of stuck. I can restart the game and go through the day again, but Penny will still give birth at the end of the night, effectively ending my file. I'm kind of upset since I made a lot of really cool things and good progress on this file. Please fix this so I can keep playing!
                           
                          • Gandalor 75

                            Gandalor 75 Star Wrangler

                            Hello again, I have another single player problem to report. I thought that this had gotten fixed but apparently not, I am still able to ride my horse through placed walls. I will post footage once I get an opportunity to play again, but I wanted to make sure this was known in the mean time.

                            Description: On horse, ride at virtical wall, go at angle or virtical along wall, while fully against wall quickly move directly into wall again. At this point you should be able to pass through the wall piece as though it wasn't there at all.

                            I will double check that the horse is required to do this when I get that footage. Hope this was good enough to help.

                            P. S. I still get the random dropped frame. Have a good day everyone.

                            Edit: Here is the video. Also I caught another bug in the video that has been around on Switch sense before 1.3 came out. At about six seconds is a frame drop that can cause tons of problems in game. I have missed numerous fish because of it. Missplanted crops because of it. I have even come close to death in the mines/skull cavern because of it. Hope this all helps.

                             
                              Last edited: Jul 17, 2019
                            • Desmond0815

                              Desmond0815 Orbital Explorer

                              First Things first: Thank you for this great Game

                              Got a reproduceable Crash.
                              Situation:
                              Farmer is talking to Haley on Day 1 12:00 PM near the River in Cindersap Forest. Haley is Buisy with her Camera. (Screenshot)​
                              Steps to Reproduction:
                              Load the added Savegame (OR Start a new Game) ,walk strait to the River and wait till Haley is there operating her Camera. ​

                              This Crash came up talking to different Characters in different locations.

                              According to the Crash-Report the Error happend when trying to localize the Message to be displayed.
                              So i tried these Languages:
                              English OK
                              French OK
                              German CRASH

                              I added a Screenshot, the Crash-report and the created Savegame.
                               

                                Attached Files:

                                Gandalor 75 likes this.
                              • isisvera

                                isisvera Intergalactic Tourist

                                Hello been having a constant disconnection issue when playing with my wife on steam. We both have very good internet connections and i have tried every method i know of. invite code and by using i.p. address on Lan but every day or two whoever does not host disconnects which makes the game unplayable for us. I have seen this similar problem posted but have yet to see a fix for it. Anyone know if this has been solved? If you need any other information please let me know I'd love to get farming again.
                                 
                                • Gandalor 75

                                  Gandalor 75 Star Wrangler

                                  Honestly at this point I am seriously wondering if there is going to be a patch for these problems. I for one, would be very happy and glad to hear one way or the other. Any news on if a patch will come out before 1.4 would be amazing at this point. I hope the information we all have shared is able to help make the game better and I hope a fix will come eventually. Have a good day to all who read this. ^_^
                                   
                                  • aqlex239

                                    aqlex239 Space Hobo

                                    Generally, multiplayer on Switch mostly works for me, though I'm regularly encountering lots of small bugs. As someone else is hosting (either local or online), some of the most common ones:
                                    -Getting stuck on a loading screen for a long while, as the other person continues to play the game
                                    -Erroring out of the game during cutscenes or events (I can never manage to get enough points at the Fair to get the stardrop because I always error out and my game closes. The host is able to keep playing, but we've tried multiple times and I've never been able to rack up enough points before my game shuts down and I lose all progress for the day. Another example of this is the cutscene where one has to play Journey of the Prairie King with Abigail. I was eventually able to complete this cutscene by switching to Local, and having our switches be only inches apart. Again, the host had no issues with these sections).
                                    -I can never seem to water my plants that already have ripe produce. When I do this, the game instead opens the nearest chest. (This is on the river farm map, if that matters). Also, often, this ripe fruit is growing right alongside the water, in case that is part of the glitch. I can solve this by picking the fruit/vegetable first, and then watering, but it is still inconvenient.
                                    -Speaking of the above, I can never charge up a tool when I'm trying to water plants that are planted vertically, directly alongside the water (again, we're on a River farmland map). I either have to back up and charge up the watering can from further away, or just water my plants one by one.
                                    -This is avoidable, but again inconvenient. The host put some chests full of items onto the front porch of their house. One night after an event (the moonlight jellies event), we were both transported back to the farm. Unfortunately, I was transported to the other side of these chests (by the old wood pile on the porch, where a Mr. Qi note can be found at one point), and I had no way to leave this spot. The host was unable to clear the chests out in time before we hit 2am and my character fell asleep.
                                     
                                    • marky1991

                                      marky1991 Void-Bound Voyager

                                      I don't think it's ever been possible to water a plant with a crop present. You have to pick the crop first. Working as intended I think.
                                       
                                        Gandalor 75 likes this.
                                      • marky1991

                                        marky1991 Void-Bound Voyager

                                        I know it's been reported before, but it's not on the google doc: After the first day, the daily music doesn't play at the beginning of each day. If you leave the farm and immediately come back, it will start to play as expected.
                                         
                                          Gandalor 75 likes this.
                                        • Gandalor 75

                                          Gandalor 75 Star Wrangler

                                          Thank you Marky for also reporting this, I was wondering if I was the only one this was happinging to. ^_^
                                           

                                          Share This Page