1. This forum is primarily for mobile related issues - for support for PC/Console visit the support section of forums.stardewvalley.net

Stardew Valley Switch Multiplayer: Known Issues & Fixes

Discussion in 'Support' started by Katzeus, Dec 12, 2018.

Thread Status:
Not open for further replies.
  1. Leeser

    Leeser Intergalactic Tourist


    Just reporting in to also confirm enormous FPS drop on Switch since the multiplayer update. I have lots of animals on my farm and this makes it worse before they’re scripted to go to their coops and barns around 5:00. I have 5 Junimo huts and several sprinklers, so that’s a farm under heavy load. The music is also inconsistent on the farm. I guess what I’m saying is my save is a good benchmarking candidate for heavy bug fixes! Ha! But, seriously, I’d be happy to help.
    • heather99

      heather99 Space Hobo

      I have been having both the shader issue and the lag issue when the other person goes down the mine stairs that others have been reporting. The lighting issue has been happening only for me, not the other person I have been playing with who is the host, and only intermittently, not consistently.
      • milktanks

        milktanks Space Hobo

        Having the same issues as several people, but specifically JasonBachee, Ever since Fall started i have had issues with making a LAN connection with my husband on My switch (I am hosting) if he hosts it was fine, but the save data is on my switch. we switched to online connection and keep getting error messages. I contacted Nintendo, re-installed stardew valley and i have checked my internet connection. Nintendo told me to come here and let you know there was an issue. My husband Is not having issues playing online with any other games and we can make a LAN connection with other games. After looking into this thread I realized there must be something going on. we have crashed about fifteen times in online mode, and have spent hours trying to make LAN connections. My file doesn't show up even though I have three houses on my file (one is his) and we have played before just fine. Once we hit Fall 1 we started having connection issues A few times it booted us both right after falling asleep but before we saved, and about five times it has been in the middle of a day. nothing major happened and then all of a sudden i get an error code saying there was a connectivity error. I love stardew valley to the point that I own five copies of the game on several platforms! PLEASE PLEASE PLEASE help me play with my Hubby!

        Starving college student/mom who needs stardew time.

        ps. thanks for your consideration and time in repairing this bug!
        • Saul the Farmer

          Saul the Farmer Intergalactic Tourist

          Im having an issue with the game crashing during abigails 2 heart scene. Im playing multiplayer on my friends farm and everytime the scene starts it crashes right before i play journey of the prarie king with abigail. It boots me out and i have to rejoin my friends farm.
          • Erisi13

            Erisi13 Intergalactic Tourist

            I've got a similar issue on my game - My friend is host for a local game with just the two of us, and we were playing fine yesterday. Today, we both were trying to interact with shops at the same time (I was buying chickens, she was upgrading a watering can). Suddenly as I close the chicken name prompt I get the game crash to a black screen and then out, and now whenever I try to rejoin, clicking on the hosted game just takes me back to the main menu, rather than joining the game. We've both restarted our switches, but it doesn't seem to have cleared the issue.
            • MelodicTori

              MelodicTori Space Hobo

              Yeah, I also discovered this "issue". On a file where I previously had two item IDs in the character name, it continued to work just fine, I just couldn't do it again (like for example with chickens). But then today it stopped working completely, the brackets just disappear and only show the numbers.
              • kiwikenobi

                kiwikenobi Aquatic Astronaut

                I've noticed a lot of small things that might be glitches that I did not notice before the multiplayer update. I played only in single player, on a new file created after the update. Here is what I've noticed:

                There is a slight jitter or shake of the screen from time to time that is a bit disconcerting, it is especially noticeable when using menus, such as when using a chest, and also I seem to notice it a lot when watering plants with a charged up watering can. It's not the same as the lag that I've heard of other people experiencing. The game does not stop, just the camera sort of jiggles a tiny bit from side to side for a split second.

                When holding a torch and switching to another row of the bag, the glow of the torch stays in the spot where I was standing when I switched rows, even if I walk away from it, until I switch back to the row with the torch on it.

                The music that normally plays on the farm in the morning does not play, except when there is an event in the morning, like Marnie showing up with the dog/cat for you to adopt, or Demetrius offering to put bats or mushrooms in the cave. I can make the music start by walking onto any off-farm screen, like up to the woods or right to the bus stop, and then the music will keep playing when I go back to the farm. There is also a delay for the rooster crowing in the morning that I do not believe was present before the update. I wonder if it has anything to do with the missing music, since they normally happen at the same time, and instead there's a delayed rooster and no music.

                Strangely, the missing morning music started playing during a cutscene with the Junimos repairing the mine carts after I finished the bundles to unlock it, then it stopped after the cutscene was over, then it came back the next morning as if it were a normal morning.

                There is a sort of delay when going down to the next level in the mines. I may just be remembering wrong, but I feel like the game didn't "hang" when interacting with the stairs to the next level before the update. Now, I push the button to interact with the stairs, and the game just freezes for a second before going to the loading screen for the next level of the mines.

                Once, one of the early levels of the mines was in darkness when I know it was not supposed to be, because it was one of the early levels, before the dark levels are introduced. But that was a weird one-time thing, and it never happened again.

                When NPC's mention buying items you've sold to Pierre's, frequently, the grammar is incorrect, such as, "I bought some Potato from Pierre's." I believe these comments about buying things that you've sold are new with the update. Either that, or I somehow didn't remember them from before.

                When going to bed for the night, the game just stays on a black screen for a rather long time before showing you your profits for the day and any level ups you've earned. This used to be very fast before the update. However, the saving process is now nearly instant, when before it took several seconds, so perhaps it's just doing whatever it needed to do to save beforehand or something.

                I'll post again if I notice anything else. I really love this game, and I want to help it to become the best game it can be. :)
                  Last edited: Dec 31, 2018
                  Gandalor 75 likes this.
                • Gandalor 75

                  Gandalor 75 Star Wrangler

                  I just wanted to add that I have seen these in my files as well I believe. The second one, about night saving timing being different, I have had and is described by kiwikanobi about as well as I could say myself. I have noticed the Mine issue during a couple skull cavern runs. When using a ladder or shaft the screen seems to freeze for a moment and then cut to black to load into the next floor. There also seems to be less time for loot near you to be sucked in with the magnet rings when this happens. Prior to the update I recall there being a fade to black which froze enemies and time but allowed rocks or gems or items or what have you to be sucked in if it was able to. Now I am losing stone that is less than two tiles away from me with a large magnet ring on that should be collected while I am descending. Hope this is detailed enough. Thanks for working so hard to make this game work well on the Switch! ^_^
                  • Sinewavesurfer

                    Sinewavesurfer Space Hobo

                    Sleepy baby glitch: playing single player on switch, an existing game file that I continued playing after the update. Post update I agreed to a baby with spouse Harvey and had the baby. The baby never comes out of the crib, every time I try to interact with it it says "Marjorie is sleeping". The baby also doesn't appear on my social tab. My other existing file that had babies prior to the update is working normally in regards to the kiddos.
                    • gaskellreader

                      gaskellreader Void-Bound Voyager

                      My husband and I have been playing local coop and have encountered multiple instances of my hosted game not showing.
                      We’ve tried:
                      Closing the software completely
                      Testing our network connection
                      Restarting our switches
                      Resetting our network

                      In today’s instance, we were playing and started to lag so badly that his time was 2 hours behind mine. He left the game and tried to rejoin, but could not as the hosted game would not show in his list.
                      • Snochy

                        Snochy Intergalactic Tourist

                        When playing multiplayer on a local network, when any player goes up or down in the mines or skull cavern the other players lock up/lag while the player going up and down in the mine is in the loading screen between floors. Happens every time a player is traveling in the mines. Make its unplayable for all other players in the game. The lag effects all types of players; Client and/or host. Game progress doesn't effect the lag.

                        The lag / lock up happens from when the loading screen appears on the player traveling in the mines to when they complete their loading screen.

                        It appears the lag is from the mines/skull cavern loading the next floor causing all players to halt/lock up until the loading is finished.
                        • Speare

                          Speare Space Hobo

                          Can't see local communication games at all on Switch. One player hosts a game (local), other player goes to coop->local-communication and the menu is empty, even after refreshing.
                            hahasound likes this.
                          • Baelum

                            Baelum Space Hobo

                            Hello I know it’s not much to go on but during multiplayer sessions with a friend I have a screen visual bug that’s happening when night time comes around. I started up a new single player game to see if the problem is there as well and it hasn’t happened. Below are screenshots of my issue.

                            I’d also like to note this only happens while in handheld mode.

                            It also only seems to happen when joining a host.

                            This issue is always apparent in the mines on darker levels.


                              Last edited: Jan 8, 2019
                            • XxRoseQuartzxX

                              XxRoseQuartzxX Void-Bound Voyager

                              Hello I am currently having issue with the music and ambient sound. I have seen similar issues posted, but none seem to match mine in particular. I just recently got a Switch and downloaded Stardew, everything seemed normal until I met Robin in the intro cutscene, when she guided me to the farm the music cutoff and all was completely silent except for sound effects.

                              When my character woke the next morning I quickly noticed the Spring theme would not start up and only the ambient bird noises could be heard. If I exited the farm to the right going towards town the music would start up like it was supposed to but when I entered the town it would not cut to the town music, at least not right away. The Spring music would slowly fade, much slower than it was supposed to and then would turn into town music.

                              I then tried to restart a new game with similar results, even archiving and redownloading did nothing.

                              I did notice however if I closed the game, restarted, and loaded the current save everything would work like it was supposed to BUT only for that one day, when my character awoke for the next day it would be silent once again.

                              I am posting this because I haven't seen any official word on this bug being recognized and I hope it is not being ignored/being put on the back burner. The beautiful music is one of the best parts of this game!

                              P.s. for anyone reading there is another glitch I am concerned about that I have seen no official word on. The crops not growing even when watered every day, like the game somehow skips over certain crops.
                              • hahasound

                                hahasound Space Hobo

                                Hello all,
                                I've been having an issue using the local wireless multi-player option. When I first started playing I was able to utilize the option but I have not been able to use it ever since. Now whenever my partner hosts the farm I am only able to connect over the Online option . When my partner hosts locally the farm doesn't show up for me even though I have my own cabin built already. I know this is not an isolated issue, because I've read up on reddit who have had similar issues.
                                  Speare and manasial like this.
                                • emily3672

                                  emily3672 Space Hobo

                                  When I play multiplayer online, my game crashes when I enter the same room as the other person on the server. Does anyone know how to fix this issue?
                                    Last edited: Jan 9, 2019
                                  • manasial

                                    manasial Space Hobo

                                    My friend had hosted a game through local communication, me and another friend had connected to the game smoothly with no troubles. This lasted until we had another firend who wanted to join us through online, where we proceeded to host the same farm through online instead, everyone then connected with no issues.
                                    Things started to fail when we switched back to local communication the following day. Me and my other pal were unable to find the locally hosted game no matter How many times we pressed refresh/ restarted the game. The Online hosted farm works as usual.
                                    We then tried hosting an entirely new farm on local and turns out to work, thus only the first farm that was once hosted online seems to now be exclusively accessible via online host and join.
                                    Wondering if there's a solution for this as it is quite frustrating when we dont have access to wifi.
                                    • manasial

                                      manasial Space Hobo

                                      Should be the same issue as mine, local no longer works after we decided to host the farm online for a friend overseas.
                                      • dbw1989

                                        dbw1989 Space Hobo

                                        We have got exactly the same issue starting yesterday. Previously my wife was able to join my farm and the great experience unfortunately did not last long. We started to play Stardew Valley on our Nintendo Switches early on the week, all of a sudden the error code 2618-0006 started to appear on my screen as a host, and on her switch, it says "one or more consoles not responding". We are in the same LAN environment, and there was no config changed before the issue occurred. The only thing I could think of is, before it stopped working, both our consoles were DOCKED. Yesterday, my wife took both out of the cradle and played with my daughter for the same game, same family farm and it was working without issue. In the evening, I picked up mine and waiting for the wife to join the farm, the 2618-0006 occurred for the first time. Since then, we were unable to play in multiplayer mode any more. Each time it will throw the same error. I did notice when the issue first occurred, the battery level was below 40% on both consoles. I also have deleted, and reinstalled the game but to no avail. Such a great game, but due to this unexpected connection barrier we started to have negative comment.
                                        • swjunkie228

                                          swjunkie228 Space Hobo

                                          Like others, we’re having issues with online games staying connected (2 of us are beside each other one across town). We are also unable to find games the local option even though we were able to originally.

                                          In general when the non hosting players are kicked out they’re not on a screen with anyone else.
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page