1. This forum is archived for reference. For support & bug reports visit the help section of forums.stardewvalley.net

Stardew Valley SWITCH: Known Issues & Fixes (Patch 1)

Discussion in 'Support' started by Katzeus, Oct 11, 2017.

  1. Dainius

    Dainius Lucky Number 13

    Can confirm that crashed on sleep/save when cooked and had item at Clive for upgrading. Did not crash when did not cook that day.
      Typhoon likes this.
    • Kitkat6270

      Kitkat6270 Lucky Number 13

      I posted already but another bug I just encountered, a couple times I've put things into the recycling machine and when I leave and come back they are gone. There's nothing in the machine and it's not running anymore.
      • Kieto

        Kieto Space Hobo

        I can confirm the sleep/crush only appears if you have food in the fridge. I took everything out of the fridge and haven't had the bug since.
        • LoopyLuke

          LoopyLuke Big Damn Hero

          When breaking a stack of magma geodes, if the item inside is a dwarf gadget the RNG seems to get 'stuck', and will only produce more dwarf gadgets for the rest of the geodes in the stack. I found a thread on reddit where this was reported happening in the xbox version as well.

          Also, not a bug but the music seems to be mono on switch? Slightly disappointed cause I use headphones a lot and the music in this game is great.
          • paperstarships

            paperstarships Poptop Tamer

            Heart Event Camera Misalignment: The mis-alignment of the camera/weird focus during heart events seems to happen every time the characters aren't on the regular map. So far, this for sure includes Harvey's 10 heart event and Abigail's 2 heart event.

            For Abigail's 2 heart event, you can generally still interact with the event (trying to avoid spoilers here if at all possible) but you can't see Abigail at all (you can see most of the tops of her speech bubbles and phrases as she reacts to things).

            For Harvey's 10 heart event, like everyone else, I am only seeing the very top portion of the scene and neither of our characters are visible (along with most of what I assume is the focus, this is my first play through of Stardew Valley so it was quite disappointing). :(

            I reset the day for now, and I'm waiting for the patch so I can play again and actually watch the scene this time! It's too bad I've already missed Abigail's, and who knows how much more I've missed (I don't necessarily know if there was more to any other heart events I've witnessed so far, but for these particular examples, it was pretty obvious something was wrong).

            Line Casting Direction During Fishing (and Using Tools at an Angle): I don't know if we're supposed to be able to control the direction of the fishing line during casting (beyond directly in front of wherever you're facing), but if it's the case, it's something I've never been able to do. From what I understand of what I've read of the PC version, it's necessary to be able to do this to reach certain fishing spots. I've noticed there have been some totally unreachable bubbles (the ones that signify there are lots of fish there) and wondered how we were supposed to reach them (until I read that maybe we're supposed to be able to change the direction of the line during casting). Maybe I'm just doing it wrong, but is seems to be happening to others on the Switch version, too.

            I just learned in this other thread that you're supposed to be able to water at an angle, too - this is another thing I'm unable to do.
              Last edited: Oct 15, 2017
              Typhoon likes this.
            • Link1021l

              Link1021l Void-Bound Voyager

              I can also say I'm unable to move the line on the rod whereas I could on PC. I'm also getting random framedrops, where it'll just freeze for around half a second (20-30 frames lost). There is nothing unique or common about when it happens, I've had it happen when I'm holding the rod and the meter is filling up, I've had it happen when I'm picking strawberries, when I'm just walking around, when I'm caving, it feels completely 100% random but it is a bit frustrating.
              • yoyotimes5

                yoyotimes5 Space Hobo

                This same thing happened to me, but it wasn't a gadget it was Basalt. Got 8 in a row, I'm assuming the rng got stuck for that in the same way, also on magma geodes
                • AlternateRT

                  AlternateRT Scruffy Nerf-Herder

                  Regarding the looping music, this can be clearly heard in Emily's 6 heart event. After she finishes her dance the music just keeps on playing in a loop.
                    Typhoon likes this.
                  • ethanmaxcraft

                    ethanmaxcraft Scruffy Nerf-Herder

                    I encountered the same thing, however I think I fixed it by blocking again.
                    • Typhoon

                      Typhoon Spaceman Spiff

                      A few new bugs, and a couple that have been reported elsewhere:

                      "Haven't seen these posted anywhere so figured they would be worth sharing:

                      • In the "standard" farm location, there are a bunch of bushes in the top right area that you're able to walk in; 1 large, 2 small. Take as starting point the lower right of these (a small bush). Place a single furnace that is one tile down, one tile left from this, then a chest that is one tile down from the furnace. Now stand in the one free tile to the right of the furnace, looking left. When you use the furnace, it will also open the chest.
                      • When using Willy's fishing shop, frequently the cursor is invisible. I haven't ascertained any particular cause for this, but it has happened regularly since early in the game. I enter his shop, talk to him to open the shop menu, the cursor is invisible, though I can still move it and select items. Backing out and reentering the menu twice fixes it (the first time you reenter it's still invisible).
                      • I caught a gold star sea cucumber late at night, Fishing Level 9 (neither of these probably matters) then got a phonecall IRL and went afk. The player character must have been in the "held above head" pose, and time still advanced, to the point of 2am where I was taken back to my home by Jojo. When I awoke, the sea cucumber was visible to the left of player char in a speech bubble (<- this is the bug), and the fishing rod was selected in the leftmost hotbar slot. Switching to another tool in the 2nd hotbar slot hid the bubble, and switching back to the rod showed it again. Casting the rod cleared the effect and it no longer happened.
                      • When in the mines, the gold masked shadow people faced left and stopped moving. I couldn't ascertain a cause for this, and it has only happened once, at a high-90s depth. I had just killed a little helmeted gold munchkin (or whatever the real name is :rofl:) near them, spamming with the Obsidian Edge to do so.
                      • In Gunther's, when you deposit a treasure and get a New Reward, relocating the treasure will retrigger the New Reward announcement each time you do so. Though you only get a single reward (un)fortunately.
                      • When in the player char home, if you have an item held above your head, you cannot sleep in the bed, even if walking into it. Perhaps this is intentional, though it seems odd.
                      • When blocking with the Obsidian Edge (potentially any sword, not sure, used a dagger before getting it) your Scythe also displays the red cooldown, despite having no block capability."

                      • Typhoon

                        Typhoon Spaceman Spiff

                      • yochrisss

                        yochrisss Poptop Tamer

                        My game crashes when trying to load my character from the loading screen in portable mode. Havnt tried docked yet because Im at work, will try later.
                        • Typhoon

                          Typhoon Spaceman Spiff

                          Is your game installed on the Switch's internal memory or an SD card?
                          • massoluk

                            massoluk Space Hobo

                            Not sure if this is the known issue in the first page. I forgot what item it was. I have 2 of the same item when I donated it to the museum. I happened to get bonus reward notification. But there was one of said item left on my cursor. And now I'm stuck. I can't back out or go to any other menu.

                            I closed the game, I unstacked the item and it worked properly this time when I donated it
                            • EoinODoodles

                              EoinODoodles Space Hobo

                              I've encountered a glitch with the crab pot tool that doesn't seem to be listed yet. It's a bit obscure, and it's just a slight nuisance and not something game-breaking, but I managed to place a crab pot in such a way that I can't interact with it. I can't add bait to it and I also can't put it back into my inventory, so it seems to be stuck where it is permanently!

                              This happened to me on the south-most bridge in Pelican Town (the one between the mayor's house and the library). I dropped crab pots into the three water tiles directly upstream of the bridge on the left bank of the river - these all behave fine and I can still interact with them. The trouble is that I used the right joycon's analogue stick cursor to position a fourth lobster pot just above the first three lobster pots (so, four tiles north of the bridge's left side) where there's a small bend in the river. The pot seems to be inaccessible because the bend makes it slightly too far away from the player.

                              It'd be great to be able to remove that troublesome crab pot, I'm worried the townsfolk will think I'm littering! I'll try to take a screenshot of the affected crab pot if there's any difficulty reproducing it, but I'd imagine it'll happen anywhere there's a river bend water tile. :)
                                Typhoon likes this.
                              • yochrisss

                                yochrisss Poptop Tamer

                                Internal memory
                                • Typhoon

                                  Typhoon Spaceman Spiff

                                  Thanks. I was wondering if the issue was down to a known random problem with the game installed on an SD card.

                                  Have you checked for corruption in the game's data - here's how to check:


                                  You could also try re-installing Stardew Valley (but when you delete the current copy of the game do make sure that you KEEP the current save data!)

                                  Or just try the Switch docked as you said you would do.

                                  Please report back here to update this thread.
                                  • Willyam

                                    Willyam Space Hobo

                                    same thing with me. Once i removed everything from my fridge, I progressed to the next day just fine.
                                      Typhoon and Kieto like this.
                                    • Typhoon

                                      Typhoon Spaceman Spiff

                                      Thats great. If you feel like doing an experiment (at the risk of a crash) please either cook something or remove something from the fridge but after doing one of those put a food item INTO the fridge. Do not empty the fridge. Then end the day and save. Does it crash then?
                                      • ResQ

                                        ResQ Space Hobo

                                        MaraPearlskin and Typhoon like this.

                                      Share This Page