1. This forum is archived for reference. For support & bug reports visit the help section of forums.stardewvalley.net

Stardew Valley SWITCH: Known Issues & Fixes (Patch 1)

Discussion in 'Support' started by Katzeus, Oct 11, 2017.

  1. Typhoon

    Typhoon Spaceman Spiff

    "At the start of Linus 4 hearts event, after he says "come near the fire" (paraphrasing), if you click the mouse rapidly, the attack animation occurs and you can't move (have broken trident equipped)

    game stuck, music continues, can't move, no input will respond"

    • vanYth

      vanYth Lucky Number 13

      At the Stardew Valley Fair when talking to tourists while not standing still, my character continued running till the conversation was over. Talking to other villagers was fine.

      (Played in TV mode)
        Typhoon likes this.
      • squeakyferret

        squeakyferret Scruffy Nerf-Herder

        Regarding the "Footstep sounds not syncing" bug:

        For me, it happens when I'm watering crops. Footsteps are normal, until I'm about halfway through watering a row of crops, and then sometimes when I'm stopped and actually watering a square, the footstep sound will just keep playing, even if I'm standing still. It can go on for like two seconds or more.
          Typhoon likes this.
        • Typhoon

          Typhoon Spaceman Spiff

          Katzeus likes this.
        • Heruderu

          Heruderu Space Hobo

          Update: In both days, 17 and 18, it is snowing. So I thought that could be related to weather. So, Winter 19, snowing, I tried upgrading again: crashed. Winter 20 was snowing again, so I kept playing normally without going to Clint. Winter 21, a sunny day, I took my Watering Can to upgrade to gold. DIDN'T CRASH.

          Hopefully this is helpful for the devs. At least in my case, there is something to do with upgrading tools and weather in Winter. I had this crash before in Fall, but can't recall if it were raining and if I were trying to upgrade anything.
            paperstarships likes this.
          • Typhoon

            Typhoon Spaceman Spiff

            I've just copied the gifting bug reports over from the old thread and added some more reports to it as it keeps cropping up:

            "When gifting people for the first time it sometimes says you already gifted them and the character only responds to you about the gift after you talk to them again. Happened 3-4 times so far on week one."


            And this:

            "I was encountering a strange bug with Penny. I gave her a gift on Day 1, and when I tried to give her a gift on Day 2 it said I had already given her 2 gifts this week. Then every once in a while her dialogue just doesn't pop up when giving her gifts."


            and this:

            "When giving gifts to villagers sometimes, the first dialogue pops up as “you’ve already given a gift today”, even though it’s the first time. Talking to the villager afterwards will show the “gift” dialogue that should’ve gone off when first gifting them."



            "I had a bug where it told me I had already given Haley too many gifts that week on a Monday... and in the relationships bar, both slots were filled. But it was a Monday, and I hadn't even given her a gift yet that day, so that shouldn't have been at all possible. Somehow it didn't reset from the previous week."



            "A bunch of times I tried to give a gift to a villager and it'll say "you've already given ______ a gift today!" when I definitely did not. And sometimes the first time I talk to someone on that day will thank me for the gift (even though I wasn't holding anything so gave them nothing)."


            "Is anyone having issues with gifting? On multiple occasions, I've selected the item I want to gift, gone to talk to the giftee, and the game says "You've already given ______ a gift today" which is definitely not the case. Is it a 24-hr (in game) thing?"

            Stencil on Neogaf: http://www.neogaf.com/forum/showthread.php?t=1443101&page=47

            and then some replies:

            "Yeah I have the same problem."

            "Did you check that you still have the item? I have times when it does give the gift but that message pops up."

            "I think it's a glitch in you not getting the dialogue box for giving the gift. I had a similar situation then realized my item stack was 1 smaller and there was an x in the weekly gift tracker box. So I gave the gift, just didn't hear them express thanks for it."

            "You can only gift two times per week. A new week starts on Sunday. Only one gift per day.

            Edit: Ah, okay, it seems to be a bug."

            "This has been an issue since forever in the PC version. If you want to hear them give thanks (which can be important since it will tell you if the gift is good or not), just talk to them again sans gift item."

            "Yeah I remember getting that bug in the PC version."


            So, in short, it's an old bug. It could still do with being fixed of course. :)

              paperstarships likes this.
            • Willyam

              Willyam Space Hobo

              I'll be happy to do more investigating on the sleep bug within my limitations. If anyone can think of something that'll help.
              • Typhoon

                Typhoon Spaceman Spiff

                • The first bug I encountered last night was during the 2 heart mini game with Abigail. During the round of Journey of the Prairie King you play with her, if she dies and you happen to be crossing into the area where she respawns at the right time she will respawn on top of you and lock both of your characters in place. You can only move again once you both either die, or the round/minigame ends.
                • Bug number 2 is with the fishing minigame during the Stardew Valley Fall Festival. When entering the little pond area after paying the guy his fee, my toon is glitched up. He doesn't have any walk animation and just kind of glides around the room. You can fish as per usual, but the animation is all messed up. The rod will move and cast, but my toon won't move. Also, I messed up the cast (didn't charge it past the first little red section on the meter) and instead of it resetting and letting me cast again like it would if you cast into the ground or grass, it locked my toon up and I couldn't move or do anything. The little timer still ticked down and the music played, but once the timer ran out nothing happened and no button presses would register. I let it sit for another 3 or 4 minutes, but nothing happened. I had to quit to the Switch home page and kill the game and go back into it.

                I hope this help someone somewhere!"

                  paperstarships likes this.
                • namroth

                  namroth Space Hobo

                  Bug: game crash
                  Cause: crafting the warp totem: farm sleeping/passing out.
                  this closes the app and starts the day anew
                    Last edited: Oct 13, 2017
                  • alicat1235

                    alicat1235 Void-Bound Voyager

                    This has happened to me almost every day. While I felt that the music was off from the very beginning, I fully realized there was a problem when rain sounds didn't happen outside (it was eerily quiet) and then when they did occur they did not stop when I went inside houses. As someone who has played on PC quite extensively, it was fairly obvious that the music wasn't right. Something just felt off.
                    This also occurred when I went to get my fishing rod from willy. I believe it was day 3. I had attempted to visit him on day 2, but for some reason the cutscene didn't trigger and instead he was just fishing outside his store, I said hi to him there. When I did do the cutscene the next day, the normal beach noises didn't come back once it was completed, so I had no sound of waves.
                    Another time that this has happened was when I left the town via the minecarts and went to the mine. The town theme was playing at that point (so it should have stopped when I left the screen. However it continued even as I went down the mine. I most likely took the minecart around 10-12 in the morning and I was in the mines until almost midnight with the same song playing the whole time.
                    I'm not sure if the music looping and the sounds playing on the wrong screens/not stopping are the same issue though. It is possible that these issues are separate.

                    Are there any details specifically that you need for figuring out how to fix this issue? Like I said, it occurs in my game very frequently and so I'm sure I can provide any daily details required.
                      Typhoon likes this.
                    • Willyam

                      Willyam Space Hobo

                      To those experiencing the crash before tally screen, do you have the minecarts repaired?
                      • Dgray

                        Dgray Space Hobo

                        No, I do not have the minecarts repaired but still have crashes. Cooking is what makes my game crash.
                        • Ap0c4lyptyc

                          Ap0c4lyptyc Big Damn Hero

                          Are you cooking from your Fridge inventory or your personal inventory. I can cook from my personal inventory, but everything crashes if I try to cook from the fridge.
                          • N7forLife

                            N7forLife Void-Bound Voyager

                            I have just begun to experience the "save/sleep bug". My game seems to crash after fishing / cooking.

                            The game crashes right after i select "yes" to sleep and fades to black. I never get to the product tally screen.

                            If i just wake up, tend to my crops and animals it saves fine, however i noticed whenever i went to fish I would fill up my shipping bin at around 11-12am and then cook some sashimi before bed, the game crashes. If i avoid those things it seems ok.

                            I only play in handheld mode also. Currently in my game its the 27th of fall.
                            • AlternateRT

                              AlternateRT Scruffy Nerf-Herder

                              I've had this bug before as well. Whenever it happens to me I just have to press the A button again and it seems to always fix the problem. However, there was a time that it did not work, so instead I just had to select an item from my hub bar with the mouse pointer.
                              • Typhoon

                                Typhoon Spaceman Spiff

                              • Typhoon

                                Typhoon Spaceman Spiff

                              • Typhoon

                                Typhoon Spaceman Spiff

                                As we all know, there are problems with cursor selections at times (devs are aware and fixing) but these can be worked around in-game by disabling the option ‘Use controller-style menus’.

                                However, this doesn't solve one aspect (which is admittedly very minor) - the title screen easter eggs. I don't want to give out any spoilers, but let's just say that clicking on the Stardew Valley title screen letters (where the LOAD/SAVE screen is) triggers certain things ....... however, due to not being able to "free roam" the cursor on the title screen it's impossible to reveal these easter eggs on the Switch version. Hopefully this can be fixed when the high priority bugs (and especially the sleep crash bug) are resolved.
                                  AlternateRT likes this.
                                • Dgray

                                  Dgray Space Hobo

                                  From my fridge inventory. I haven't tried from my personal inventory.
                                  • HyperFlux

                                    HyperFlux Void-Bound Voyager

                                    • (Need more Details) Softlock while fishing
                                    I just had this . Playing portable with joycons detatched (due to rumble not working attached) i took the bamboo pole out of a chest to as to not waste my bait on my 7.5k one. I then tried to fish in the small pond near the house to get some trash to recycle. I switched to bamboo. Tried to fish but misclicked and only used a tiny bit of power. It didnt go far enough to hit the water properly and reset. But when it reset the rod was stuck over my character and i had to reset. Picture

                                    I had a similar issue when i bought a new rod and tried to use it in the ocean and it did a similar visual glitch but didnt make me stuck. It seems to have happened both times when i had just obtained a second fishing rod and tried to use it straight away. I fixed the visual bug by switching to a different item and back again[​IMG]

                                    Bonus shot of visual glitch
                                      Katzeus and Typhoon like this.

                                    Share This Page