Stardew Valley Multiplayer: Known Issues & Fixes

Discussion in 'Support' started by Katzeus, Aug 1, 2018.

  1. margotbean

    margotbean Scruffy Nerf-Herder

    @Katzeus (and @tccoxon) -- I think Secret Note #14 is misfiring ("I hid something behind the Community Center").
    In this post from the old bug reports thread: https://community.playstarbound.com...own-issues-fixes.142850/page-183#post-3276650 Katzeus said that Eric said that Secret Note #14 would do nothing if the player purchased a Joja membership. But I've just started a new game with v1.3.32, purchased a Joja Membership, it's only Spring 27 of year 1, and I found the Stone Junimo behind the Joja Warehouse.

    There is this code in StardewValley.Locations, Town.cs:: DayUpdate
    if (Game1.dayOfMonth == 2 && Game1.currentSeason.Equals("spring") && !Game1.MasterPlayer.mailReceived.Contains("JojaMember") && !this.isTileOccupiedForPlacement(new Vector2(57f, 16f), null))
    {
    this.objects.Add(new Vector2(57f, 16f), new StardewValley.Object(Vector2.Zero, 55, false));
    }


    Object 55 is the Stone Junimo statue from BigCraftablesInformation.xnb. According to the old post, the statue should spawn for players migrating v1.2 saves over to v1.3, but they may have to wait till Spring 2 to get it. So, something has gone wrong. Unless Eric changed his mind, the statue is spawning on Spring 2 of year 1, I think. Which is well before anyone can purchase a Joja membership, and well before the Winter Mystery quest can happen.
     
    • TheHyruliest

      TheHyruliest Seal Broken

      I posted a thread about this last week but I figure I should put it here too now that it looks like it's happened to someone else:

      My friend and I were playing multiplayer on PC (about a week before the most recent update) and got the witch event on the night of Spring 5. It yielded 2 void chicken eggs, one of which we put in the incubator (on Spring 6) in our fully upgraded coop (which currently houses 5 animals). We stopped playing after making it to Spring 23, and resumed again after the most recent patch, which we both downloaded.

      As of 19 days into Summer it still had not hatched. Out of curiosity we tried to shove a different egg inside, causing the incubator to turn into a tapper.
      [​IMG]
      My friend disconnected to restart the day and tried it again, and this time it turned into a furnace (and an active one at that!)
      [​IMG]
      Meanwhile, the second void egg seems to have disappeared from the chest it was placed in.

      Someone replied to my thread saying the same thing happened to them; while playing multi on pc they got the witch event early in the Summer, as of mid Fall the egg hasnt hatched, and attempts to put more eggs yield in the incubator becoming a tapper or a furnace.
       
        Last edited: Nov 27, 2018
        Keralimah likes this.
      • Keralimah

        Keralimah Poptop Tamer

        I was the other person this happened to. What we ended up doing was building an entirely new coop and upgrading it to a Big Coop as well. We transferred our chickens and ducks into it and resumed as we were. To add more information, once the new coop was made and upgraded we put a duck egg into the incubator. I can confirm that it incubated normally and a duck hatched. We currently have a dino egg in it as well, and it seems to be going fine as well.

        This is my first time playing Stardew, so one thing I didn't know was that the incubator sprite changes when an egg is inside it, apparently. We noticed this change of sprite and the "working" animation (the slight stretching and squashing) played with the duck egg and is playing currently with the dino egg, but with the void egg, only the "working" animation was playing and the sprite was just that of an empty incubator.

        Furthermore, before we decided to build a new coop, I did download a save editor and the two of us examined the XML of the incubator. We weren't able to understand....basically anything in there but we did find the (forget the exact phrasing) "minutes until ready" variable and it was still at 9000, even after like 3 weeks of the void egg's incubation.

        I don't know how much, if any, of this helps but I figured more info can't hurt! ^^;
         
          TheHyruliest likes this.
        • scararmst

          scararmst Space Hobo

          So... My Enter code to join multiplayer button has... dissapeared?
          I know I'm not the only one with this problem, but I tried everything I could find online and nothing fixed the issue. So i decided to report it. I tried stuff like reinstalling credist, reinstalling the game, disabling the firewall, checking my steam profile (public, btw) and that's it. Nothing fixed it. Hopefully some light will be shed on the issue. Thanks!

          [​IMG]
           
          • margotbean

            margotbean Scruffy Nerf-Herder

            So I see this post is no longer stickied. Does that mean all the existing bugs are not going to be fixed, or that CA is going to set up some other system for reporting bugs?
            There are a LOT of bugs still in the game -- Sebastian's lobotomy during Sam's 2-heart cutscene, slimes warping through the player, mosters being "buffed" before reaching the bottom of the mines, 7-heart recipes being sent at 3 hearts, Shane being stuck inside the Ranch all day on Winter 15, and these are just off the top of my head.

            What gives?
             
            • Katzeus

              Katzeus Community Manager Chucklefish

              Hey I was the one who unstickied. I'd only temporarily unstickied it to reduce confusion for the Switch launch, it's still being monitored, and will be restickied in a few days.

              Also, things identified as issues we've escalated into our internal ticketing system - this thread isn't how we track bugs or determine if they're 'open'.
               
                margotbean likes this.
              • United_Steaks

                United_Steaks Intergalactic Tourist

                Is the constant disconnection for Co-op on PC Steam still a common problem or has there been a fix for that already? Because my friend and I both have great wifi but I keep disconnecting from their server.
                 
                  Chyzon likes this.
                • Katzeus

                  Katzeus Community Manager Chucklefish

                  There have been some fixes - are you getting an error when you disconnect? Is it only in one location or only with one friend where it's happening?
                   
                  • United_Steaks

                    United_Steaks Intergalactic Tourist

                    No, my friend and I just get booted out of the server with a disconnection message, "The server has closed the connection". It only happens to the person connecting and not the host.
                     
                      Chyzon and Piedawg55 like this.
                    • GenericSpider

                      GenericSpider Space Hobo

                      So, I've encountered an issue that left me unable to use the multiplayer.

                      On the waiting for player screen; I lost my internet signal. This caused the game to crash; and only display the Stardew Valley logo. This somehow caused the people I was playing with to be stuck on the waiting for player screen.

                      When I reloaded the game; the option to put in an invite code had disappeared.
                       
                      • margotbean

                        margotbean Scruffy Nerf-Herder

                        Steam gave me a beta update (600mb) yesterday, but the game version # didn't change. Any idea if anything visible to the player was changed?
                         
                        • yamina-chan

                          yamina-chan Scruffy Nerf-Herder

                          There is a strange issue going on since the last update, where after you've played for a day, the music on the farm stops playing. All further days in the same session have no music playing untill the lunch theme kicks in.
                           
                          • Calmer

                            Calmer Space Spelunker

                            Seconding this issue. A friend started their fresh multiplayer farm last night, and upon joining, I realized their farm wasn't playing any music upon starting new days.

                            The daily music only seems to kick in for each individual player if they leave the farm screen. Really takes some "life" out of the game.
                             
                            • Berbe

                              Berbe Space Spelunker

                              It seems this problem is not fixed despite changelog lines addressing it in recent updates...

                              Could anyone having access to the bug tracker give us status update on how it is handled?
                              There also is a dedicated thread about that problem.
                               
                              • derpman4k

                                derpman4k Space Hobo

                                Hey guys, my friend and I have been trying to play through Stardew in Co-op mode and we have been noticing some really bad lag in the Skull Caverns, I'm unsure if this is a bug or not but it only happens in caves. The normal caves have lag but the Skull Caverns have really bad lag, which doesn't appear anywhere else in the game. Sorry if this is the wrong place to post about this but I don't see it mentioned anywhere else.
                                 
                                • TellyGaga

                                  TellyGaga Space Hobo

                                  So I think the code for my horse got messed up somehow. I made a post about it but have not received a reply. After I built my stable I was not given the option to name my horse. My horse has no name. The game doesn't recognize that I have a horse. When I looked at the string of text for my save file this is what it says for my horse, "<NPC xsi:type="Horse"><name />" Is this a known bug/issue?
                                   
                                  • XxRoseQuartzxX

                                    XxRoseQuartzxX Orbital Explorer

                                    Making a report about the music, it's seems to be out of sync.

                                    What I mean is every morning when my character wakes up no music will play only ambient season noises. If I exit the farm to the right the music will start up but will not change to the village music when I enter town. I have noticed this on the switch version as well so perhaps it is connected to the 1.3 update?

                                    Either way it is pretty annoying when playing...
                                     
                                      margotbean likes this.
                                    • Mizrani

                                      Mizrani Space Hobo

                                      I have just started modding stardew after having played it vanilla for a long time. Today I wanted to play with friends and co-op has worked fine before, but today after starting up the game and my friend joining he could'nt exit his cabin. When we slept his game also crashed. We tried restarting the game, I moved the cabin to a different location, but it didn't help.
                                      We made sure before that we both have the same mods and as far as I can tell none of the mods should have a problem working in multiplayer. I have tried googling the issue but can't find anything.

                                      Mods in use:
                                      Aoutomate 1.11.1
                                      Tractor mod 4.7.3
                                      Ace's Expanded Cellars Acerbicon Cellar
                                      Bigger Greenhouse 1.2
                                      MailFrameworkMod - v1.3.2
                                      AnimalHusbandryMod-v2.2.2
                                      PyTK-Platonymous Toolkit
                                      Content Patcher 1.6.3
                                      Stack Everything
                                      MTN(More than necessary) 2.0.0-alpha5
                                      Ace's Building Tilesheets
                                      Community Farm-2.0.1

                                      The only error I find in my log is:
                                      [13:52:24 ERROR SMAPI] Skipped mods
                                      [13:52:24 ERROR SMAPI] --------------------------------------------------
                                      [13:52:24 ERROR SMAPI] These mods could not be added to your game.
                                      [13:52:24 ERROR SMAPI] - [CP] Ace Expanded Cellars - Eemie because it contains files, but none of them are manifest.json.

                                      And it only says my friend is leaving the game when he crashes.. He didn't have any crash logs either. I assume he was just kicked out of the game but I don't know why.

                                      Appriciate any info anyone might have on this since I really want to play with friends and stillmbe able to use mods.

                                      Edit:
                                      Ok so we tried starting a new game and now more errors showed up in the log
                                      New log and savefile added. Pippi_207411204 is the new save file
                                       

                                        Attached Files:

                                        Last edited: Jan 17, 2019 at 2:24 PM
                                      • Piedawg55

                                        Piedawg55 Space Hobo

                                        My wife and I have been having a similar issue where I host and she constantly disconnects after being in the game for varying amounts of time, despite perfect wifi and high end computers. I at least am glad at least that it sounds like it's not just us having a one off issue. Has anyone else found a way around this, or why it is happening to just a few players???
                                         
                                          Chyzon likes this.
                                        • Chyzon

                                          Chyzon Space Hobo


                                          Same here with my girlfriend. I host the game and don't have any problem about connexion. On her side it often takes her 3 or 4 tries before being able to join the game. And constantly disconnects after varying amounts of time. Since the beginning of the game she wasn't able to play a single day without being disconnected. And we feel like it's getting worst from day to day (game days), we are in summer and she can't even play enough to go outside the farm ... It happens when she fishes, when she walks, browse her inventory, harvests ... It doesn't seem like there is a fixed event that kicked her out. Sometime she even doesn't do anything, like not moving in the lodge and not doing anything, and she gets kicked anyway.

                                          We tried to check the error log but it's not created so I guess there are no errors to report...

                                          I browsed the internet for clues and didn't find any, except something about Visual C++ not being installed. So we installed it (maybe again), but nothing changed.

                                          If you need any information I'll be glad to give them. It's now impossible to play and starting to be very annoying.
                                           
                                            Last edited: Jan 22, 2019 at 2:30 PM

                                          Share This Page