Stardew Valley Multiplayer: Known Issues & Fixes

Discussion in 'Support' started by Katzeus, Aug 1, 2018.

  1. thmtrxhsu

    thmtrxhsu Tentacle Wrangler

    "Hello, In our 4-player multiplayer game we went into the Stardew Valley Fair -event in Fall and as a host I was unable to do the fishing and darts minigame. In both any key did not work at all and I was forced to just stand in place.
    This is a quite new save in year 1."

    Similar situation, but 2-player local coop. I believe the bug is multi-player triggered. Still no word from anyone on this bug.
     
    • Bafiomelon

      Bafiomelon Space Hobo

      Hello! I started a new game recently and I noticed some weird bugs:
      1) My character had green eyes, but after the first reload they became brown (like the default farmer). I made a new game to see if that was happening again and yep, it was.
      2) When I first went mining on day 5, at level 6 in the mines I dropped a cherry bomb on a Slime. I wanted him to blow, instead the game crashed after the bomb exploded: a simple white screen. That was so sudden I bursted in a very long laugh. Well that Slimy guy got me, didn't he?
      Please note that I updated the game to the most recent patch and that I don't use any mod. Thank you for all your amazing work
       
      • foxingworth

        foxingworth Master Chief

        Hi,

        We have two players, one on GoG one on Steam both on the latest 1.30 beta. Had two random crashes today, error logs and saves attached.
         

          Attached Files:

        • Gylentia

          Gylentia Yeah, You!

          I'm running into the same problem as Far-To-Much in the Feast of the Winter Star and the same problem as Bafiomelon with green eyed characters defaulting to brown when the game is reloaded. While the green eyes one is just annoying, the other one is much more concerning because I can't play the event without this happening.

          My details for the Winter Star one are that I had Emily, and George had me. I gave Emily an Amethyst and George gave me a Jade. I tried talking to everyone, not talking to anyone but Emily, and talking to everyone but George to see if anything would change and it didn't. The game isn't frozen because the regular sprites are doing breathing motions and such. The only action that I could get to work was the chat box.

          Edit: This was in single player mode, not multi and I have the 1.3.30 installed.
           
          • tccoxon

            tccoxon Procedurally Generated Programmer Chucklefish

            We've seen reports of this come up a couple of times, but we haven't been able to reproduce it ourselves. Could you tell me what precise version of the game you're using, whether you obtained it through Steam or GOG, and whether you have SMAPI or any mods installed?

            EDIT: We've managed to reproduce it today. As a workaround, until we release the fix, make sure your active hotbar slot is on a tool or an empty slot before entering a festival.

            Thanks, we've been able to reproduce this issue and will fix it in the next patch.

            Are you using the current beta branch, or are you on the default branch? Do you have SMAPI or any mods installed?

            Are you sure this was in the latest version of the game, v1.3.30? We already fixed a bug that was present in v1.3.29 that caused a crash when using a bomb, which sounds a lot like this.

            Did the game close when this happened, or did it lock up on the white screen? If it closed, please send the crash logs--they should be in %appdata%/StardewValley/ErrorLogs
             
              Last edited: Sep 24, 2018
            • Lovely Beast

              Lovely Beast Orbital Explorer

              I keep crashing when I try to join my friend's game on day 5. I first crashed when she went into the community center cutscene, and then afterwards when I tried to reconnect it would let me see her game and start to connect (she would get the notification that I joined the game), and then my game would crash to desktop. Error logs are attached, any thoughts?

              Edit: I was able to finally successfully connect after she made it through the community center cutscene and the mines cutscene. When I went to the community center I did not get a cutscene (but was able to access the Junimo note in the bottom corner). I did get a cutscene at the mines (as well as the sword), and the next day I was able to complete the wizard's hut cutscene successfully. Hopefully it's not like this for all cutscenes, because I really like going to the festivals...
               

                Attached Files:

                Last edited: Sep 25, 2018
              • Slockhart

                Slockhart Void-Bound Voyager

                I am having the exact same problem. After the cut-scene where I receive my gift, the game "freezes". I say "freezes" because the breathing animations are still going however, I cannot move or open any menus. The details are a bit different in my game. I had Abigail and Clint gave me a gift. I am playing in a multiplayer save but, the other player is not online. Tried all the same ways Gylentia did. The only thing that avoids freezing is not going to the event at all.
                 
                • tccoxon

                  tccoxon Procedurally Generated Programmer Chucklefish

                  We've updated the beta branch with v1.3.31 to address some of the issues reported since v1.3.29.
                  • Fixed junimos dropping crops on the floor instead of collecting them
                  • Fixed NPCs walking through the saloon doors
                  • Fixed a few rare-ish crashes that can occur when connecting to another player's game
                  • Fixed eye color being reset to brown after reloading
                  • Fixed inability to use rod / slingshot in festival minigames
                  • Fixed the title menu back button being hidden behind submenus
                  • Fixed inability to move after receiving a gift at the winterstar festival
                  Note that the default branch is still on v1.3.28 for now.
                   
                  • Poulpetrans

                    Poulpetrans Space Hobo

                    Hello, we are playing multiplayer and there are a lot of random crashes, they seemed to be related to fishing and purchasing items.
                     

                      Attached Files:

                    • wozearly

                      wozearly Tentacle Wrangler

                      I ran into exactly the same issue (PC, Steam, singleplayer, 1.3.28 and 1.3.29) with Clint, Marnie and (if I recall rightly) Demetrius.

                      I'd have to double check whether it affected every character I got to 3 hearts who could give a recipe at any time, or just those who give more than one recipe, etc. Margotbean also reported a similar issue at an earlier stage of the beta. It's not entirely clear what's causing it, as no other heart events seem to be mis-triggering.
                       
                        margotbean likes this.
                      • Pathoschild

                        Pathoschild Oxygen Tank

                        There's a typo in Linus' new event (Content/Data/Events/Mountain): rhythym should be rhythm.
                         
                        • margotbean

                          margotbean Scruffy Nerf-Herder

                          Pierre seems to be selling items from my Shipping Bin. I haven't visited him in weeks and weeks, but he's selling items I put in the Shipping Bin. Don't know if this is intended...
                          v1.3.28, singleplayer
                           
                          • tye

                            tye Space Spelunker

                            Trying my first multiplayer game. Host can navigate around just fine, but when I (Player 2/first farmhand) attempt to enter Town, the game gets stuck on the loading screen. I uninstalled a few mods I thought might be causing the issue and reset my Spring Town files, but it's still happening. How can I share the save file as the non-host?
                             

                              Attached Files:

                            • Danila1900

                              Danila1900 Space Hobo

                              The game remained on version 1.38. As a result, I can't create an invitation code for a friend and join a friend in the game. There is no "create invitation code"option in the settings. No way to " Invite a friend" steam does not offer to update the game
                               
                                Last edited: Sep 29, 2018
                              • Pathoschild

                                Pathoschild Oxygen Tank

                                @tye Does the host player have any mods installed?

                                @Danila1900 Stardew Valley 1.3.28 is the latest non-beta version. I don't think that affects the 'create invitation code' option, but make sure you're launching the game through Steam and try restarting your computer.
                                 
                                • gchristopher

                                  gchristopher Subatomic Cosmonaut

                                  1.3.31, downloaded via GOG Galaxy: "Enter Invite Code" is missing after clicking on "Co-op". Downgrading to 1.3.28 fixed it.
                                   
                                  • tye

                                    tye Space Spelunker

                                    @Pathoschild : Yes, the Host and I have the same mods installed:
                                    AutoGate
                                    AutoAnimalDoors
                                    BetterRanching
                                    BetterSort
                                    CJBShowItemSellPRice
                                    ContentPatcher
                                    - Pokemon Pets
                                    - Natural Clock
                                    - Rustic Traveling Cart
                                    - No More Bowlegs
                                    - Matching Slime Hutch
                                    FastAnimations
                                    GiftTasteHelper
                                    HorseWhistle
                                    NoFenceDecay
                                    NPCMapLocations
                                    RecatchLegendaryFish

                                    We're also using PokeMania mod, which is a copy/replace mod... If I'm going to attempt a fix with a vanilla install, would it need to be done on the host's version too? The host is not encountering any errors currently.
                                     
                                    • Pathoschild

                                      Pathoschild Oxygen Tank

                                      @tye Those mods shouldn't cause any issues that I know. Do the errors still happen if all players reset their content files? What if all players temporarily play without SMAPI?
                                       
                                      • Sleeping Fox

                                        Sleeping Fox Orbital Explorer

                                        Version 1.3.28, Steam, Single player, no mods:

                                        I triggered Sam's 2 heart event but skipped it, so I never told him what kind of music I like. Now I got the 8 heart event where the band plays and there was no music at all during their performance, just one minute of silence. Maybe this could be changed to a default or random music and band name if the player didn't make a decision for the band.
                                         
                                        • TehErk

                                          TehErk Void-Bound Voyager

                                          I haven't seen this listed here. I posted this on the main support page and no one has answered. I'm running the mainline version off of Steam right now. In multiplayer games, when someone goes through a hole in Skull Cavern, the game just pauses. The further down you fall, the longer the pause. You can click on the "X" and it makes a sound, it just stays on the black screen with the "You fell x levels" FOREVER. Sometimes hours of game time. Worse, when it finally does recover, it sometimes locks up or the monsters will act weird. Any ideas?
                                           

                                          Share This Page