Stardew Valley Multiplayer: Known Issues & Fixes

Discussion in 'Support' started by Katzeus, Aug 1, 2018.

  1. Far-To-Much

    Far-To-Much Space Hobo

    Couldn't get a screenshot of my bug since nothing seemed different at the time.

    25th, Day of the Winter Star: I gave my gift to Marnie and then received a gift, and after that cutscene I was unable to move or pull up my inventory or menu. None of the hotkeys worked, so I was stuck there next to the huge tree. Eventually I alt+ctrl+deleted the window but still.

    Another bug I've been experiencing is that blowing up bombs in the mines give me a white screen and crash my game.
     
    • margotbean

      margotbean Scruffy Nerf-Herder

      I can't get Elliott's 10-heart event to trigger. I've received the "elliottBoat" mail, and event 43 is not in my "eventsSeen" in the save file, but every time I go to the beach, I see an animation of debris popping in the air for no reason, and Elliott's cutscene won't trigger. Attaching save file for what it's worth. I'm still using v1.3.28 because I really like to set off bombs without crashing. ;) The save was created in v1.3.28 as well. Singleplayer.
       

        Attached Files:

      • l.vang

        l.vang Master Chief

        My back button is behind my save file tab, making it hard to exit the game.
         
        • mizeryschild

          mizeryschild Intergalactic Tourist

          Multiplayer is broken in the GOG Version 1.3.29.125537. With this version, there is no option to give or enter an invite code.

          If I roll back to Version 1.3.28, it works properly.

          Note: I am running Windows 10.

          Update: My friends on the most recent Steam version are unable to generate invite codes for GOG users to enter. It's complicating things. :-/
           
            Last edited: Sep 17, 2018
          • randomusername8256

            randomusername8256 Space Hobo

            what about the issues with fullscreen mode?
            since release, this game simply does not play nice with it
            I'm running it on a 1080p monitor and by default it always start on windowed borderless 1440*900, why?
            changing to fullscreen is not a easy task either, you have to switch between windowed and fullscreen modes in order to fix the corrupted tools menu
            and even after you set up everything correctly, the next time you start the game = windowed borderless 1440*900
            seriously...

            and while I'm here = PLEASE ADD THE OPTIONS MENU TO THE INITIAL SCREEN, we're talking about a pc game in 2018 after all
             
            • Swrundeep

              Swrundeep Space Spelunker

              The last 3 days I've been having problems with my game files opening and my character being stuck in a chat box or trapped in a continuous motion depending on the tool I'm on. All my files are single player. I haven't had this problem since the early days of the last beta. My game on steam should be fully up to date.
               

                Attached Files:

              • JackGhosen

                JackGhosen Space Hobo

                MULTIPLAYER***

                In the first year of my game, I placed fish traps in the ocean. But since I chose the "Trapper" and "Luremaster" professions, I couldn't bait fish traps ot change their locations. Whenever I try to pick up/bait fish traps, "Inventory Full" notices irritatingly appear. (If someone asks "Why are you trying to bait traps?", because they don't catch any fish or thrash despite the "Luremaster" profession.)

                Added pics and save file, thanks for your attention :love:
                 

                  Attached Files:

                  Last edited: Sep 15, 2018
                • boocat

                  boocat Void-Bound Voyager

                  Uh, excuse a really basic question, but I need to update my game to 1.3.29. It seems to be stuck on 1.3.28, even though I finally got the SMAPI updated to 2.8-beta.4. The SMAPI installer tells me to update the game - but I don't know where to go to do it! A link or something would be really helpful. I've wandered all over and can't seem to find the right place.
                   
                  • Andromeda31

                    Andromeda31 Orbital Explorer

                    I don't know if this is intentional or not, but my partner and I just finished the bulletin board bundle in the community center and only I (the host, and the player to put in the last item) got the friendship increase. Now he's the town recluse while I'm super popular, even though he did as much of the work on those bundles as I did. :(
                     
                    • margotbean

                      margotbean Scruffy Nerf-Herder

                      I was finally able to get Elliott's 10-heart event to trigger, but only after getting Alex's 8-heart event to trigger. I got both events consecutively.
                      ...Still playing in v1.3.28 because I still need to be able to bomb rocks without crashing. Still seeing all kinds of monsters with a speed boost upon entering a level in the mines or skull cavern, until they hit an obstacle, after which they slow down to normal speed (all 3 crabs, mummies, shadow shaman, shadow brutes, slimes, anything that walks). Still getting swarmed by serpents and bats without fog. Hello?
                       
                      • MouseyPounds

                        MouseyPounds Phantasmal Quasar

                        Since 1.3.29 is another opt-in beta, you have to follow the instructions posted here.

                        =======================================

                        There seems to be a bug with the processing of "one-time" dialogue entries (those which start with $1) that is still present in 1.3.29 where some of the alternative dialogue never appears. There are two primary cases and there are approximately 15 examples of each in the dialogue files.

                        Case 1: Dialogue which looks like '#$1 flag#text1#$e#text2#$e#text3'

                        Dialogue of this form will display text1 the first time you talk to that NPC while that entry is current, but will ignore text2 and only display text3 every other time. It is most noticeable on Kent's "Thu6" dialogue, but can also be seen with Pierre's "Fri" and "Sun" dialogues and Haley's "Thu" dialogue.

                        Case 2: Dialogue which looks like '#$1 flag#text1#$e#text2'

                        Dialogue for this one will again correctly display text1 the first time you talk to that NPC while the entry is current, but after that the NPC says nothing. They will have the speech bubble icon on hover, but when you click them to initiate the conversation, nothing is said. The player does get "credit" for talking to them and the speech bubble icon goes away. Examples of this include Abigail's "Thu" dialogue, Leah's "Wed" dialogue, and Linus' "Sun" dialogue.
                         
                        • tccoxon

                          tccoxon Procedurally Generated Programmer Chucklefish

                          We've updated the beta branch with v1.3.30 to address some of the issues reported in v1.3.29.
                          • Fixed path and floor tiles rendering as 1x1 tiles instead of joining up
                          • Fixed some rare tool-related crashes in multiplayer
                          • Fixed an audio-related crash often caused when using bombs
                          Note that the default branch is still on v1.3.28 for now.
                           
                            One More Day likes this.
                          • Koihime Nakamura

                            Koihime Nakamura Ketchup Robot

                            Is there any way we can get a list of bugs being considered for future patches/being worked on?
                             
                              sharonsz, margotbean and sirsilica like this.
                            • Pathoschild

                              Pathoschild Cosmos Killer

                              (1.3.30 also fixes the double fade-in bug from 1.3.29-beta.)
                               
                                margotbean likes this.
                              • Koihime Nakamura

                                Koihime Nakamura Ketchup Robot

                                From mod description of an artifact bug:

                                'The chances for finding an artifact are written in two places. Firstly, each artifact describes in which locations it can be found and the chance of it being found there. (I call this the primary table). Secondly, each location (e.g. Farm, BusStop, Town etc.) has a list of artifacts and their chance of being found there. (Secondary table).
                                The method the game uses to choose an artifact to spawn is by running through the primary table, and checking each item's chance. If nothing is found, it will run through the possible items in the secondary table.

                                The biggest bug is in the primary table. For these eleven artifacts: { Prehistoric Scapula, Prehistoric Tibia, Prehistoric Skull, Skeletal Hand, Prehistoric Rib, Prehistoric Vertebra, Skeletal Tail, Nautilus Fossil, Amphibian Fossil, Palm Fossil, Trilobite }, the list of drop chances is written on the wrong line, so the game doesn't read it! This renders the eleven artifacts unobtainable from the primary table. Eight of the items are written in the secondary table, so they can be obtained from artifact dig spots. The remaining three: Skeletal Tail, Nautilus Fossil and Amphibian Fossil are completely unobtainable from artifact dig spots! You can only find them through the mines or fishing chests.'
                                 
                                  sirsilica likes this.
                                • SapphireFrost

                                  SapphireFrost Yeah, You!

                                  I'm having the same issue as Far-To-Much in that after I gave Abagail her gift and received one, I wasn't able to move at all. I reloaded the game without mods and I'm still having the issue.
                                   
                                  • margotbean

                                    margotbean Scruffy Nerf-Herder

                                    Does it bother no one that this has been posted twice, and no one has explained what "the wrong line" is? The data file contains one long string (i.e., line) for each item, not separate lines.

                                    What I believe is being referred to is the fact that Game1::digUpArtifactSpot always reads index 6 of ObjectInformation.xnb, but the 11 artifacts mentioned have the location and % in index 7. In index 6 they all have "Item 1 289", which is not a valid location. But, this is just a guess.
                                    None of the Dwarf Scrolls have any location or % information in ObjectInformation.xnb either.

                                    The orange strip of flooring in my house bothers me way more than the chances of finding a Trilobite, just by the way. Here are some cookies for the devs: :cookie::cookie::cookie:. Please fix my floor.
                                     
                                    • oxygen1234

                                      oxygen1234 Void-Bound Voyager

                                      I have noticed a few issues while playing multiplayer with version 1.3.28

                                      I am playing with one other person, they are hosting and I am the farmhand.
                                      - I as the farmhand am unable to upgrade my house to the highest level (the one with the basement). This was true before the host upgraded theirs to that level and also after they did. I do have the achievement on my character for having the max level house though.
                                      -My horse lost his (my) hat!. Noticed it when I woke up one morning. I think this was on the day after the festival. We both rode our hatted horses to the town square and of course afterwards you get teleported back to the house without your horse. Maybe that has something to do with it?
                                      -When my horse was wearing a bowler hat, the graphic kept flickering between showing the hat and the horses ears when the horse was facing north.
                                       
                                      • Pathoschild

                                        Pathoschild Cosmos Killer

                                        @tccoxon Thanks a lot for the modding changes in 1.3.30!

                                        There's one other change that'd be helpful. The HoeDirt.dayUpdate method doesn't account for the new IsGreenhouse property, though other code does. Can you change it from this:
                                        Code:
                                        if (environment.isOutdoors && Game1.currentSeason == "winter" && this.crop != null && !this.crop.isWildSeedCrop())
                                          this.destroyCrop(tileLocation, false, environment);
                                        
                                        To this (adding the !environment.IsGreenhouse check)?
                                        Code:
                                        if (environment.isOutdoors && !environment.IsGreenhouse && Game1.currentSeason == "winter" && this.crop != null && !this.crop.isWildSeedCrop())
                                          this.destroyCrop(tileLocation, false, environment);
                                        
                                         
                                        • Swrundeep

                                          Swrundeep Space Spelunker

                                          Two glitches today:
                                          1. Unable to donate artifact (chicken statue but not sure if it's limited to that or not). I select Donate and the screen opens up my menu by the tables but then fades black and it centers back on my character
                                          2. Unable to access my backpack or menu with the Esc button. I can at least get to my backpack through chests but otherwise I'm unable to do anything.
                                           

                                          Share This Page