1. This forum is primarily for mobile related issues - for support for PC/Console visit the support section of forums.stardewvalley.net

Stardew Valley Multiplayer Beta: Known Issues & Fixes

Discussion in 'Support' started by Katzeus, Apr 30, 2018.

Thread Status:
Not open for further replies.
  1. Criamos

    Criamos Intergalactic Tourist

    I wanted to chime in on this bug, since it appeared in our savegame around Summer 8th of the 1st year and we were able to "fix" and reproduce it:
    • (Need More Details) Frame rate drop on farm in evening (some have reported removing the recycling machine helps)
    We had 3 furnaces and 1 recycler running out in the open and it was perfectly playable until 6pm - right on time, every day the insane performance slowdown (to 0-1fps) started happening at exactly 6pm. This only occured after we had the recycler out in the open for a few days of ingame time already, same for the furnaces, which made tracking it down really hard to figure out (since we thought it must've been our torches that slow the game down on 6pm).

    But we were able to reproduce the problem: We crafted 2 more recyclers, put them all inside 1 farmhand house and let them run throughout the day. That house gets absolutely unusable after 6pm - if you enter it, you'll have constant 1fps (or worse) until you either manage to leave the house or sleep in the bed and skip to the next day. The weird thing: The person sleeping inside the "bugged" recycler-house actually manages to drag down server-performance even though only his client has the problem (and other players sleeping in their unaffected houses) are fine: If somebody is suffering through that 1fps performance-hell the day-resumé (income, skill-up etc. screens) are taking way longer to appear and the other clients are sitting around with a black screen until the 1fps-person has "loaded" the day-transition.

    I attached our savegame and I hope it helps you to track the bug down. (Btw: thank you for this glorious update, MP is awesome.)

      Attached Files:

    • azurerosez

      azurerosez Space Hobo

      In my file I was crashing every time I tried to talk/but from the merchant wagon by the wizard tower several fridays and the ring for multiplayer didn’t show up as an option to buy. Also every time I jump on my horse there is a very large jump animation. I’ve also been unable to change the wallpaper in my bottom half of my upgraded house, haven’t tried the upper half just Incase that glitches too. Its the basic yellow when a player starts a new game and when I go to try to change it the item disappears like it worked, but the wall stays them same yellow wood panel wallpaper. And in cutscene for the spring festival Pam’s trailer is there instead of the new house, i dunno about other festivals yet.
        Last edited: May 2, 2018
      • Sonikki

        Sonikki Void-Bound Voyager

        My friend is keeping a log of all the weird oddities and bugs we've encountered. My notes will be in parenthesis/italics to help clarify what was going on on my end. Sorry if some of these have been posted before. I've omitted the ones I know have been mentioned through my last scan of the thread.

        I am the host of the game, both of us are on Mac OS X, my friend is on El Capitan still and I am on High Sierra. Steam version for both of us and online, not LAN. We have NOT played the newest build just yet, so I'm sorry if some of it has already been remedied.

        So far we have this:

        •Don’t sleep in the same bed. Sends you back to the menu and the host has to wait till you’re gone for it to work again.
        (I also had to restart the server because the next day's end resulted in a boot to the menu screen for her as well. We were curious to see if it caused an issue and.. it did.
        When it does this, the game freezes and locks up for us both until she is kicked out of the game server and to the menu screen, then my game resumes as normal.)

        •Exp/leveling things is a bit off and doesn’t give things as it should. If I get kicked to the main menu, I lose what I’ve done. “Advancement” quest completed but it’s making me do it again.
        (To clarify more, she logs back in to the server and gets the exp she missed, but any quest progress is reset to the last thing she did, as if she didn't do it, but any items -like say, the scarecrow made -are still there where she placed them and she still has all of her items.)

        •Hearing doors open and close all over the map.
        (Both of us can hear this + the footsteps of the other player even if you are not near them.)
        •Host can hear whatever I do on the farm when they’re not on the farm.
        (Was at the beach fishing while my friend was at the farm and using the scythe to cut grass and I could hear it.)

        I'll post again if there are any more bugs we come across. ^^ So far it's working surprisingly well considering though! Great work and thank you guys so much!
        • SenpaiTiger

          SenpaiTiger Intergalactic Tourist

          Like ThunderstormWoman before me, I too have a problem regarding Friendship and Gifts due to the beta.
          Some of the Villagers I have given gifts dont reset at the start of a new week. The game just say that I have already given them 2 gifts this week, despite it being the 3rd week they refuse to accept new gifts.
          I've tested and it is only the ones I gave gifts while playing multiplayer, because when I gave gifts to other villagers they reset like normal. Additionally, the gifts dont reset during multiplayer, as that was the first thing I tried.
          • sallysc343

            sallysc343 Space Hobo

            Mine is doing the same thing. Was ok until today, first it started when I tried to enter my farm and made my game unresponsive, then I was able to get on the farm but suddenly had massive lag after 6. I have 2 furnaces which had been working fine but the issues started when the recycler had been used. All machines were out in the open. I'm on single player though and the issues started on 27th Spring in the first year. Have staggered my way to the first day of summer
            • Katzeus

              Katzeus Chucklefisherman Chucklefish

              Could I ask if you (and anyone else who'd reported an issue with Festivals starting) if you or another player were running SMAPI? We just fixed an issue in this morning's patch which should resolve a conflict which may have caused something like this. Want to isolate if it's the same bug or a separate problem.

              If anyone who's seen this happen could update tot the latest version and try again that'd be helpful!
              • Criamos

                Criamos Intergalactic Tourist

                To (temporarily) fix it: Pick up the recycler and put it into a house that's not on your main farm screen (I haven't tried it besides farmhand-houses, but maybe you can put it down inside the barn/mushroom cave/chicken coop?). Either way: After picking it up and putting it down again, we got a few days of "problem free" use out of the recycler until the problem started appearing again, so it doesn't happen immediately after putting a recycler down, but a few days in only. Our way to deal with it was to use the 4th farmhand-house (that is only rarely used) as our off-screen dump for the recyclers + recycler-box, so we'll recycle in the morning, throw more stuff in and come back before 6pm - after that, the house is a no-go zone for all of us until the next day ;)
                • Neonir

                  Neonir Big Damn Hero

                  When starting a multiplayer game with multiple cabins using the seperate feature on the wilderness map, the first cabin for some reason does not appear. The second one appears when I tested that, but the first one does not exist on the map.
                  • Opalie

                    Opalie Void-Bound Voyager


                    very small bug, but still: when you change the color of the chest, it shows this instead (a log and a color sign under it).
                    • Pushover476

                      Pushover476 Space Hobo

                      Hey there,

                      here are the buggs that I experienced so far.

                      1. The recycle machine causes massive framedrops. I was able to reproduce this problem all the time.
                      You place the recycle machine (the framedrops appear on any map, no matter where you place it) and once you use it, the frames will break down at exactly 6pm ingame time.
                      Removing the recycle machine again fixes the framedrops.

                      2. I planted 100 wheat seeds on a 10*10 square in the evening (don't remember the exact time, but it was past 6pm). When I watered those seeds with my steel watering can
                      for the very first time, suddenly roundabout half of the seeds disappeared randomly (still unwatered seeds aswell), as if they have never been there.

                      3. Music blocks only play the music for the player who uses them. The other players can't hear it. They only hear it when they use these blocks by themselves.

                      4. Some quests can only be completed by one player, because the necessary quest item only exists 1 time in the world. For example: Finding Robins axe.
                      Either there has to be one axe for each player or the quests have to synchronize between the players, otherwise the incomplete quests always remain for the player who didn't
                      finish it.

                      5. The community center does not synchronize correctly between players. Sometimes it helps when a player enters the community center and looks at the different rolls, so it gets
                      updated for him. But this is not always the case (I can't tell what exactly makes it update or sometimes not). This also means that only the host is able to see the actual still
                      needed items for the community center in his inventory.

                      6. Sometimes tools disappear and then show up duplicated. We had this with the watering can. When one of my friends was missing his watering can, whilst there showed up 2 watering
                      cans in one of our boxes. Which means we were 3 players with 4 watering cans. I can't tell how exactly that happened or what we were doing while the can disappeared and showed up again,
                      because it was simply too confusing and we didn't realize it at first.

                      7. It's not possible to dig over the sandy parts in the mine with the rake. Ingame time does not affect this.

                      I shall edit this post when I notice more issues.

                      Greetings from Germany!


                      8. I got the message that someone found my lost items and put those to the repository and then have been put next to my bed, even though noone of us got unconscious. This message appeared to show up randomly, because there were no items in one of our houses or boxes.
                        Last edited: May 2, 2018
                      • SamuelSmith

                        SamuelSmith Intergalactic Tourist

                        The version of Visual C ++ Redistributable Packages for Visual Studio 2013 x64 was already installed on my pc however only after installing the x86 version that the online multiplayer option appeared
                        • Slendermando

                          Slendermando Intergalactic Tourist

                          I have noticed some little inconsistencies when playing with the GAMEPAD, not really bugs but I thought you wanna know about them :)

                          - Sometimes when you try to plant a bunch of wild seeds, it's not displaying the planting location, you just have to guess it. It has only happened once.
                          - One time I was mining a rock, and the music when you receive a gift played, with the message : "you received a rock". This has only happened one time.
                          - When you walk towards a shop (or a bundle in the C. center) and click on it, the sound of the footsteps continues. This happened everytime I tried it.
                          - After playing a few hours without a problem, it appears that my character sometimes randomly use the highlighted tool when I'm just trying to walk
                          - In town, the sound of the doors feels too close... as if everyone's house was just next to you
                          • JaiS

                            JaiS Space Hobo

                            Hi, just a small detail/bug I had when playing stardew with a friend last night is that my map became misaligned. We haven't been on today as for some reason me and my friend aren't able to join one another online (not sure if that's a bug or that servers are down?)

                              Attached Files:

                            • browncjay

                              browncjay Void-Bound Voyager

                              (Need More Details) Only LAN option available at join screen

                              I can reproduce this by disabling internet access to stardew valley (disable network adapter or put it behind a firewall)

                              But it works fine when i have a full connection
                              • wolf-5

                                wolf-5 Void-Bound Voyager

                                When attempting to turn in items for quest from bulletin board, I had the characters the items they request, and nothing happens. IT give it to them but doesn't count for the quest.
                                • Jurk0wski

                                  Jurk0wski Orbital Explorer

                                  This would be a good time, since it's another 6pm bug, for me to reiterate the bug that animal moods (not friendship) will drain if the mood is above 150 if you stay up past 6pm unless it is winter and you have a heater. If this is not a bug, it'd be nice if they'd acknowledge so, since this problem has existed for a while, and it seems like it'd be a bug considering that at 150 mood, it becomes statistically impossible to achieve iridium quality animal products even at maximum friendship unless you took that animal's specific profession.
                                  • foperator

                                    foperator Big Damn Hero

                                    Bug 1: Two players were able to request a tool upgrade from Clint at the same time, and the first person to request an upgrade lost their tool. Clint basically "forgot" he was upgrading it. The first person's (guest's) tool reappeared next to the bed later. The second person's (host's) tool was upgraded normally.

                                    Bug 2: Museum items on display disappeared after being rearranged. I donated a frozen tear and then went to rearrange some previous donations. The next time I returned, most of the donations were gone. Any items that disappeared could be re-donated to the museum. I was playing as a guest.

                                    Bug 3: All refrigerator items disappeared the day of the Stardew Valley Fair (Fall 16). The multiplayer guest cabin was upgraded to have a kitchen, and on the day of the festival everything in the fridge was gone. Contents of the fridge did not return after the day ended.
                                    • Complete_Luck

                                      Complete_Luck Intergalactic Tourist

                                      Yo, this worked for my mate
                                      • Repeatz

                                        Repeatz Space Hobo

                                        My Game Crashes when trying to host a multiplayer game. I have played with one of my mates closed the game and half an hour later i could start up the server. I pick the save and in the loading screen the game crashes. We are curently at day 2 of summer (year 1). Other save games work.

                                        Edit : problem solved with the new update

                                          Attached Files:

                                          Last edited: May 3, 2018
                                        • Farside

                                          Farside Lucky Number 13

                                          I forgot to add that you can dupe your basic tools. Between my wife and I, we have 6 watering cans.
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page