1. This forum is primarily for mobile related issues - for support for PC/Console visit the support section of forums.stardewvalley.net

Stardew Valley Multiplayer Beta: Known Issues & Fixes

Discussion in 'Support' started by Katzeus, Apr 30, 2018.

Thread Status:
Not open for further replies.
  1. puppaa

    puppaa Space Hobo

    I'm having an issue where I can't play multiplayer at all. I've followed the steps and downloaded the beta update for multiplayer but when I go onto the coop option on the game there's no option for typing in a code to join another farm. When I made a farm to host there was no option to change the server mode from online to invite friends. My privacy settings on steam are set on allowing friends to view games that I'm playing and all my other friends can play together so it doesn't seem to be anything from their side. They've sent me invites to play with them and I've tried to join the game by clicking join game through my friends list too but nothing seems to be working. T^T
      Julybeatles and viobeth22 like this.
    • Quequio99

      Quequio99 Space Hobo

      Hola mi amigo y yo tenemos un problema en el cual no nos aparecen las configuraciones de multiplayer menos crear partida coop y tal

      Hello my friend and I have a problem in which multiplayer configurations do not appear except create coop and such
        Last edited by a moderator: Apr 30, 2018
      • Skullbrain

        Skullbrain Void-Bound Voyager

        My friend seems to have the same problem, it seems to be account related because its working for him on my account. This is pretty strange :/
          Tetrio21, CalciteFox, wells and 2 others like this.
        • cocotopo

          cocotopo Void-Bound Voyager

          Hello, I found two small bugs, the fist one is that Gus just walks into the table in the community center (he also walks into the bookshelves in the bottom right corner but I wasn't able to take a picture) This happened after I had the event with Willy and the crabs
          the second one is not really a bug(?) it is in Linus' dialogue in the event where I tell him that he can live with me in the farm, it's not very important but I mean the "." at the start of the dialogue

          • Vandabe

            Vandabe Space Hobo

            1. Sound everywhere on the farm even if your at the other side of the farm not next to another player.
            2. If one player puts in an item to the museum the other player can only see the information about the item when they are in the museum themselves and if they aren't they will get the usual "Gunther can teach you more about this" text
            3. I went to pierre's shop an sold 2 parsnip and my friend couldn't sell anything afterwards. She could sell after going in and out of the shop after i went out though.
            4. We also experienced as mentioned in another bug post a minor bug where you pickup something exciting which in this case was a geode but it showed up as "I just found something exciting!" You found a stone yay a special stone just what i wished for LOL.
            • Cats PantsS

              Cats PantsS Space Hobo

              Don't know if this has been reported yet, but speaking to Emily while she's inside Pierre's shop on the second day around 10am crashes straight to desktop. This has happened twice now. Also I am just playing with one other person. :kitten2:
              • Pench

                Pench Space Hobo

                After downloading the beta, I opened a previous save file and it started fine until I walked outside to find my "wife" stuck in the terrain. I also couldn't talk to her. After playing out the rest of the day she appeared back in my cabin. The next day I found her in the cabin like normal.

                On another note, after being in town for most of the day (same day as the above problem), I returned back to my home to find that while on my property, I was playing at an extremely low frame rate and input lag.

                (This in on Mac)
                • Pangaea

                  Pangaea Forum Moderator

                  I have the same issue. Loaded a previous save and Emily went from girlfriend to single with 8 hearts.

                  Also, can confirm the bug that crashes the game to desktop when talking to Emily whilst she's exercising occurs in single-player. Just tested with a fresh save in which I did nothing else.

                    Attached Files:

                  • katelic

                    katelic Intergalactic Tourist

                    My wallpapers appear to have reverted back to defaults in every room of the largest main house with the basement, the only exception is the spare empty room above the kitchen and to the left of the nursery, it still has my wallpaper I selected before. No new wallpapers show up on the walls after application.

                    Also, every time you hover near the horse the speech bubble icon is there.

                    No mods.
                    • carlacaroline

                      carlacaroline Space Hobo

                      i was playing with my boyfriend (i was the host) and i bought a backpack for me (i don't know if its backpack in english because im playing in portuguese - the bag pierres sell to upgrade inventory) and it worked fine, but when he bought it he had to restart the game and when he came back it was gone and the money too

                      and i cant change my itens with the keyboard numbers
                        Last edited: Apr 30, 2018
                      • Oldest_Stern

                        Oldest_Stern Void-Bound Voyager

                        I have a bug where after creating a new character for co-op, and loading the farmhouse, I alt tabbed out of the game, and my player starting walking into the wall non-stop. I can use the mouse wheel to switch in my hotbar, but cannot use any keyboard keys. I can also use the tools in my inventory.
                        • CMoon

                          CMoon Void-Bound Voyager

                          I was just playing with my mom over LAN and we got to the day of the Egg Festival.
                          We got the notification that it started so we headed over. We got the dialogue to enter (needs all the players to enter) but the festival wasn't going on. It was like any other day in town.
                          • sallysc343

                            sallysc343 Space Hobo

                            Hi, my game crashed when I tried to speak to Demetrius in the saloon on the friday ( I started a new game for the update so it was the first friday)
                            • JustHere2Download

                              JustHere2Download Void-Bound Voyager

                              Tried it and nothing changed. I've tried reinstalling it, verifying the integrity of the files through the Local Files, and restarting my whole computer. I can't seem to find a fix. Another user said they used a friend's account so it was their computer, but we just tried switching accounts but nothing changed as well. They can see my host files, but aren't able to see the Input Invite Code button.
                                Last edited: Apr 30, 2018
                                viobeth22 and isoca like this.
                              • raspberryjam

                                raspberryjam Aquatic Astronaut

                                The game crashes when both me and the other person I'm playing with (the host) goes to sleep. It loads up the tally for the money made then the screen freezes. Here are the error logs from my side:

                                [16:09:53 INFO SMAPI] SMAPI 2.6-beta.2 with Stardew Valley 1.3.3 on Microsoft Windows 10 Home
                                [16:09:53 DEBUG SMAPI] Mods go here: C:\Program Files (x86)\Steam\steamapps\common\Stardew Valley\Mods
                                [16:09:53 TRACE SMAPI] Log started at 2018-04-30T20:09:53 UTC
                                [16:09:53 ERROR SMAPI] The game crashed last time you played. That can be due to bugs in the game, but if it happens repeatedly you can ask for help here: http://community.playstarbound.com/threads/108375/.
                                [16:09:53 ERROR SMAPI] If you ask for help, make sure to attach this file: C:\Users\cafev\AppData\Roaming\StardewValley\ErrorLogs\SMAPI-crash.txt
                                [16:09:53 INFO SMAPI] Press any key to delete the crash data and continue playing.
                                [16:10:02 TRACE SMAPI] Starting game...
                                [16:10:06 TRACE SMAPI] Detecting common issues...
                                [16:10:06 TRACE SMAPI] Loading mod metadata...
                                [16:10:06 TRACE SMAPI] Loading mods...
                                [16:10:06 INFO SMAPI] Loaded 0 mods.
                                [16:10:06 INFO SMAPI] Type 'help' for help, or 'help <cmd>' for a command's usage
                                [16:10:06 TRACE SMAPI] Context: locale set to en.
                                [16:10:06 TRACE SMAPI] Checking for updates...
                                [16:10:06 TRACE game] Signing into GalaxySDK
                                [16:10:06 TRACE SMAPI] SMAPI okay.
                                [16:10:58 TRACE game] Starting client. Protocol version: 1.3-24
                                [16:11:04 TRACE game] Lobby entered: 123232095682357962
                                [16:11:18 TRACE SMAPI] Content manager '(temporary)' disposed, disposing assets that aren't needed by any other asset loader.
                                [16:11:18 TRACE SMAPI] Invalidated 0 cache entries.
                                [16:11:18 TRACE game] gameMode was 'titleScreenGameMode (0)', set to 'loadingMode (6)'.
                                [16:11:19 TRACE game] gameMode was 'loadingMode (6)', set to 'playingGameMode (3)'.
                                [16:11:19 TRACE SMAPI] Content manager '(temporary)' disposed, disposing assets that aren't needed by any other asset loader.
                                [16:11:19 TRACE SMAPI] Invalidated 1 asset names: Minigames\Clouds. Reloaded 1 core assets.
                                [16:11:24 TRACE SMAPI] Context: loaded saved game 'R_184795793', starting spring 1 Y1.
                                [16:16:41 TRACE SMAPI] Content manager '(temporary)' disposed, disposing assets that aren't needed by any other asset loader.
                                [16:16:41 TRACE SMAPI] Invalidated 0 cache entries.
                                [16:18:32 TRACE SMAPI] Content manager '(temporary)' disposed, disposing assets that aren't needed by any other asset loader.
                                [16:18:32 TRACE SMAPI] Invalidated 0 cache entries.
                                [16:19:46 TRACE SMAPI] Content manager '(temporary)' disposed, disposing assets that aren't needed by any other asset loader.
                                [16:19:46 TRACE SMAPI] Invalidated 0 cache entries.
                                [16:22:14 TRACE SMAPI] Context: before save.
                                [16:22:43 TRACE game] Disconnecting from server 123232095682357962
                                [16:22:43 TRACE SMAPI] Disposing...
                                [16:22:43 TRACE SMAPI] Disposing SMAPI's main content manager. It will no longer be usable after this point.
                                • PatataSenpai

                                  PatataSenpai Intergalactic Tourist

                                  Hey! First of all sorry, btu my English is not ver good hehe

                                  After 3 hours playing multiplayer, I've encountered some bugs. I don't know if they exist in singleplayer too tho.

                                  - I hosted a server, a friend came in and I adjusted the volume levels. Then my friend hosted it and the volume leves were reseted.
                                  - When a character is "exhausted" others players can't see him in that state. They just see him walking slow.
                                  - The water bowl is empty for some players and full for others. I guess that is client-sided.
                                  - On fullscreen, playing on 1920x1080 resolution, the items bar looks like this [​IMG]

                                  - You can hear the NPCs opening and closing the doors while in the town.
                                  - You can hear other players walking and doing all the actions if they are in the same area of the map as you.

                                  These two last bugs are reeeeeally annoying. I've just played with one friend, but imagine hearing 3 more people cutting grass or chopping trees down at the same time xD

                                  That's all for now!
                                    Last edited: Apr 30, 2018
                                  • unknownSaschka

                                    unknownSaschka Space Hobo

                                    Hello everyone,
                                    I got a really annoying bug during multiplayer with my friends.
                                    I've played with two other friends but only I had big desync problems. After a couple of minutes, ingame time of my friends was around 8pm while I was at 10am. They created a field, felled some trees but all these things weren't shown in my view.
                                    Then, when I moved to the city (13:00 pm my time), I got stuck for around 5 minutes in the Loading Screen (at my friends ingame time was already 1 am) and it was finally done loading (it was 1 am in my game). I had some really long loading screens and huge time desyncs during this gaming session and playing was for me and my freinds nearly impossible.
                                    The problem could be my slow internet (2kbit down, 500 kbit up) but my internet load was sometimes at 100% and other times nearly nothing. I hope, the netcode will be better so I and some other people with not so good internet connections could play better.
                                    • viridiannet

                                      viridiannet Intergalactic Tourist

                                      Bug: The 'X' keyboard key no longer advances through dialogue or other text (like checking a sign). It is still set up to be the action key in the Control settings, and can be correctly used to initiate dialogue or check things, it just won't cycle or close dialogues anymore. Left/Right mouse click still work correctly.

                                      Other details: Using Mac OS X, and not in Co-op mode (but yes, in beta).
                                      • tevite

                                        tevite Space Hobo

                                        If you are fishing while your friend enters a cutscene, you will see the cutscene but can fish at the same time.
                                        If you manage to catch the fish in the cutscene, you will have the catched fish window open while having your fishing rod selected on your hotbar.
                                        If you use the fishing rod, the window will close and you wont get the fish you caught.
                                        • Grunkle Dan

                                          Grunkle Dan Orbital Explorer

                                          Just played for a few hours with a friend and we had three bugs.

                                          First is minor, he came across some invisible grass that he could break and pick up.

                                          The second two happened on night 14 of the first season:

                                          He collapsed when coming back from fishing on the night, I was already in bed waiting. The screen went black as if it was about to load the days income but never loaded.

                                          After replaying the day he came back a bit earlier but I was in bed waiting again. I had tabbed out to read the Stardew Valley subreddit and when he returned went to tab back in but couldn't. The game completely failed to recognise all inputs. I tried everything from repeatedly tabbing in and out, plugged in a controller, closed other programs but nothing worked so we ended up closing again. We decided to retry day 14 tomorrow night so hopefully we can get passed it.

                                          Overall incredibly impressed with this though, a lot of fun. Thanks very much :)
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page