Stardew Valley Multiplayer Beta: Known Issues & Fixes

Discussion in 'Support' started by Katzeus, Apr 30, 2018.

Thread Status:
Not open for further replies.
  1. TheusOliveira

    TheusOliveira Aquatic Astronaut

    I'm having a problem in the conection, when me and my friend try to enter in co-op we get a Failled Conection, no matter if its me enter on his server, or the opposite, we have tried to create a new farm or use an old one. :/
     
      Aquariae likes this.
    • Pent

      Pent Void-Bound Voyager

      For the 1.3 multiplayer beta: We went into Pierre's house on Tuesday, and talking to Emily crashed the game (for both of us when speaking to her).
       

        Attached Files:

      • TheusOliveira

        TheusOliveira Aquatic Astronaut

        maybe you had enter on day 2, and the host had sleeped the first day, so you are having the first weather report, and he de second one
         
        • A Vicious Vegan

          A Vicious Vegan Space Hobo

          I was playing on a game hosted by my friend and my character when to sleep. He started playing the Western arcade game and kept doing so until the time hit 2am when his character passed out. On my screen the game proceeded as usual, I leveled up in the mining skill, but then I got stuck at the "saving" screen. My friend was stuck at a paused state in the arcade game.
           
          • maximise20

            maximise20 Seal Broken

            when you are in the shop buying stuff and it gets late (shop is closing), he walks away from the counter. You can still buy/sell stuff though
             
            • Nawl

              Nawl Space Hobo

              So i was playing with a friend and he went afk , the night arrived and i went to sleep but after the 2AM passed my screen went black, and when my friend back he had a message that he passed out but his screen was also black
               
              • Alcopops

                Alcopops Void-Bound Voyager

                Hello! My friend and I have been playing 2 player co-op and we found a weird bug.

                If he goes into a building and opens a door and then I (the host) enter, the doors go completely seethrough for me and unuseable. The only way we've found to fix this is if he leaves the building and I re-enter. If he stays in the building and I re-enter, the doors are still bugged.

                We have re-created this bug twice. The buildings we've tried this in are: Pierre's shop, The Tavern and Harvey's Clinic. The Clinic doesn't seem affected but the other two do, we haven't tried in houses yet.

                It doesn't seem to happen if I do the same thing and he enters, it looks like a host only bug.
                 
                • woutwoot

                  woutwoot Space Hobo

                  Not a very important "issue", but a visual teleport glitch when one of the players enters the wizard's tower:
                  [​IMG]
                   
                    hwcxx likes this.
                  • JackNorisk

                    JackNorisk Intergalactic Tourist

                    Watering can keep poping in my house every day.

                    Every morning in a small house (not the principal one) a watering can pops out from the bed I slept, and go in my inventory. At the moment I have five, for the fifth day. I precise that the other player gave me his own watering can, like this it's easier to wark on the farm while he is fishing. Don't know, if it comes from this. But still, this is strange and I can't destroy those watering can and two is quite enough I think :rofl:
                    The house from wich the watering can pop's out is the one next the greeenhouse. And it wasn't supposed to be my house (since I'm the host) and it's a four player map.
                     
                    • Aihe

                      Aihe Intergalactic Tourist

                      And I can't even host a server myself, when I finish to create my character and set up the number of cabins(...) the game instantly crash with this error log :
                       

                        Attached Files:

                      • hoshikuma_chan

                        hoshikuma_chan Void-Bound Voyager

                        I'm also having a similar issue some of the other players described! I took off all my mods, so all my files are now vanilla. I have 3 save files; two (2) are in year one (1), and the one I'm having issues with is the file in year two (two). I cannot get out of bed, it just automatically crashes without me touching anything.

                        Mods were taken off using the in-built Steam 'verify files'.
                         

                          Attached Files:

                        • Nox Regalia

                          Nox Regalia Space Hobo

                          When i join my friend's server, it crashes everytime it gets to the loading screen.
                          Capture.JPG Capture2.JPG Capture3.JPG
                           
                          • aumolac

                            aumolac Void-Bound Voyager

                            So, two little bugs I found with my play partner in co op:
                            1.) Sound: While on same map part (e.g. city, farm), but on far sides, sound of co-op player is like, super loud.
                            2.) I had full inventory, and I wanted to start exploring the mines. Moments before, my partner got his rusty sword. I was asked to remove one item from my inventory, which I did, but I didn't receive rusty sword. At least it wasn't in my inventory.

                            That's it for now.
                             
                            • dustandroses

                              dustandroses Space Hobo

                              Similar (if not the same) bug as post #8:

                              Attempting to check Grandpa's Shrine crashes the game.

                              I can right-click and read the note ('wait for me on the dawn of your third day...' etc), but when I right click to try and pick up the statue (I haven't claimed it yet), the game crashes.

                              Have attached logs and my save. Hope they help!
                               

                                Attached Files:

                              • minervamaga

                                minervamaga Scruffy Nerf-Herder

                                I am having a similar issue. Playing single player, using SMAPI. Every time I place something in the shipping bin, the game locks up on the end of day summary. Mouse will not register in game, no keyboard inputs register, etc. Playing using a brand new save as well.

                                Site says my save file is too large for the server to process, but SMAPI log is below.

                                EDIT: Was able to do it with it zipped
                                 

                                  Attached Files:

                                • DunCakes

                                  DunCakes Space Hobo

                                  I'm plating with 2 of my friends and my game crashes when I try giving a gift or turning in a quest, it's happened 4 times at this point
                                   

                                    Attached Files:

                                  • ousndx

                                    ousndx Space Hobo

                                    i can' join my friend's game and they can't join me, in my coop menu the button are stacking, i can t "enter invite code"
                                     
                                    • Katzeus

                                      Katzeus Community Manager Chucklefish

                                      Could you all try the following and report how it goes?

                                      Try completely quitting the game and exiting Steam. Then re-sign in with Steam, making sure you're online and not playing offline. Then launch the game through Steam, and wait at the title screen for a full minute. Then enter the co-op menu?

                                      The devs suspect the game isn't finished connecting to Steam in the background when you're opening the menu.
                                       
                                        ExoAluz, CalciteFox and ousndx like this.
                                      • Katzeus

                                        Katzeus Community Manager Chucklefish

                                        Could you send over the host crash log for this one? Thanks!!
                                         
                                          digitaleevee likes this.
                                        • Cirom

                                          Cirom Cosmic Narwhal

                                          I talked to Demitrius in the bar in the first Friday of the first year. Was the host, playing with one friend at the time.

                                          Code:
                                          Message: Unable to parse string path: %Demetrius is busy.
                                          InnerException:
                                          Stack Trace:    at StardewValley.LocalizedContentManager.parseStringPath(String path, String& assetName, String& key) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\LocalizedContentManager.cs:line 289
                                             at StardewValley.LocalizedContentManager.LoadString(String path) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\LocalizedContentManager.cs:line 206
                                             at StardewValley.NPC.setTemporaryMessages(Farmer who) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\NPC.cs:line 2500
                                             at StardewValley.NPC.checkAction(Farmer who, GameLocation l) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\NPC.cs:line 1307
                                             at StardewValley.GameLocation.<>c__DisplayClass195_0.<checkAction>b__0() in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\Locations\GameLocation.cs:line 3923
                                             at StardewValley.ModHooks.OnGameLocation_CheckAction(GameLocation location, Location tileLocation, Rectangle viewport, Farmer who, Func`1 action) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\ModHooks.cs:line 13
                                             at StardewValley.GameLocation.checkAction(Location tileLocation, Rectangle viewport, Farmer who) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\Locations\GameLocation.cs:line 3899
                                             at StardewValley.Game1.tryToCheckAt(Vector2 grabTile, Farmer who) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\Game1.cs:line 7755
                                             at StardewValley.Game1.pressActionButton(KeyboardState currentKBState, MouseState currentMouseState, GamePadState currentPadState) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\Game1.cs:line 7644
                                             at StardewValley.Game1.<>c__DisplayClass643_0.<UpdateControlInput>b__0() in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\Game1.cs:line 9774
                                             at StardewValley.ModHooks.OnGame1_UpdateControlInput(KeyboardState& keyboardState, MouseState& mouseState, GamePadState& gamePadState, Action action) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\ModHooks.cs:line 11
                                             at StardewValley.Game1.UpdateControlInput(GameTime time) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\Game1.cs:line 9362
                                             at StardewValley.Game1.Update(GameTime gameTime) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\Game1.cs:line 2297
                                             at Microsoft.Xna.Framework.Game.Tick()
                                             at Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
                                             at Microsoft.Xna.Framework.GameHost.OnIdle()
                                             at Microsoft.Xna.Framework.WindowsGameHost.RunOneFrame()
                                             at Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(Object sender, EventArgs e)
                                             at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
                                             at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
                                             at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
                                             at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
                                             at System.Windows.Forms.Application.Run(Form mainForm)
                                             at Microsoft.Xna.Framework.WindowsGameHost.Run()
                                             at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
                                             at StardewValley.Program.Main(String[] args) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\3\chucklefish\stardewvalley\Farmer\Farmer\Program.cs:line 122
                                           
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page