1. This forum is primarily for mobile related issues - for support for PC/Console visit the support section of forums.stardewvalley.net

Stardew Valley Multiplayer Beta: Known Issues & Fixes

Discussion in 'Support' started by Katzeus, Apr 30, 2018.

Thread Status:
Not open for further replies.
  1. Alana

    Alana Space Spelunker

    My partner and I also had this same issue. Only on nights that we placed items to sell in the shipping box did we experience the bug.
     

      Attached Files:

    • TheCyber416

      TheCyber416 Yeah, You!

      1 (Severe) At 6+ PM in the farm area on a river farm frames go to about 0.25 FPS for all players. If you leave area or enter house frames return to normal. Only happened after several hours of play.
      2 (Very Minor): When entering an area with a player who is fishing until the player pulls fish out they are placed far away from their actual location and it resolves itself.
      3 (Minor): When host didn't make it to bed and passed out I the client got hit with the fatigue penalty. Only happened once.
       
      • deej3335

        deej3335 Space Spelunker

        I'm having a few issues, all repeated/reproducible on joining player side.

        1) after each day, when you get to the earnings screen, the mouse freezes and I have to Alt + F4 out of the game, reopen it, and rejoin to progress.

        2) after each day, I get a "level up" for every skill, sometimes multiple levels for the same skill, but I don't get the crafting recipes associated with it. I'm not sure if I'm not getting the other benefits.

        3) some cutscenes, the joining player gets teleported to the end location of the hosting player's cutscene. Example: the first community center cutscene.

        4) during the egg hunt, the joining player couldn't see anything (empty town square) but the hosting player couldn't do the egg hunt without the joining player (got stuck on Waiting For Other Players, basically).

        5) the community center button in the inventory screen says nothing has been put in any bindle, but actually at least one has been completed and several others started. This only happens for the joining player.

        Love multiplayer so much so far, and most of it works very well, but these bugs are affecting gameplay and I hope you can fix them soon!
         
        • xRaenboe

          xRaenboe Void-Bound Voyager

          On the fishing map, as the player in the house automatically placed south of the main house, peoples cut trees/weeds are spawning directly outside my house for no reason.
           
          • HunterLee2600

            HunterLee2600 Intergalactic Tourist

            Same here, it always seems to happen around 6PM on River map. Don't have this issue on Regular or Mountain.
             

              Attached Files:

            • Ean_Seki

              Ean_Seki Space Hobo

              I also experience the same bug as sardinesyee. When I press the right trigger on my Xbox one controller, it commonly uses the item in the slot. For some reason, the right trigger is also acting like the action button as well as the inventory selector. I booted up, went straight to multi-player, installed two extra cabins on brand new farm. Everything else seemed to be working fine, but this little bug, bugs me so much, that I have to put it down for right now. This bug does not occur when using the left trigger, but I'm not going to keep cycling through my inventory to the left only.

              [EDIT] I've uninstalled the beta to make sure, and I can confirm, the right trigger acting as the action button is only in the beta version right now. The controller still works fine in the final version. I also noticed a bit of a bug after I uninstalled the beta, the new save file for my "Travis" character with 500 cash and 0 time,.... has had his pants removed along with his legs, and for some reason, hair number 2 isn't showing up so instead it looks like the character sprite has had their hair ripped out. 20180501025524_1.jpg
               
                Last edited: May 1, 2018
              • deej3335

                deej3335 Space Spelunker

                I'm also having this issue. I've just been Alt + F4'ing every day and restarting to progress, but it's annoying.
                 
                • paperbirdies

                  paperbirdies Space Spelunker

                  Major visual bug, starts when i try to join or host a multi-player game. Start up is normal. Happens in windowed, fullscreen, and windowed borderless. I try to access the menus in game to exit out and bug persists. Managed to exit out to title and it shows a black screen. Screen-shot is of me in game.

                  Menus and such still work, it's just a visual bug. It also happens while creating a character.
                  Edit: Issue resolved when I hosted a game and hunted around in the graphics settings to change it from windowed to fullscreen. game is fully functional and normal now. likely a render problem with the hardware I'm using.

                  Capture.PNG
                   
                    Last edited: May 1, 2018
                  • ellerae

                    ellerae Master Chief

                    I had three bouquets handed out and hearts up to nine or ten for all of them, when I loaded into the beta they then all listed as single with eight hearts. Giving them bouquets again brought the hearts up to the right level.
                     
                    • KirieZ

                      KirieZ Void-Bound Voyager

                      I was playing with 2 other friends tonight and we had a couple of issues, I don't know if they were already posted (26 pages x.x).

                      Players:
                      * Ryo - Host
                      * KyrieZ - Joined player
                      * JuanFox - joined player

                      Bugs:
                      1. Crash (joined player) when attacking a Grub/Cave Flying (CrashLog - Bug1)

                      2. Crash (joined player) when going down on a mine ladder (level 41 if I recall correctly) (CrashLog - Bug2)

                      3. Host player crashed when players went to sleep.

                      4. (I think this one was reported already, but maybe there's more info here) Extreme lag while entering the farm in the afternoon. (World - Bug4)
                      - Standard Farm
                      - After 4pm
                      - Days 19 and 20 of Spring, Year 1
                      - After we went sleep (after a lot of struggle/reconnections) the farm was back normal, and at 4pm lag appears again
                      - Might be coincidence, but on day 19 we've added 5 furnaces and 2 Recycling Machines to our farm. We tried removing them on day 21 and the lag was gone. We'll try to add one of them later and see if it could be related to these furnitures.

                      5. Not sure if it's intended, but you can dupe your tools if you lend them to your friend: (e.g Watering can)
                      - Player A puts Watering Can on Chest
                      - Player B takes Player A's Watering Can from the chest
                      - Players go sleep
                      - Player A receives a new Watering Can in the morning
                       

                        Attached Files:

                      • sage5

                        sage5 Void-Bound Voyager

                        Bugs I've encountered (I was NOT host on any):

                        * Crash when talking to Demetrius while he's in the bar friday night (maybe was dancing?). (See Log File)
                        * Crash when inside mines randomly, can't remember what I was doing also no log file was created unless it's in the same log file from above.
                        * When progressing in the mines with the host at the same time only one reward was giving at level 10 chest for the host none for the client (Intentional?).
                        * After crash host and did not restart day, I did not get back in till next day, all the people I talked too did not save for the acquaintance quest but in my social panel it said I had met them but it still had people to meet in the quest. So I had no idea who I needed to talk too to complete the quest. Also the wizard did not contact me the next day to visit him (like he was suppose to), I had to go back after the crash and click the bundle again to start process over. Seems like it doesn't save quest progression for the client if they crash.
                        * After crashing robin quest to find her axe disappeared from my log (never came back).
                        * After crashing I lost my level 1 farm upgrade when host did not restart day and I did not get back in before next day started.
                        * I had just earned level 1 farm upgrade and had made a scarecrow then was kicked by the host upon return from being kicked and restarting the day I no longer had the scarecrow recipe but still have the level 1 farming upgrade.
                        * When trying to view bundle from the control panel it does not show any items added to it unless i'm inside the community center, does not work from outside of it (Again I'm Client, Works Correctly For Host).
                        * When finding an artifact it acts like it hasn't been submitted to gunther yet when it already has unless I'm inside the museum then it shows it's been submitted (Again I'm Client, Works Correctly For Host).
                        * Random duplicate NPC's sometimes, only one I recall is two willie's floating on the river right by leah's house.
                        * Once saw the host fishing from in front robins house even though they were at the lake. (See Screenshot)
                         

                          Attached Files:

                        • lesbianpinkie

                          lesbianpinkie Void-Bound Voyager

                          Hi, my friends game consistently crashes a few minutes after booting it. This has only started happening since using the 1.3 beta. No crash log is generated - %appdata%/StardewValley contains only her saves and no ErrorLogs directory
                           
                          • PrincessMelonade

                            PrincessMelonade Void-Bound Voyager

                            Just a little thing I found, I dunno why. Just so you know we both have seen the cut scene that sprites from.
                             

                              Attached Files:

                              • 1.png
                                1.png
                                File size:
                                209.4 KB
                                Views:
                                13
                            • TheAutumnAffect

                              TheAutumnAffect Void-Bound Voyager

                              My game has crashed more times than I can count now but here's the bugs and crashes I think I've been trying to track what causes them.
                              1. My game crashed in the mines when we both tried to descend down a ladder at the same time.
                              2. My house was moved by the host and this started causing crashes like no tomorrow; I can't even rejoin now as it loads into a crash. Playing on the forest farm if that helps.
                              3. I lost my watering can and I wasn't able to check my set of drawers to find it again (This happened after my cabin was moved); I was however able to steal another watering can from another spare cabin.
                              4. Mobs in the caves were double spawning, and invisible on my screen while still active on my coop partners screen, this also worked with bombs and drops from mobs and barrels/chests in the mine, where they spawned separately for us both, and dropped different things upon destruction.
                              Edits from here on out.
                               
                              • Pathoschild

                                Pathoschild Tiy's Beard

                                Updating to SMAPI 2.6 beta 3 should fix that.
                                 
                                  pyrochicken likes this.
                                • jjm5658

                                  jjm5658 Yeah, You!

                                  I think it has some map error, because when I got this pic my character was in his house.
                                   

                                    Attached Files:

                                  • littlebutts

                                    littlebutts Space Hobo

                                    Just played this in co-op mode for the first time and loving it so far.

                                    I did run across a couple issues.

                                    1) minor - as a couple people have already noted, the person playing the farmhand can consistently hear doors opening/closing regardless of position on the map
                                    2) major - farmhand can go to bed while the main player is still active and wake up again with a full energy bar

                                    A big thank you to everyone involved with Stardew Valley. I'm glad such a great game is consistently getting better.
                                     
                                      raihowl likes this.
                                    • DerogatoryTerm

                                      DerogatoryTerm Void-Bound Voyager

                                      I cannot seem to load my saves. I was planning on starting a new farm with my friends, and I made a new save file for Multiplayer, created with the "Host New Farm..." option, but it doesn't appear in the Host section of Co-op when I try to load it. I can only load the world up in Single Player now.
                                      20180501003015_1.jpg 20180501003026_1.jpg
                                      I'm probably just missing something obvious, but I'd like assistance.
                                       
                                        CalciteFox, LeeroyBr and wells like this.
                                      • raihowl

                                        raihowl Space Hobo

                                        Hi!

                                        I don't want to report a crash or a freeze. I happened to stumble upon just an annoying bug. I was fishing near the river when you go straight down from your farm past Marnie's home. My friend went mining. He reached the floor where the flies start to spawn and then for me, on the other side of the actual map, the fly sound started. Even though he killed the fly, the sound stayed for me for the whole day and I just turned the volume down. I think it stopped after I went to bed.

                                        The bug happened once but thought I'd report it, because the span of it was through the whole gameday :D

                                        Edit: Fixed a grammar issue :D
                                         
                                          Last edited: May 1, 2018
                                        • pyrochicken

                                          pyrochicken Master Chief

                                          I also had this mouse-freezing issue on the shipment screen when sleeping - updating to beta 3 fixed it! Thanks so much.

                                          Minor issue: also encountering the wallpaper glitch - everything reverted back to default walls (but floors stayed to whatever custom ones I had), trying to fix from the catalogue did not work as it just stayed the default wall. [Edit] This happened to the walls on the "ground floor" of my fully upgraded house. The second room retained the custom wallpaper. The kids room also reverted back to the default walls.

                                          Bigger issue: auto-feeding in the barn and coop aren't working despite there still being plenty of hay in the silos.

                                          [Edit] oh, just noticed I've also got the glitch where you can hear door slams in town no matter how far away you are.

                                          Also this is all in single player, not multi.
                                           
                                            Last edited: May 1, 2018
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page