Stardew Valley Multiplayer Beta: Known Issues & Fixes 2

Discussion in 'Support' started by Katzeus, Jun 4, 2018.

Thread Status:
Not open for further replies.
  1. thaurane

    thaurane Space Hobo

    My mom and I are playing together and we started a new file. When it came time to unlock the community center. I went into the main part of town through the bus stop. She was forced into the cutscene at the same time I was. She gets the "rat problem" quest as well but however when she tries to interact with the tablet on the ground nothing happens. But it lets me (the host) interact with it. I noticed there was an update at 5:40am through steam this morning. Before the update the community center rat problem quest worked fine but now it doesn't.
     
    • MrBootybreath

      MrBootybreath Void-Bound Voyager

      I used to give Harvey gifts every week, but after my friend joined my farm it got stuck like this. It's been about two years in-game since my friend joined, and his gifts wont reset.
       

        Attached Files:

      • dRageSSBM

        dRageSSBM Space Hobo

        Ran into the same issue today. Started a new save with my sister and only the host can progress the "Rat Problem" quest. The second player can't interact with the golden plate in the community center at all and due to this never recieves the letter from the wizard. We tried starting another save (switching who hosts) but the problem occured again. All players were able to interact with the plate and progress the "Rat Problem" quest on the saves I've played before this latest update.
         
        • Dino0810

          Dino0810 Space Hobo

          Hi, I am a mac user, my steam goes auto-updates for the game and I can not access beta mode anymore, how can I fix this or the mac user just can't play multiplayer mode anymore?
           
          • Koihime Nakamura

            Koihime Nakamura Ketchup Robot

            Version: 1.3.16

            So I went to buy a new animal from Marmie after having started the upgrade from Big Barn to Deluxe Barn. The upgrade was due to start the next day. And.. the barn wasn't listed. Poking at the code, I noticed this:

            Code:
                            if (building.buildingType.Value.Equals(name) && (int)((NetFieldBase<int, NetInt>)building.daysOfConstructionLeft) <= 0 && (int)((NetFieldBase<int, NetInt>)building.daysUntilUpgrade) <= 0)
                                return true;
            
            As before. that should be .daysOfConstructionLeft.Value and daysUntilUpgrade.Value to eliminate potential null issues.
             
              Gelex likes this.
            • piccalo

              piccalo Space Hobo

              Yes, same problem here, exactly as described by dRage and Thaurane. Hoping for a fix!
               
              • pueodragon

                pueodragon Yeah, You!

                I have the same issue. It doesn't show up as an option under stardew valley / properties / beta on steam.
                 
                • rusbus

                  rusbus Intergalactic Tourist

                  Major Bug
                  - Host and Farmhands got the quest to "investigate the Community centre" after first starting, however one of the farmhands decided to go do it then and of course they forgot. We choose to do Joja mart and the Community Center is now the warehouse. The one farmhand who choose not to do to that quest still has the quest stuck in his quest log and the mage tower is permanently locked for him because he can't investigate the warehouse to unlock the "talk to the wizard" step.
                   
                  • Dino0810

                    Dino0810 Space Hobo

                    YES, it appears we have exactly same problem, I checked the changelog it's nothing there, I asked steam community someone says it might be because mac get later update than normal player.
                     
                      pueodragon likes this.
                    • Goldenglade

                      Goldenglade Intergalactic Tourist

                      I'm kind of an idiot.... but if you cast your fishing rod into the right side of the hospital that harvey lives in..... your get stuck :p
                       
                      • Blorp

                        Blorp Big Damn Hero

                        Can you do this again? Or was it just a one-time glitch? If you can repeat this problem, can you describe exactly how, or give a screenshot showing it?
                         
                        • foperator

                          foperator Big Damn Hero

                          In 1.3.16:

                          Grandpa's shrine reward has some issues. We tried several different scenarios with both players at 4 candles. First, host player inserted a diamond in the shrine, then we slept.

                          1) We proceeded to the next day as normal, no server restarts. Both players received both cutscenes and the statue.
                          2) Server DC'd/restarted on the day of the evaluation. Guest did not get the spirit cutscene. Host player got statue first, guest player went second and did not get the statue.
                          3) Server DC'd/restarted on the day of the evaluation. Guest did not get the spirit cutscene. Guest player got statue first, host player went second and did not get the statue.
                          4) Server DC'd/restarted on the day of the evaluation. Guest did not get the spirit cutscene. Host and guest players agreed to use the shrine at the same time. Both players received the statue.

                          Guest player was never able to insert a diamond, and regardless of whether or not the host received the statue, he was unable to insert another diamond since he already got 4 candles.

                          Additionally, it may be intentional, but grandpa called me "boy" while playing a female character as a guest. The host player is male.

                          (Also, to add to NovinChaos's post: The Initiation quest/Adventurer's Guild issue for guest players is pretty major. There needs to be a way to re-trigger that quest for people who lost it or never got it. I'm in Fall Y3 and still locked out. For me though, the Community Center completion cutscene worked probably because the host and I entered it at the same time, but the host's character showed up in the cutscene instead of mine. We guest players can't win either way. :p)
                           
                            Last edited: Jun 6, 2018
                          • zahthris

                            zahthris Space Hobo

                            I experienced a repeat crash today. Wed 24th Summer Year 1, storming weather. Went to the beach, fished, bought a pig, then went to the secret woods around 6pm. Upon entering the secret woods the game crashed. I loaded, and did roughly the same things, went to the secret woods and upon loading, the game crashed again. I've attached the logs.

                            Error is on the current up to date Windows 10

                            Playing in full screen mode.

                            Verson of the game: 1.3.6729.31064

                            Unrelated: Love the beta changes so far!

                            Edit: It occurred again under similar circumstances. In that I spend the day fishing, and in the evening headed to the secret forest. Upon loading to the zone, it crashed. The difference this time is it was on Fall 3rd, with no rain.
                             

                              Attached Files:

                              Last edited: Jun 6, 2018
                            • Koihime Nakamura

                              Koihime Nakamura Ketchup Robot

                              Tested the fix, and that actually breaks more. I think this might be a side effect where a barn being under construction just blocks the availability of animals. (but adding . Value removes a fully grown Coop from consideration.). Would appreciate confirmation if this was intended.
                               
                              • Mondai

                                Mondai Title Not Found

                                Can you please attach the host's save file?
                                 
                                • skp227

                                  skp227 Intergalactic Tourist

                                  Though the ladder/shafts are now synced in the skull cavern, the number of floors you go down via the shaft is not in sync. Host will go down 7 but second player will only go down 3 ect.
                                   
                                  • Iglooman

                                    Iglooman Yeah, You!

                                    Just joined a friend tonight on their farm. They played a while before I could join and ended up on Summer 14 of the first year when I got in game. When I joined I got the standard started quests, including harvest a parsnip... Which I couldn't plant because of the season. Maybe this needs to be changed to be a three season crop of 4 day growth? Or allow the quest to be completed by harvesting any crop? I have to leave before my wheat finished growing, so I don't know if that's already the case, but quest text doesn't make it look like it. Without doing that first step, there seems to be a lot that you can't do for progression farm-wise until the following spring.
                                     
                                    • Aeri_

                                      Aeri_ Master Chief

                                      So my friend converted his single player save to multiplayer.

                                      Consequently he already interacted with the wizard ant community center and I am unable to access the bundles.

                                      Still an issue where client players can't use the remote-bundle checker
                                       
                                      • Mara100617

                                        Mara100617 Space Hobo

                                        Hi! I've downloaded the latest update but I still can't build Pam a new house. I've fully upgraded my farm until I got the cellar but I don't have the option at Robin's to build Pam a new house and I don't know what else to do! I wonder If I should complete the community center bundles first...Thank you in advance.
                                         
                                        • Dreoh

                                          Dreoh Void-Bound Voyager

                                          My Friend created a fresh farm with 2 cabins for his girlfriend and me.

                                          I'm a farmhand, I did the Rat Problem quest first, then did the cutscene getting high with the Wizard.
                                          Then my Friend, the Host, did both just fine.

                                          His girlfriend then attempted to do the "Rat Problem" quest and can see the Junimo who disappears when she gets close, but she can't interact at all with the tablet, meaning she can't finish the quest and can't get to the Wizard, and subsequently can't do any community center quests
                                           
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page