Stardew Valley Multiplayer Beta: Known Issues & Fixes 2

Discussion in 'Support' started by Katzeus, Jun 4, 2018.

Thread Status:
Not open for further replies.
  1. andie301

    andie301 Master Chief

    So I have a bug that I am not sure if it has been reported, but the Farmhand when they upgrade their cabin to get the kitchen their dresser is put into the kitchen instead of in the bedroom, Also I don't know if this is a bug but Farmhands can't purchase the third upgrade for their cabins giving them a cellar.
     
      Dayshi90 and faithstark11 like this.
    • RandomKitten

      RandomKitten Void-Bound Voyager

      Since updating to Update 1.3.24, farmhands can (finally!) use the stove with the fridge items, BUT they can make infinite numbers of the recipes for which you have stock in the fridge, without affecting the number of items in the fridge.

      If the farm owner uses the stove in the same way, it depletes items from the fridge correctly.
       
      • rainydaydance

        rainydaydance Intergalactic Tourist

        Okay, I asked my friend and he say's I did Mod the game when I changed the currency amount. I thought Mods were downloads only. I didn't realize any changes to the game was considered a Mod. I didn't think about it since I've been doing that since I started playing. I apologies. How do I send files on here?
         
        • Feathered Sparks

          Feathered Sparks Big Damn Hero

          I've been playing a multiplayer game for a little while now with my sister, whose character is now married to Harvey (mine hasn't gotten married yet). We've noticed a couple of odd behaviors with him which I don't see in the opening post or reported anywhere else in this thread:
          -Never leaves the farm, unless you count appearing in an event (I can still get heart events with him, though)
          -Often uses spouse dialogue when I talk to him, despite being married to a different player
          -Seems to use "specific day" dialogue only with me; for example, on the days he's supposed to go to the clinic he'll tell me he's going to work that day but tells my sister something different

          I'm not sure if these are general multiplayer bugs or specific to my sister being a farmhand (I'm the host). If these problems are still persisting once I get married in the game, I'll report back in with any similar issues or the lack thereof. I am married in another singleplayer save in the beta, and my spouse there is still behaving normally.
           
          • margotbean

            margotbean Scruffy Nerf-Herder

            There are semi-transparent dialogue bubbles over everyone's head at the Luau as well as the Stardew Valley Fair, during Lewis' (and the Governor's) dialogues and cutscenes. I've clicked, but they're not talking. ;)
             
            • Riguel

              Riguel Subatomic Cosmonaut

              Yep this is a bug. I get this too when my friend is playing too and I'm the host. She's married to Maru and Maru will give me the spouse dialogue and everything despite not being married to her.
               
              • 13odobson

                13odobson Space Hobo

                Unsure if this has been covered - it was an issue for me as of 13/07/18 - Difficulty initiating magnifying glass cutscene on Winter 1st. Attempted multiple times from 6 am - 8 am with default English language selected. Only initiated following a language change to Dutch (initiated immediately following the change at around 6:30 am). I then saved and reverted the language back once I had obtained the wallet item.
                 
                • IAmFrenk

                  IAmFrenk Space Hobo

                  Can't fish during the Festival of Ice minigame. Also, can't use the slingshot during the minigame on the Fair.
                   
                  • Skorm

                    Skorm Aquatic Astronaut

                    Consistent disconnecting for farmhand in multiplayer LAN within minutes
                     
                    • littlebigfish

                      littlebigfish Yeah, You!

                      My two brothers and I have a farm together, and there seems to be a glitch where more of the same item can be donated to the museum. So now we are stuck in regards to the museum as extra space has been taken by the duplicate items, as well as even touching one of these items to rearrange them in the museum freezes the game for the player doing it. Is there any word of a fix for this, or a we stuck with a broken museum? Is there a file somewhere that can be edited that will allow me to delete these extra items from the museum? Any other ideas?
                       
                      • kaguya_yoru

                        kaguya_yoru Intergalactic Tourist

                        I'm playing a single-player game in the v 1.3.24. There is a huge increase in the drop chance for prismatic shards - I got one within the first 2 minutes of entering the Skull Cavern - and the chance for monster waves - I got three waves back to back and ended up dying because I couldn't get to my food quickly enough in between attacks. I was watching a Twitch streamer play a single-player game in Stardew last night and she also found three Prismatic Shards in The Mines over the span of a few in-game days.

                        Also, I lost my Obsidian Edge when I died in Skull Cavern so I loaded the Master Slingshot with stone ammo. However, every time I opened or closed my inventory or opened or closed a chest, I would lose a stone from the total ammo loaded. I started off with 400 stones and ended up down to 395 without firing a single shot.
                         
                          Last edited: Jul 14, 2018
                        • sirsilica

                          sirsilica Star Wrangler

                          Not really a bug, per se (or maybe it is), but even in singleplayer, the floors in the mines don't immediately reset themselves. It takes an indeterminable amount of time (at least for me) before they finally do. Makes it pretty inconvenient for grinding for ores and monster kills.
                           
                            margotbean likes this.
                          • Pathoschild

                            Pathoschild Cosmos Killer

                            The witch farm event goes into an infinite loop and freezes the game (possibly only on the last night of winter). The attached save reproduces the issue — just go straight to bed after waking up, you'll hear the witch cackle, and the screen will stay black forever.

                            Other reports for reference:
                             

                              Attached Files:

                            • youra6

                              youra6 Intergalactic Tourist

                              Yep since .24 I've been experiencing the same issue.
                               
                              • Koihime Nakamura

                                Koihime Nakamura Ketchup Robot

                                That's not a bug. It's the result of a fix.
                                 
                                • Swiddow

                                  Swiddow Big Damn Hero

                                  Tried looking through the first page for this bug but didn't see it reported there.

                                  If two people try to mount the same horse at the same time it causes a critical failure of sorts. One person will mount the horse, and the other person will move to where the horse was and be stuck there. If the player actually on the horse leaves the map, the other player gets their own version of the horse but it faces the direction that the main person's horse is facing. This can cause a critical failure in two types of instances.

                                  1: Host player has a "corrupted" horse - Cannot dismount, cannot enter buildings, at 2:00 AM enters an infinite loop of falling asleep but doesn't actually move them to the house. Cannot open any menus. A force-quit of Alt+F4 had to be done.

                                  2: Farmhand player has a "corrupted" horse - Cannot dismount, cannot enter buildings, and when that player exited the following error happens and the game froze for other players who were connected -
                                  Code:
                                   The game failed unexpectedly: System.NullReferenceException: Object reference not set to an instance of an object.
                                     at StardewValley.Characters.Horse.dismount() in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\Characters\Horse.cs:line 300
                                     at StardewValley.Multiplayer.playerDisconnected(Int64 id) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\Network\Multiplayer.cs:line 542
                                     at StardewValley.Multiplayer.Disconnect() in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\Network\Multiplayer.cs:line 988
                                  I have some screenshot of the graphical glitches that happen but we managed to easily replicate the bug by trying to mount the same horse at the same time. (Just stand a little bit away from the horse or you can't click through the other player to mount.)
                                   
                                  • jbrianj

                                    jbrianj Void-Bound Voyager

                                    Can you attach the savefile this happens on? Save corruption bugs are easier to fix if devs have access to the corrupted savefile.

                                    Save files:
                                    • Windows: %appdata%\StardewValley\Saves
                                    • Linux and Mac: ~/.config/StardewValley/Saves
                                     
                                      Last edited: Jul 15, 2018
                                    • Swiddow

                                      Swiddow Big Damn Hero

                                      I can do that if needed, there's no savefile corruption because it causes the game to be in a state in which the night couldn't end, thus no saving. We had to crash the game and restart the day and it moved on perfectly fine if we just avoid trying to hop on the same horse at the same time.
                                       
                                      • syzygyquirks

                                        syzygyquirks Space Hobo

                                        Tried searching for this in the thread but couldn't find anything.

                                        I married my farmhand and we have 2 children (already fully grown). The Full House achievement never unlocked for me--is this intentional? Do I have to marry an NPC in order for the achievement to unlock?

                                        Also, is there any way to get the marriage stardrop when married to one's farmhand?
                                         
                                          Last edited: Jul 15, 2018
                                        • Hakuna Matata

                                          Hakuna Matata Orbital Explorer

                                          Single player, got the secret note #16 but could not get the statue when reaching the exact spot.
                                          I had played a previous single player game in beta, and did get it like a month ago or more.
                                          Did this break?
                                           
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page