Stardew Valley Multiplayer Beta: Known Issues & Fixes 2

Discussion in 'Support' started by Katzeus, Jun 4, 2018.

Thread Status:
Not open for further replies.
  1. Koihime Nakamura

    Koihime Nakamura Ketchup Robot

    They fixed one problem, but it looks really strongly like for the fishing event isn't properly hooking the fishing rod's functionality (the fishingrod::updatetick event *never* fires.) I can confirm this bug.
     
      Accidentalsuicide likes this.
    • Izuriel

      Izuriel Intergalactic Tourist

      Reporting some bugs, I tried to see if they were fixed or reported or patched, but with the keywords I searched, I couldn't quite find what matched. Anyways, I'm sure someone will read.

      Also this is my first ever post on the forums I think so please be nice. I really love this game. <3

      EDIT: I see some of these ARE listed in places. I'm not going to weed out all of them though. I'll enbolden the parts I think are important for easier reading.
      No mods
      3 players MAX on farm (including host) because I don't have friends. Never had more than 4 on a farm. Max multiplayer houses on farm is 2.
      I haven't messed with any files and I keep my game up to date all the time. I even think I saw one last night but I haven't checked yet.
      I don't have logs, I'll have to learn how to do that because I'm stupid. :p


      1. This happens ALL THE TIME WITH ME: If I hit a chest with a pick that has stuff in it, the chest will go into my inventory and I've lost EVERYTHING inside the chest. I've restarted so many days because I'm clumsy. My farmhands have done it. We have a "no pick rule" when you're at a box even. This doesn't ever happen on my single player files I have, new or old, I've tested it on several new and old files.


      2. In spring, year 2, at night, I placed a chest to the right of the door of the Fishmonger on the dock, it was gone by 9am the next day when I walked over there to sell the fish inside. I don't think it's in the way of an NPC or anything but it was completely gone.


      3. Farmhand sounds carry to host while in forest intermittently. This has happened during every season, every time of day: If I am in the forest that shares the area with Marnie and the Wizard, oftentimes I will hear all of the interaction noises of at least one other person as if I was the one performing the action. Sounds include all of the farming, harvesting, petting, milking, moos, quacks, bawks, oinks, shhk, chk, shhhh, of every tool. I've tried leaving the area, returning, sleeping, talking to NPCs, and restarting the server. Nothing stops it. But it IS somewhat intermittent (thank god!).


      4. Players cannot chat at the end of the day during payout/screen to discuss what to do before morning... Like when you go to sleep, no one can see each other's text. I've told my friends I was going to brb and I'd let them know when I was back. They went too, so we ended the day. When I got back, there was no way for me to communicate with my teammates that I WAS back. I don't know if this is a bug or if it's designed this way. If it is supposed to block chat on the payout screen between days (at the payout screen that shows your money breakdown), I think you should remove the option to chat in the text box.


      5. I have no idea why, but I have so many copies of tools on my first multiplayer file I regularly use (since stopped I think). I have like 4 of each tool... Not sure why, but I got a letter saying that my tools were found in the "lost and found" and had been returned to me. These are always the basic-level tools and I've never "lost" any of my tools, even with the pickaxe incidents above. (seriously, I've lost a ton of ore doing that on accident, though)


      6. The signs are too easy to change what they show. It's only a single click, I thought it was supposed to be a doubleclick? The signs aren't very useful if used to identify what's in a row of boxes stacked vertically or if you're doing something behind the signs. Probably not a bug.


      7. We had a forger that ran for like 2-3 seasons? We thought it might've been something good but it never shut off. Don't know if that one's been fixed because it only happened the once.

      8. Bombs can cause everyone to lag. Cherry bombs are safe but don't use more than two.

      9. We've only had one or two "random" crashes because we were both smashing big rocks and/or using bombs in the mines haphazardly.
      - We tested out what's safe and what isn't. We decided that a regular (black) or large (red) bomb can cause lag if another player can see it. But if two peoples set of regular/large bombs at once on two separate floors of the mines, it can cause the other person (not the host) to crash. We just don't use bombs around each other anymore and are careful about them in the mines. I don't have crash logs because I'm not savvy enough to get them. I'll learn how to do it, though.


      10. Farmhands have to wait 5-6 days to access Community Center to get the cutscene if they've started later in the year than other players. Seems weird, not sure if it's a bug or what. But my friend on one of my files started in Winter with my other buddy and I and he couldn't access the CC. And then he couldn't READ it. It's all fixed now (cutscene, mail, etc. worked for him) so maybe it's not a bug. Just weird.

      EDIT:

      11. Is it intended for the chutes to be random when a farmhand follows after a host or vice versa?

      EDIT2: PLEASE KEEP MULTIPLAYER LUCK DIFFERENCES! I am the only one that likes to farm, so everyone else fishes or mines and I'm so damn sick of doing all the harvesting every damn time. xD <3

      Thanks guys!

      - Izu
       
        Last edited: Jun 12, 2018
      • kittentamer

        kittentamer Phantasmal Quasar

        This page has maps of what are safe locations for chests: https://stardewvalleywiki.com/Worm_Bin
        It might not be 100% up to date, but still a really good resource for where you can place chests without them getting destroyed.

        Also, I have had the bug where I hit a full chest with a pick (was trying to pick up an empty chest next to it) and it let me pick up the full chest. Which was now empty. Needless to say, I restarted the day.:geek:
         
          Shenorai likes this.
        • Frundan

          Frundan Space Spelunker

          I want to confirm the bug with fishing treasure chests. Whenever the player gets the treasure, the moment the chest is opened a sound can be heard indicating something fell into the water, and if the avatar is positioned correctly you can even see something falling in. I've never noticed, since I'm playing a file that's in Year 3 and I have all the Stardrops, but whenever this happens the game treats it as if a fishing line was cast, and substracts the appropriate amount of energy from the player's energy bar.
          This is an issue that's been there since day one of the beta btw. I didn't report it, since I originally didn't notice the accompanying energy substraction and just assumed it was the treasure chest falling back into the water after it was opened.
           
          • temimi

            temimi Space Hobo

            My friend and I are getting a couple bugs or errors while playing multiplayer. First, when a Farmhand joins, on the first day after them joining, their spouse is stuck in their original bed (before getting married). For example, Abigail being the farmhand's spouse showing up in her room in Pierre's shop the day that said farmhand logs in. This fixes on the second day they're online but still weird.
            Secondly, we played a couple of days today and are now consistently getting crashes when we sleep on the night of Summer 2 Year 2. Here's the error report:
            Message: Object reference not set to an instance of an object.
            InnerException:
            Stack Trace: at StardewValley.Game1.Update(GameTime gameTime) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\Game1.cs:line 1832
            at Microsoft.Xna.Framework.Game.Tick()
            at Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
            at Microsoft.Xna.Framework.GameHost.OnIdle()
            at Microsoft.Xna.Framework.WindowsGameHost.RunOneFrame()
            at Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(Object sender, EventArgs e)
            at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
            at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
            at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
            at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
            at System.Windows.Forms.Application.Run(Form mainForm)
            at Microsoft.Xna.Framework.WindowsGameHost.Run()
            at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
            at StardewValley.Program.Main(String[] args) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\Program.cs:line 122

            We can't figure out why as the only thing we're doing is building a barn and tilling a few crops.
             
              Last edited: Jun 12, 2018
            • _Keru_

              _Keru_ The Court

              @Koihime Nakamura I would like to have your additions to the next 1.3.18 bug report.
               
              • Koihime Nakamura

                Koihime Nakamura Ketchup Robot

                Which addition?
                 
                • Havenowl26

                  Havenowl26 Space Hobo

                  Hi!

                  Normally, when something goes wrong in my game I tend to know what caused it.... However in this specific case I can't figure out what to do.

                  Now, I believe my problem began with the Fall Festival. In which, I tried to play the fishing game however, like many other players experience, I was unable to. Due to this, I tried switching my game back into the normal mode so I could continue game play as normal. (I also knew that were was an issue of Year 2 Fall 27th repeating itself over and over again). I made a save file for the beta (the game I was playing is pre-beta) I made a save file, and switched the game back to normal. As I tried to continue, I find myself not beign able to acess any of my save files (even the backed up one). When I open the "load game" screen, my characters pants and hair are missing, it says I have 500 gold and 0 time invested. When I click on the file, my game immedietly crashes. Doesn't freeze or anything, just crashes. So, I switched back to beta in hopes I would get all of my data back. Which, it did. Everything went back to normal. However, I can no longer go back to SV playing in the normal mode without my files being messed up. I have no idea what to do, and whether or not it was something I did or didn't do.

                  Any help or advice would be greatly appreciated.... Thank you!
                   
                  • Trixie9819

                    Trixie9819 Void-Bound Voyager

                    Fishing treasure chest stealing energy bug is still here is 1.3.18, it really makes it hard when you have the pirate skill.
                     
                      Andunelen likes this.
                    • Riguel

                      Riguel Subatomic Cosmonaut

                      Animation bugs are still in 1.3.18, host can see the animations, farmhands cannot. Spouse kissing animation still doesn't work if farmhand connects in multiplayer.

                      Also spouses are parking themselves in the area outside the house at the same time. This causes things to look weird and especially if Shane's chicken coop is there. I would suggest possibly adding 3 other areas like this so each farmhand spouse goes to their own separate one.

                      [​IMG]
                       
                        Last edited: Jun 13, 2018
                      • WolfWhisper

                        WolfWhisper Space Hobo

                        Hi, I'm not sure if these issues below have been posted before, but let me share it:

                        1st Year, currently starting Winter

                        1. When you go mining alone and destroying chests in the mine, it will be destroyed twice and thus makes you got double the stuffs inside. For me, it happens all the time, it's a good thing because we got more stuff, but it doesn't feel right.
                        2. I am a friend who joined my friend's farm but everytime i buy a recipe, it's not recorded on my craft list. The first time, I bought wedding ring recipe from travelling merchant, and the second i bought the Jack O'lantern recipe. I asked my friend to buy it and it's on his list. It only happens to the "guest player". That means I can't get recipe by buying?
                        3. Still related to recipe, after reaching Marnie's lvl 3 heart, she sent me Pale Broth recipe on the mailbox, but there're only texts and no recipe, which means i also don't get the recipe on my cooking list.
                        4. In winter, the farm and other areas are winter themed, but the town is still in spring. It only happens to me as a guest player, the host doesn't experience this.
                        5. Sometimes, when i woke up from the bed, i can suddenly get tools like: pickaxe, scythe, so i now have like 3 pickaxes and i don't know how to delete them.
                        6. On the Stardew Valley Fair, my friend who hosts the game was in the fishing mini game when the Mayor Lewis said he has done inspecting the grange display, my friend can't close that message box and we need to reset the game.

                        Questions:
                        1. Does the welwick's info on tv different for each player? When on my side it's a very good day, my friend said his is bad day.
                        2. The event of a fairy blessing a crop, my friend and me see the fairy blesses different crop.
                        3. When I reached Marnie's room to get Mayor Lewis's short, I can take two of them... which means even when my friend can't enter the room yet, i can give it to him to give Mayor Lewis.

                        Please let me know if my report is useful or not. And I LOVE STARDEW VALLEY! <3<3<3
                         
                        • Andunelen

                          Andunelen Astral Cartographer

                          SMALL COSMETIC ISSUES:

                          Skull Cavern Chest Prizes

                          Blue and Red Cowboy Hats are the only items that won't appear above the character.
                          [​IMG]

                          2 Audio Glitches
                          1. When loading saved file (black screen with "loading..."), the "lighting fireplace" sound plays.
                          2. When fishing and getting a treasure chest, the "tackle hitting the water" sound plays while you're seeing content of chest.
                           
                            Last edited: Jun 13, 2018
                          • uselessdragonfly

                            uselessdragonfly Title Not Found

                            Crash in the skull cavern.
                            Has happened a few times now, all the error logs look to be the same with hitting the rock crab with a tool. The days were 6/9 and 6/10 that we last tried going into the skull cavern.
                             

                              Attached Files:

                            • Aeri_

                              Aeri_ Master Chief

                              My partner can't host correctly, it only gives them the option to host/join LAN games.
                               
                              • Zifeara

                                Zifeara Yeah, You!

                                With the new update 1.3.18, I'm still having a couple of problems. There are 3 of us total and I am the host.
                                1) Two of us could do the fishing minigame at the Fall Fair, 3rd player froze and had to exit the game.
                                2) Cactus seeds, even those bought from Sandy cannot be planted. I have no mods that would effect crops in any way shape or form.
                                3) Barrels do not seem to spawn correctly in the mines. In the areas of wooden floor, the barrels aren't visible but if I swing my sword in the area, the flying wood animation still happens exactly as it does when you break a barrel. No sound play and I don't gain anything from it. The barrels didn't have this issue in the skull cavern.
                                4) I think the luck is either displaying vastly incorrectly or it really is just a crap shoot every time. Most of the time, if I'm supposed to have a good or great luck day, I don't, sometimes on bad luck days I've found 3 diamonds not to mention what drops from mobs ¯\_(ツ)_/¯
                                5) One player's watering can completely went missing. We woke up one morning to find the tool gone. It was a steel can, she hadn't given it to Clint, and now we only have 2 cans between the 3 of us. That's fine, I don't grow things, but we have no clue where the 3rd can went.
                                 
                                • Zeravania

                                  Zeravania Void-Bound Voyager

                                  My kid and I have been playing since the first Beta, both running vanilla with no mods. She has completed a bundle in the Community Centre, we have gone to bed for the night (then exited the game). I came back to play the game later, and got the cutscene at the community cente. She has joined my game after the cutscene has triggered for me, but on the same day (in game), and did not get any cutscene. The community centre is restored for both of us, but Pierre's is still closed on Wednesdays for her and she still has the "community centre bundles" option accessible from her inventory. It shows that all bundles have been completed but says that there is one reward still pending. She cannot claim this reward.

                                  I am aware that there is a glitch around the trophies but wasn't sure if this was the glitch that is causing her to miss out on that trophy.

                                  Thanks :)
                                   
                                  • tep1

                                    tep1 Space Hobo

                                    My audio level is at the lowest hearing possible but whenever I join multiplayer, i always have to readjust the volumes as they sound louder than the volume I've put it to
                                     
                                    • Frundan

                                      Frundan Space Spelunker

                                      Would like to confirm this, my boyfriend has the exact same problem.
                                       
                                      • Akinatsu

                                        Akinatsu Intergalactic Tourist

                                        Jukebox in the saloon only contains two tracks.
                                         
                                        • Blorp

                                          Blorp Big Damn Hero

                                          @Katzeus I think I've found the cause of the chest problem, where trying to hit an empty chest with a tool may cause a non-empty chest to drop with contents being lost, or fixed non-chest objects (e.g. hopper) dropping as a chest.
                                          In Chest.performToolAction: Vector2 toolLocation = lastFarmerToUse.GetToolLocation(false)
                                          This should work, but, presumably because of the mutex, who.lastClick = Vector2.Zero in Farmer.useTool is hit between performToolAction starting and the location check, meaning it destroys the item in the wrong position. A possible fix could involve using "this" rather than GetToolLocation, or resetting that lastClick at a different point, or passing the correct location another way.
                                          While you're looking at that, performRemoveAction(tileLocation, location); seems useless, as the constructor that gets called for these chests doesn't set tileLocation, which remains as {0,0}, which may cause problems elsewhere too.
                                          I've also found at least part of the problem with the fishing minigame lockups, here.
                                          I hope this helps.

                                          Edit: Slime hutch was similar, but only as far as it gets too many updates. One is through the loop of building indoors locations in Game1.UpdateLocation, but this also calls Farm.updateEvenIfFarmerIsntHere => BuildableGameLocation.updateEvenIfFarmerIsntHere, which loops through building exteriors and updates them, updating the interiors too. If I had to guess, I'd say this second, farm-specific loop was unnecessary if locations and their buildings are already scanned.
                                          I also noticed that Monster.update has a if (!location.farmers.Any<Farmer>()) { return; } before it gets to behaviorAtGameTick, which I think means slimes will never mate (or move) unless someone is watching, which seems strange.
                                           
                                            Last edited: Jun 13, 2018
                                            Koihime Nakamura likes this.
                                          Thread Status:
                                          Not open for further replies.

                                          Share This Page