Stardew Valley Multiplayer Beta: Known Issues & Fixes 2

Discussion in 'Support' started by Katzeus, Jun 4, 2018.

  1. Dekan

    Dekan Intergalactic Tourist

    After going to Jodi cutscene about a dinner with her family, my game crashed in co-op.
     

      Attached Files:

    • leahh

      leahh Space Hobo

      In the Spring of Year 2, after I built a Slime Hutch, the cut scene that triggers as soon as you leave the house causes a crash. As soon as the Adventurer's Club guy starts to speak, a super large dialogue box shows up but without words or an NPC picture, and then the whole game crashes. I tried deleting and re-uploading the beta, loading the game from the main menu as well as the co-op menu, and it's done exactly the same thing and crashed 7 times. Can't continue on because the cut scene happens leaving the house. Version 1.3.17.

      Error log (they all appear to be exactly the same so just pasting one):
      Message: Index was outside the bounds of the array.
      InnerException:
      Stack Trace: at StardewValley.NPC.translateName (System.String name) <0x1823ee0a0 + 0x000d2> in <filename unknown>:0
      at StardewValley.Character.get_displayName () <0x1823edff0 + 0x0004c> in <filename unknown>:0
      at StardewValley.NPC.getName () <0x188cecba0 + 0x00017> in <filename unknown>:0
      at StardewValley.Menus.DialogueBox.drawPortrait (Microsoft.Xna.Framework.Graphics.SpriteBatch b) <0x188ceb6e0 + 0x00b91> in <filename unknown>:0
      at StardewValley.Menus.DialogueBox.draw (Microsoft.Xna.Framework.Graphics.SpriteBatch b) <0x18738a490 + 0x00677> in <filename unknown>:0
      at StardewValley.Game1.Draw (Microsoft.Xna.Framework.GameTime gameTime) <0x16c9f8000 + 0x0bfd7> in <filename unknown>:0
      at Microsoft.Xna.Framework.Game.DoDraw (Microsoft.Xna.Framework.GameTime gameTime) <0x16bbf9aa0 + 0x00065> in <filename unknown>:0
      at Microsoft.Xna.Framework.Game.Tick () <0x16bbf3c20 + 0x005b9> in <filename unknown>:0
      at Microsoft.Xna.Framework.SdlGamePlatform.RunLoop () <0x16bbf07d0 + 0x00059> in <filename unknown>:0
      at Microsoft.Xna.Framework.Game.Run (GameRunBehavior runBehavior) <0x119633010 + 0x0020b> in <filename unknown>:0
      at Microsoft.Xna.Framework.Game.Run () <0x119632fa0 + 0x0002d> in <filename unknown>:0
      at StardewValley.Program.Main (System.String[] args) <0x113683fb0 + 0x000f8> in <filename unknown>:0
       
        Last edited: Jun 12, 2018
      • falathis

        falathis Space Hobo

        Game crashed when talking to Marlen at the spirit festival on the host computer. This also happened a bit ago and we were not 100% sure what it was but it was also talking to Marlen but at the grange festival but it was not on the host computer. At the previous crash the game kept running on the host but farm hand was disconnected. We both remember talking to him during the first years festivals and there was no issue. Here is the crash log. If you need the save file let me know. It seems he crashes whoever talks to him now. But only crashes at festivals.

        Message: Index was outside the bounds of the array.
        InnerException:
        Stack Trace: at StardewValley.NPC.translateName(String name) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\NPC.cs:line 444
        at StardewValley.Character.get_displayName() in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\Character.cs:line 78
        at StardewValley.NPC.getName() in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\NPC.cs:line 483
        at StardewValley.Menus.DialogueBox.drawPortrait(SpriteBatch b) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\Menus\DialogueBox.cs:line 676
        at StardewValley.Menus.DialogueBox.draw(SpriteBatch b) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\Menus\DialogueBox.cs:line 881
        at StardewValley.Game1.Draw(GameTime gameTime) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\Game1.cs:line 11402
        at Microsoft.Xna.Framework.Game.DrawFrame()
        at Microsoft.Xna.Framework.Game.Tick()
        at Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
        at Microsoft.Xna.Framework.GameHost.OnIdle()
        at Microsoft.Xna.Framework.WindowsGameHost.RunOneFrame()
        at Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(Object sender, EventArgs e)
        at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
        at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
        at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
        at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
        at System.Windows.Forms.Application.Run(Form mainForm)
        at Microsoft.Xna.Framework.WindowsGameHost.Run()
        at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
        at StardewValley.Program.Main(String[] args) in C:\Users\gitlab-runner\gitlab-runner\builds\5c0f9387\0\chucklefish\stardewvalley\Farmer\Farmer\Program.cs:line 122




        Not sure if I need to make a new post but a possible issue is coming up. We have a baby that is in its first 14 day stage (perma sleep) but got the dialog to have a baby and both clicked yes without thinking. Don't remember if you could before multiplayer but if there is already a baby in the crib where does the new baby go? It may already have a solution for it but don't remember getting an option for another baby that soon.
         
        • Primavera

          Primavera Space Hobo

          Thanks! When will the patch come out?
           
          • GreyWays

            GreyWays Space Hobo

            Simply adding my report concerning the Marlon bug since I think there was mention of trying to find out whether or not it has to do with mods or not. I intend to use Mizzion's fix (thank you so much for making it!) soon and send information on it to those I play with.
            I apologise for not having error logs to upload, as even using the Win+R process to find %appdata%\StardewValley\ErrorLogs isn't working, all I can find is a saves folder and the default steam folder.

            Anyway.

            The bug:
            Speaking with Marlon causes the game to crash.
            We discovered this by way of the mine cutscene. I managed to avoid the situation by pressing 'skip' before the dialogue box came up.
            This happens both in solo and multiplayer mode.
            Neither of us is running any mods, my partner (the host) has SMAPI turned off and I have yet to install any mods.
            Both parties are using steam to connect.

            Thank you for your time.


            Edit: I apparently should have checked the most recent posts before posting this. I apologise if I have wasted anyone's time! And my thanks to the crew working on the fix.
             
            • Katzeus

              Katzeus Community Manager Chucklefish

              Update 1.3.18 is available now!
              • (Fixed) Active players can cancel new player creation for farmhands
              • (Fixed) Mouseover hover missing for buffs
              • (Fixed) Horse footsteps using wrong sounds
              • (Fixed) Crash whenever Marlon's name is used
              • (Fixed) NPCs end of route animation playing at double speed for clients
              • (Fixed) NPC positions not syncing at end of route animations (multiple NPCs)
              • (Fixed) Extra tools spawning overnight if another player has them
              • (Fixed) Gift giving not properly resetting after upgrading from 1.2 to 1.3
              • (Fixed) Mistranslated pt-br seed disc saying to plant in winter
              • (Fixed) Spa sign in English while playing in Chinese
              • (Fixed) Proposals cannot be canceled
              • (Fixed) Fishing rod event not triggering for farmhand
              • (Fixed) Machines producing 'empty' products
               
                corana likes this.
              • One More Day

                One More Day Aquatic Astronaut

                Just got the update to 1.3.18

                Just confirmed that the scene with Marlon introducing you to the mines is working properly now

                OTOH, since the 1.3.18 update, I'm trying to loot the trashcans and there's no apparent indicator that an attempt was even made. The sound doesn't play.
                 
                  Last edited by a moderator: Jun 12, 2018
                  Katzeus likes this.
                • Iris Blanche

                  Iris Blanche Manifestation Forum Moderator

                  Please avoid doubleposts. i merged 'em.
                   
                    _Keru_ and Katzeus like this.
                  • One More Day

                    One More Day Aquatic Astronaut

                    Yeah, you know what? Sometimes there's actually a reason why people post consecutively in a thread, and it doesn't always need a ham-fisted moderator to squash them together

                    Like, perhaps it's in a really important thread, for reporting bugs in a beta version, and you know that the one person you really want to see your new post has already seen your previous post, and therefore might not notice that it has been edited to include a single extra line, but it's really important that they do see it, because you want to report a potential new bug.

                    You don't always have to be so anal about merging consecutive posts, when your modding time could be better spent editing items that actually need moderator attention. Like the douche (whose name escapes me at the moment) who posted something blatantly homophobic in the farm name thread, and it sat there for days instead of being deleted. Or that tholfikar idiot who kept starting a new thread every day asking when 1.3 was coming out, and you somehow didn't ban him after he'd done it ten times.

                    Mod better IMO


                    Now, if you don't mind, I'd like to report a potential bug, if that's OK, and I would very much like it to have its own post, so that it is less likely to get missed
                     
                    • D.M.G.

                      D.M.G. Black Hole Surfer

                      I'm sorry my good sir, but you are the utter anal person here. Iris Blanche here is doing their job, and one can't do alone the task of several people.
                      So please make your words more useful than that.
                       
                        corana, _Keru_ and chroniz like this.
                      • Frundan

                        Frundan Tentacle Wrangler

                        While I definitely agree with your sentiment, your style comes across as rather provocative. I think you should tone it down a notch, since you're giving grounds for the mods to come after you for insulting them needlessly.
                         
                        • Katzeus

                          Katzeus Community Manager Chucklefish

                          If you can't follow the forum rules while you're reporting here then you're going to be moderated. If you attack moderators doing their job you'll be banned - permanently.

                          I appreciate that you're reporting issues - but behaving like this won't be tolerated.
                           
                            _Keru_, margotbean and Code_Monkey like this.
                          • squeakyferret

                            squeakyferret Void-Bound Voyager

                            Sure, it does - I'm not saying we're prevented from playing. But the fact that the other options aren't working suggests there's still a bug, right? I mean, at some point, I'd like the option to play co-op with someone remotely.
                             
                            • DanmakuGrazer

                              DanmakuGrazer Void-Bound Voyager

                            • DogeDoggo

                              DogeDoggo Space Hobo

                              Updated this morning, still find myself unable to use the shafts/holes in the desert mines. Takes a minute before it loads the level, then loads the entire level in frozen - usually crashes the game which makes it really hard to use the mines in the desert properly. Also the farmhand (is that the name for people that join your game?) can not see when a dungeon level turns "purple" when a bunch of monsters start swooping in.

                              Another save file and 2 crash logs from today. (I'm not sure what happened the first time, it crashed after I invited my friend.)
                               

                                Attached Files:

                              • Kaydia

                                Kaydia Poptop Tamer

                                Hey, everyone. The game crashed when I clicked "ok" at the end of character creation. There's, obviously, no save game to attach, but here are the error logs. I had decided to skip the intro this time. I am running the base game, no mods other than cosmetic replacements for the barn, chicken coop, stable, and horse. I tried it twice just to make sure it wasn't a one time glitch. I have the latest version.

                                Thanks!

                                *Edit 1: To clarify, this was in single player.*

                                *Edit 2: The came also crashed while attempting to load in an existing character (Ian)*
                                 

                                  Attached Files:

                                  Last edited: Jun 12, 2018
                                • l.vang

                                  l.vang Poptop Tamer

                                  During the hoe and water can animations, my character just stay in one position instead of doing the full animation (not swinging the hoe, not pouring the can).
                                  Also the farm owner can't see what the farm hands have donated to the museum, and the farmhands can't see what the farm owner has donated.
                                   
                                  • Koihime Nakamura

                                    Koihime Nakamura Ketchup Robot

                                    You didn't fix the underlying issue, which is that the field in NetWorldState suffers from implicit conversion. Again. And the fix you posted forgets that, so it'll not actually be fixed.
                                     
                                    • Pathoschild

                                      Pathoschild Oxygen Tank

                                      Here's a summary of bug fixes requested by modders which still apply in 1.3.18.

                                      Wedding ring bug
                                      • Summary: after buying the wedding ring recipe from the Traveling Cart, it doesn't appear in the player's crafting list.

                                      • Cause: Game1.craftingRecipes is set to "Data//CraftingRecipes", then Stats loads "Data\\CraftingRecipes" and removes the wedding ring. Both refer to the same asset, so this removes the wedding ring from Game1.craftingRecipes too. That doesn't cause issues in the base game because it doesn't normalise asset names (SMAPI does), so there are two copies of the data.

                                      • Proposed quick fix: change Stats.checkForCraftingAchievements from this:
                                        Code:
                                        Dictionary<string, string> dictionary = Game1.content.Load<Dictionary<string, string>>("Data\\CraftingRecipes");
                                        
                                        To this:
                                        Code:
                                        Dictionary<string, string> dictionary = new Dictionary<string, string>(Game1.content.Load<Dictionary<string, string>>("Data\\CraftingRecipes"));
                                        
                                      • Proposed better fix: instead of removing the wedding ring from the data, ignore it when counting stats by adding an if check in the loop and subtracting one from recipes.Count in Stats.checkForCraftingAchievements:
                                        Code:
                                        Dictionary<string, string> dictionary = Game1.content.Load<Dictionary<string, string>>("Data\\CraftingRecipes");
                                        int craftedRecipes = 0;
                                        int knownRecipes = 0;
                                        foreach (string key in dictionary.Keys)
                                        {
                                           if (key == "Wedding Ring")
                                              continue;
                                        
                                           if (Game1.player.craftingRecipes.ContainsKey(key))
                                           {
                                              knownRecipes += Game1.player.craftingRecipes[key];
                                              if (Game1.player.craftingRecipes[key] > 0)
                                                 ++craftedRecipes;
                                           }
                                        }
                                        this.itemsCrafted = (uint)knownRecipes;
                                        if (craftedRecipes >= (recipes.Count - 1))
                                           Game1.getAchievement(22);
                                        
                                        // ...
                                        

                                      Deepest mine level bug

                                      • Summary: the player's 'deepest mine level' value isn't updated until they go deeper than any other player. This affects some vanilla quests and geode rewards.

                                      • Cause: the game only updates the player's lowest mine level reached when they go deeper than any other player; it should check that player's lowest mine level instead.

                                      • Proposed fix: change MineShaft.loadLevel from this:
                                        Code:
                                        if (level > MineShaft.lowestLevelReached)
                                        {
                                           MineShaft.lowestLevelReached = level;
                                           Game1.player.deepestMineLevel = level;
                                        }
                                        
                                        To this:
                                        Code:
                                        if (level > MineShaft.lowestLevelReached)
                                           MineShaft.lowestLevelReached = level;
                                        if (level > Game1.player.deepestMineLevel)
                                          Game1.player.deepestMineLevel = level;
                                        

                                      Custom seasonal map tilesheet bug
                                      • Summary: if a map uses a custom seasonal tilesheet, the asset reference is broken when seasonal logic is applied.

                                      • Cause: the seasonal logic replaces the tilesheet path with Maps/. This breaks map tilesheets added by SMAPI mods, which use a special asset path. Here's how the game seasonalises an example mod asset:
                                        Code:
                                        SMAPI\meevers.whitewaterfarm\assets\spring_extrasTileSheet.png
                                        => Maps\summer_extrasTileSheet.png
                                        

                                      • Proposed fix: change GameLocation.updateSeasonalTileSheets to keep the asset path, and only seasonalise the filename. This has no effect for vanilla assets, but avoids breaking mod assets.

                                        From this in GameLocation:
                                        Code:
                                        public void updateSeasonalTileSheets()
                                        {
                                           if (!this.IsOutdoors || this.Name.Equals("Desert"))
                                              return;
                                           for (int index = 0; index < this.Map.TileSheets.Count; ++index)
                                           {
                                              string imageSource = this.Map.TileSheets[index].ImageSource;
                                              if (imageSource.Contains("spring_") || imageSource.Contains("summer_") || (imageSource.Contains("fall_") || imageSource.Contains("winter_")))
                                              {
                                                 this.Map.TileSheets[index].ImageSource = "Maps\\" + Game1.currentSeason + "_" + this.Map.TileSheets[index].ImageSource.Split('_')[1];
                                                 this.Map.DisposeTileSheets(Game1.mapDisplayDevice);
                                                 this.Map.LoadTileSheets(Game1.mapDisplayDevice);
                                              }
                                           }
                                        }
                                        
                                        To this:
                                        Code:
                                        public void updateSeasonalTileSheets()
                                        {
                                           if (!this.IsOutdoors || this.Name.Equals("Desert"))
                                              return;
                                           for (int index = 0; index < this.Map.TileSheets.Count; ++index)
                                           {
                                              string imageSource = this.Map.TileSheets[index].ImageSource;
                                              string imageFile = Path.GetFileName(imageSource);
                                              if (imageFile.StartsWith("spring_") || imageFile.StartsWith("summer_") || imageFile.StartsWith("fall_") || imageFile.StartsWith("winter_"))
                                              {
                                                 string imageDir = Path.GetDirectoryName(imageSource);
                                                 if (string.IsNullOrWhiteSpace(imageDir))
                                                    imageDir = "Maps";
                                                 this.Map.TileSheets[index].ImageSource = Path.Combine(imageDir, Game1.currentSeason + "_" + imageFile.Split(new[] { '_' }, 2)[1]);
                                              }
                                           }
                                        }
                                        
                                       
                                        margotbean, Katzeus, Bifibi and 3 others like this.
                                      • Accidentalsuicide

                                        Accidentalsuicide Intergalactic Tourist

                                        The Fishing minigame in the Stardew Valley fair STILL doesn't work. (the second it begins, the character is frozen in place, and if you try to cast your line, the game freezes and has to be forcibly closed from the desktop. Because the game doesn't crash, there is no error file to attach)

                                        Supposedly this error was fixed three updates ago. Is this an error only occuring in saves that were made prior to the beta? (This save is a pre-beta one. I will try and replicate on a new save.)
                                         

                                          Attached Files:

                                          Last edited: Jun 12, 2018

                                        Share This Page